Question

I'm DONE with Tmobile Home Internet

  • 10 May 2021
  • 9 replies
  • 401 views

Userlevel 2
Badge +1

Issue: Does not work with GlobalProtect VPN. My company just changed to this. Also tried a 5.2 version of GlobalProtect. NG.

Called TMO support on Friday and requested to push the 168 firmware. Support needed to submit a ticket to engineering for that. Gave them until today. No update.

Factory Reset two times to see if my gateway would update from 143 to 168. It would not.

Called and canceled and went back to Xfinity. At least I was able to get the intro rate.

I really wanted TMO Home Internet to work, but so tired of the lack of real support, not using 5G, and no access to typical router settings.

Maybe in a year when my intro rate is over, TMO will have gotten their stuff together

Best to all.


9 replies

Badge

I would have at least waited for the .078 firmware update which we will all get within 30 days.

Userlevel 2
Badge +1

@Den_in_USA  Wait? Like I said, no VPN to my office with GlobalProtect. I’m WFH.

I explained the issue to support, they said GlobalProtect was a known problem, and I asked for them to push the update. Nothing.  I had no choice.

Userlevel 6
Badge +14

@MetsFan , our Tech Care team may need to file a Trouble Ticket for you. If you haven’t spoken with them recently, I’d reach out again and give them another shot at this.

Userlevel 2
Badge +1

@tmo_mike_c : Please see support ticket # 53400948 that I placed on May 7 asking them to push the .168 update to me. Was told they would open a ticket with engineering. Crickets since then, and I need VPN so I can work from home! How is something like that not escalated right away? And not just for me, but for all the others in this forum who have had GlobalProtect VPN issues over the last 6 months. My company went from Aruba VIA VPN which worked fine, to GlobalProtect which did not. I had no choice.

But, all of this is irrelevant as I sent my gateway back to Tmobile today. Maybe in a year when my intro rate with my new ISP is over I’ll look at TMO again. There has to be big changes though. The lack of router configurations and proper VPN support will be a show stopper.

Best to all.

 

Userlevel 4
Badge +3

 

Should have never left beta stage without confirming VPN passthrough worked properly.

 

With all the security concerns of the world today, that is a "must have" feature they should have fixed.

 

And it isn't like they were not aware of this concern... I joined while it was still in that "beta" phase, and the issue was regularly posted, as well as the streaming and console issues.

 

Should have never gone "public" without resolving such issues.

My company is switching to Global Protect also!  T-Mobile LISTEN UP!!

Badge

@djb14336 You're exactly right. An unnecessary PR nightmare because it was rushed. Why company’s continue to do this is beyond me. 

Hey FYI, my grey trash can with 178 works fine with Anyconnect and Global Protect.  It doesn’t even lose settings when unplugged like people said.  I was pleasantly surprised!

Badge

@djb14336 You're exactly right. An unnecessary PR nightmare because it was rushed. Why company’s continue to do this is beyond me. 

yes.

Hey FYI, my grey trash can with 178 works fine with Anyconnect and Global Protect.  It doesn’t even lose settings when unplugged like people said.  I was pleasantly surprised!

I think this is only an issue when you power cycle with the button. 

Anyway, I have a unit that’s only a couple weeks old and came with the latest “Fixit Firmware” for VPN. However, Teradici PCoIP won’t connect. If I could figure out how to manually configure MTU on my Chromebook, I think that’s all it would take to set straight. Googlefu has been unhelpful. 

Reply