NAT (Forwarding) in T-Mobile Gateway

  • 9 December 2021
  • 34 replies
  • 24165 views

Userlevel 1
Badge

I recently signed up for T-Mobile internet, and I am VERY disappointed that I could not even forward NAT traffic to my home security system.   I saw that this was discussed 7 months ago in a previous thread, and hope the developers will notice this.  The speed is great, and the same as was advertised in the chat.

I would like this issue to be resolved so that I don’t need to continue with Optimum (Morris Broadband).


34 replies

I spoke with TMobile Home Internet technical support over the past week. They are working on the port forwarding feature within their 5g modem/router, but it's not available or ready yet. 

2 different techs said they have a workaround, however (& it doesn't require 3rd party services).

I haven't tested it yet, but what you need to do is, & many of us have this setup already, connect via Ethernet (wire) the garbage can LAN port <-> YOUR own router.  Then configure port forwarding on YOUR router. That's it. (Your router needs to support ipv6! Not sure if we need to allow ipv6 passthrough for this.)

Now, I was educated a long time ago on IPv4 & they barely touched on IPv6, so I don't know a lot about it, but this would never work this way with IPv6. Ipv6, however can allow passthrough so public "internet" can pass through a router, which is why I'm "buying" this theory.  Ie, you can go through T-Mobiles garbage can, and then your router, and you device (call it a PC) could have a public IPv6 IP, which is why port forwarding could work this way.

Anyone have time to test & report back? Or comments?

I previously had a dynamic public IP (ipv4) that I made work with my domain name via ZoneEdit that allowed my PC to update ZoneEdit with public Ip changes since it was dynamic. With this NEW setup, I'm not exactly sure how that would work, or if my DNS service will play nicely or even support ipv6 or if ZoneEdit will either. And I have numerous services that I need to "hit" MY router & forward internally, such as a VPN, RDP, FTP, website, etc - not sure if all that will play nicely - or if all the services, like VPN client, can point to a domain->ipv6 ip & work. Like will the VPN client config & SW accept this new format?

Anyways, lot of testing & messing around needed!  Please report back with any updates!

​​​​

Badge

T-Mobile Home Internet uses CG-Nat - which means end users share IP addresses. Unless they move away from that (which they will not since it would require completely new infrastructure) you will not be able to do port forwarding. There simply is no way to identify YOUR unique address since you do not have one - it is shared. 

However, there is a solution which does work - I am using it. Paketriot https://packetriot.com/ allows tunnels to be created which will have a unique endpoint which will then allow you to hit a port in YOUR internal network. There are other providers like Packetriot. I like Packetriot because it has the option to create a Windoze Service for all your tunnels. Nice when the machine reboots because you can have the service autostart. Most of the providers offer a free tunnel so you can try it out.

They should not call this Home Internet it is really a home hotspot.

Userlevel 1
Badge

I’m fairly confident that this device (Nokia) is able to handle all of these things.  I think what has happened here is T-Mobile threw a very locked down firmware on the device to make setup easy.

 

The following things need to happen.

Provide settings to place the gateway in bridge mode.  This will allow customers to keep their existing setups and NAT fine.

Provide settings to turn off the wifi in the gateway COMPLETELY.  Turning off broadcast and reducing power to minimal is not sufficient.

Make all of these settings accessible only through the web admin page.  The average consumer doesn’t need this stuff, but the power user who is smart enough to know how to login to the admin web page should be able to modify these settings.

 

Ultimately, I just want “a dumb modem” just like I get with the cable co.  I don’t want or need T-Mobile helping me by dumbing down the device.

Userlevel 5
Badge +5

They need to fix their screwy xlat464/cgnat style network first.

As long as they continue to filter that unsolicited inbound traffic at the higher network layers, won't matter what options are available/configured on our local modems/routers.  It is actually getting nixed at the outer edges of the networks, so it never makes it to the modem, much less the router.

I agree TMobile could have made this much easier by providing an internet facing IP address, as well as IP scope control and other things. But there are easy ways to get your setup working if you have another router.

To start, just have another router and connect either of the yellow ports of the TMobile gateway connected to the internet port (WAN) of your router. Now you have complete control over your internal network with DHCP, Scope, Static IPs if you want, Firewall rules for the internet, etc.

The next thing is to use something like the free version of TeamViewer, which will create the path through the internet to your computer for remote access and you can remote into your computer from outside the network whenever you want.

For security system viewing, just setup the viewing app on your home computer (which you probably already have) and remote into your computer and view your cameras that way. TeamViewer has a version for Windows computers, phones, tablets, Linux, MacOS, Raspberry Pi. So pretty much any device you have.

I know this is a workaround for T-Mobile's lack of services on the gateway, but it works great, it’s reliable, it’s a free solution, and restores functions many people need. It’s also only takes a couple of minutes to setup. I use it all the time and I have no issues. I’m sure you could do this with other remote services that are available, but I prefer TeamViewer over many of the non-trusted remote services available.

Good Luck

The problem with that is we are out of IPV4 IP addresses. We have been out for a while now. The world seems to be incredibly slow at adapting to IPV6. I’m sure between costs for the ISPs and the ancient devices out there that have never or will ever be updated for IPV6 is also an issue. Now an easier solution would be for T-Mobile to just give us a usable IPV6 address as many of our modern devices will be able to use that. 

Hello Everyone.

If anyone needs to port forward for a DVR security camera system. Forget it.

However, if your DVR has a Cloud P2P option, it will work.

I have a HikVision DVR and I successfully connected my phone with their Cloud P2P.

 

I would imagine that any DVR that uses a Cloud P2P service will work because it bypasses the need to Port Forward.

Hope this helped someone.

Good Luck!

Userlevel 3
Badge +2

The port forwarding is a huge issue around here. Others have said it involves IPv6 and so forwarding can’t be done. They can explain why.

Some suggestions have been VPN, ZeroTier or Tailscale. I’ve seen PFSense mentioned here too but can’t figure out how a firewall downstream from the can can port forward. 

After 8 very good months of fast, reliable service here in Tampa I'm about to cancel. I need to open one simple port to allow some services and TMO Home Internet can’t seem to do it and I’m not spending hours trying to figure out some sort of work around. 

Calling Frontier Fiber in the morning got 1GB fiber fir $69 or maybe 2GB Fiber for $150… either way I’m done w/ TMO. Kind of sux because otherwise it worked will.

 

J

I can't use noip with t-mobile because it doesn't support it, but if it was just bridging I could.

 

I'm not willing to wait around for another device when the speeds I get right now are just fine and the device I have is capable of the functions I need.

Sorry, you’re incorrect.  You can setup NOIP on other devices other than just your modem.  I set it up on my local server.  But, this doesn’t work as T-Mobile doesn’t assign you a unique IP address (it’s shared with hundreds/thousands of other people).  So even if you setup NOIP, that doesn’t help one bit.  Nor would port forwarding or bridge mode.

You’re failing to understand the problem.  The issue is how the T-Mobile network is setup for a security aspect.  It was setup to be a secured network for phones.  It’s not capable of working with a DDNS service, bridge mode, or port forwarding.  That’s why they disabled these features on the T-Mobile modem, as they would never work.  Keep in mind that Nokia added these features to this modem firmware when they designed it (for other markets).  When T-Mobile wanted to use it, they had to disable features as they don’t work on their network, not because they wanted to limit the device.

The new modem won’t resolve the problem either.  It may happen along with a T-Mobile network change, but a modem alone can’t fix the problem, either a firmware update or new hardware.  The only work-around is a service like ZeroTier until T-Mobile changes their network, which very well may never happen.

Not sure if anyone answered this exactly yet.....But, sounds like you can port forward. What you need to do is switch over to a business account. The monthy cost is the same, but you have to add $5 per month for a static IP address and also get their FX2000 modem. Then you can port forward. I have not tested it yet, I literally just ordered it.
Service:
https://www.t-mobile.com/business/solutions/business-internet-services/small-business-internet

Modem:
https://inseego.com/products/fixed/fx2000-tmobile/

Thanks for the responses.

I ended up taking the SmartThings hub to my current home (where I have Frontier FIOS service) and I got the SmartThings hub online there. I then moved the hub to my new home (T-Mobile 5G service) and connected it via Ethernet to the modem. It came online and has been working well. It appears the issue is only with the initial registration. 

ok, so this is an interesting conversation, I came here via google for the same reason you guys did. I live in an RV, so a service like this is super interesting to me, but I also work in tech and some kind of public access to the network behind the T-Mobile device is pretty important to me for stuff like HomeAssistant, some kinds of file transfer I have to use, etc.

idk if T-Mobile is “incapable” of not using CG-NAT for this. if you’re doing NAT you can do routing; they’re comparable levels of compute-intensiveness. whether or not they will actually do it is another question; I am also skeptical (though this would be huge for me).

in my particular situation I have a lab environment with a public-facing IP hosted for me at a datacenter not far away from me. has anyone tried using Nebula to solve this “no publicly routable IP” issue? (Nebula is more or less self-hosted ZeroTier, I think) https://github.com/slackhq/nebula

Thanks for the update,  I ordered one too.  Not sure what I am getting but it is coming.  Will update when it arrives

So I’m having NAT Issues for my ps4 where I’m trying to connect with people in elden ring which I need a NAT 2 and I have no idea how to change the NAT type from 3 to 2 on my 5g gateway please help help help help help is there any way around this or a way 

On the waiting list ‘ere.

As far as I’m reading there’s passthrough which’ll let me reuse our existing network and maybe treat the modem as a dumb modem like we’re doing to our ADSL modem. Our modem doesn’t even do the job of providing DHCP; effectively as if we connected directly to our ISP’s network.

However, from reading it sounds like T-Mobile is doing carrier level NAT for IPv4 similar to what I’ve been hearing with Starlink on their equipment; basically I could be sharing 18.0.12.3 between five other customers.

And IPv6 is not our silver bullet since it sounds like T-Mobile’s network is filtering requests before it even hits the equipment if I’m understanding what I’m reading.

IPv4 is a nice-to-have but at the same time it’s deadweight going forward since IPv4 served it’s purpose and is more of a nuisance. I can grab a IPv4 address---until IPv6 reigns supreme on public Wi-Fi---and set up tunneling and be happy with that so I can control my smart-home server wherever.

Not sure if anyone answered this exactly yet.....But, sounds like you can port forward. What you need to do is switch over to a business account. The monthy cost is the same, but you have to add $5 per month for a static IP address and also get their FX2000 modem. Then you can port forward. I have not tested it yet, I literally just ordered it.
Service:
https://www.t-mobile.com/business/solutions/business-internet-services/small-business-internet

Modem:
https://inseego.com/products/fixed/fx2000-tmobile/

@Jackson300zx: Just to follow up if you have successfully tested the NAT and Port-forwarding features of inseego FX2000 gateway. I talked to T-mobile rep about this and she told me that

Small Business Internet (SBI):
Gateway: Nokia 5G21 and Arcadyan KVD21
Note: Static IP eligibility - Not Included

Business Internet (BI)
Gateway:
• Nokia 5G21
• Inseego FX2000
• BYOD (Bring your own device)
Note: Static IP eligible (Inseego only)

Only BI can ask for static IP, not SBI

Holy sh* man you are saying exactly what I’m stating!  The right thing to do would be instead of trying to work against me, work WITH me to pressure T-Mobile to get this deivce more functional and then we can ALL do whatever we want with it.

 

 

 

All T-mobile has to do is enable the device to bridge.  That’s it.  I know this because that’s how my cable modem worked and I was able to do everything else I wanted from there.  So if you want to sit there and tell me the networking configuration I used for YEARS was ‘incorrect’ and didn’t work, go right ahead…..but you are not helping. You can be an apologist for why they don’t enable these things, but this device is for HOME INTERNET.  I do not sit at home on my phone and nothing else. If that is T-mobile’s position then I’ll be returning it and wait until they grow up.

Actually, we’re not at all saying the same thing.  You believe the modem could be updated with a few feature and it would work.  I’m saying that’s not the case, as you’re basically behind T-Mobile’s NAT/VPN so enabling features on the model wouldn’t solve the problem one bit.

How exactly do do believe enabling bridge mode would solve your problem?  You’re comparing your cable company’s network with T-Mobile, which are TOTALLY different.  Your cable company didn’t hide your connection behind a NAT/VPN.  You could identify your home connection with a unique IP address which you could access remotely (with or without a DDNS like NoIP).  But T-Mobile’s network doesn’t work like your cable company.  Every connection is like a VPN or NAT, where there’s not a unique IP address, but it’s shared with many other people.

So, lets’s say bridge mode is available on your T-Mobile modem.  How would you remotely access your home modem?  By IP? Via a DDNS like NoIP?  Nope!  As there’s still not a unique IP address assigned to your home connection, it’s shared with thousands of other people.  So you would try to access your home network and it could never route to your home.

So I’m sorry, you don’t know what you’re talking about.  You have limited knowledge and basing your assumptions on how your cable company’s network is configured, when in reality T-Mobile’s network isn’t at all setup the same way, and as a result, your assumption that bridge mode will solve everything is totally wrong.  Sorry, it’s not as simple as that.

You are forgetting, that T-Mobile LTE gateway works just fine when switched into a bridge mode! So, it is not the network issue per se, it is a firmware issue on this 5G trashcan.

I agree TMobile could have made this much easier by providing an internet facing IP address, as well as IP scope control and other things. But there are easy ways to get your setup working if you have another router.

To start, just have another router and connect either of the yellow ports of the TMobile gateway connected to the internet port (WAN) of your router. Now you have complete control over your internal network with DHCP, Scope, Static IPs if you want, Firewall rules for the internet, etc.

The next thing is to use something like the free version of TeamViewer, which will create the path through the internet to your computer for remote access and you can remote into your computer from outside the network whenever you want.

For security system viewing, just setup the viewing app on your home computer (which you probably already have) and remote into your computer and view your cameras that way. TeamViewer has a version for Windows computers, phones, tablets, Linux, MacOS, Raspberry Pi. So pretty much any device you have.

I know this is a workaround for T-Mobile's lack of services on the gateway, but it works great, it’s reliable, it’s a free solution, and restores functions many people need. It’s also only takes a couple of minutes to setup. I use it all the time and I have no issues. I’m sure you could do this with other remote services that are available, but I prefer TeamViewer over many of the non-trusted remote services available.

Good Luck

My nat was strict and couldn’t play in a party on Xbox.

Great lad at customer service had me run 2 speed tests and that pushed me into whatever and now the nat is open. Yay for cgnat 

@jarrodsfarrell what solution are you using to tunnel? I’ve setup ngrok to get around the port-forwarding on a laptop running behind the T-Mobile 5G POS Modem, but it’s not persistent. Every time I lose power or the internet connection is interrupted, the tunnel drops and I lose all remote connectivity. With CG-NAT I don’t see how it’s ever going to be possible to host an OpenVPN server from inside my network, even with port-forwarding, so I have to find something more durable.

@arcanenox OpenVPN here since our existing ADSL with TDS allows our public IP to be reached. But for your issue specifically I don’t have a tidy solution given I was going to suggest Cloudflare’s Argo Tunnel, but it looks like it might be limited to protocols that can give a hint to what service they’re trying to access or require software on the client otherwise for some turducken solution. https://danishshakeel.me/creating-an-ssh-tunnel-using-cloudflare-argo-and-access/

Full disclosure, I’m not certified in any capacity for network engineering: I’m a hobbyist.

But having to establish a tunnel with Argo then OpenVPN for local access is obviously not a nice solution. If someone has a better solution it’d be nice, but my working theory if I have to deal with this is renting a cheap VPS and set up OpenVPN to connect my firewall to with some route trickery to route traffic from the VPS to the firewall over OpenVPN. And if I’d want to expose a service from within my network then I’d use a IP Table rule to port-foward the traffic.

E.g.

VPS OpenVPN announces it handles IPs going to 192.168.0.0/16, 192.168.7.0/24 is where VPN clients live, and 192.168.1.0/24 is where the home network lives.

IP route on the VPS to direct 192.168.1.0/24 to whatever IP the firewall is given by OpenVPN (192.168.7.2 as example.)

IP route on the firewall (if needed) to direct 192.168.7.0/24 to the VPS (192.168.7.1 as example.)

So when I’m connected to the VPS VPN, accessing a service on 192.168.1.5 routes to the VPS, the VPS routes to the firewall, and the firewall routes it to the service. And the service can reply back in reverse order.

Overall hopefully reducing cruft in the connection. But does mean trading the OpenVPN job from my firewall to the VPS and losing some convenience (I can mint config files in pfSense to quickly get my devices working as an example.)

Not to be pessimistic but TMO has known about this issue since inception. They aren’t going to fix it. Or they aren’t knowledgeable enough to do so. Needless to say, TMO is just a step to getting better services in my rural location. TMO doesn’t seem to care. They laud themselves as customer-centric but TMO is just another business innit for the money. Yay capitalism. 

If they could fix this issue for us their customers, maybe they wouldn’t be viewed as they are. 
 

For my part, I live on a boat, using the Inseego Wifi Router.  Bandwidth is good, but I have the problem when trying connect to Minecraft hosted instances and playing astroneer.  I also have an Android Samsung A52, that I use as a hotspot on the T-Mobile Network.  Zoom works for meetings w/ work (kind of had to set up my laptop as a DMZ machine to get it to work).  Long story short.  I have an iPhone that has Verizon, and no problems.  On the Verizon network I have no problem with Minecraft, Zoom, or Astroneer.  Whatever T-Mobile is doing on their network to hack around their lack of IP addresses (or whatever their major malfunction is) does not appear to exist on Verizon.  I tried ZeroTier and was not able to get it to work, but I’m sure I probably could if I had the time/motivation to get a VPN properly working.  The main problem is that the IP address that presents to the Internet can never route back to my actual box, e.g. you connect to the outside world but the  IP address presented to the Internet  will never route back to your local box because of the way CGNAT (carrier grade NAT) that is being implemented on T-Mobile.  In other words, you make a connection to a remote host and they try to connect back to the IP address that they think you are connecting from and it doesn’t actually connect back to the host that you are connecting from.  It’s not a problem w/ the modem or your device, it’s on the T-Mobile network.  It works on Verizon, not on T-Mobile.  If you want to solve this problem either T-Mobile has to fix their broken network, or you need to switch to Verizon.

 

Edit: ignore my reply.

I recently purchased a new home that came with a “Home Automation Kit”. This included a Ring doorbell, Samsung Smartthings Hub (to connect to Z-Wave thermostats) and a Genie Aladdin Connect garage Door Control Module. I have the T-Mobile 5G modem with WiFi turned off and a Netgear AP connected for WiFi. 

The Ring doorbell works over WiFi. The Samsung Smartthings Hub will not connect (using Ethernet port on T-Mobile modem or WiFi). The Aladdin Connect module will not connect via WiFi. 

The installer immediately indicated that the Smartthings hub would not work with my “hot spot” and it didn’t. 

Has anyone been able to get a Smartthings Hub working with the T-Mobile 5G modem.

Reply