Question

New 5G Home Internet: phone blazing fast, laptop not so much

  • 17 September 2022
  • 2 replies
  • 107 views

Badge

I setup the new 5G home internet gateway, have a 3-bar “solid” signal and when I connected my iPhone11 it’s getting a speed test of around 222 Mbps download speeds.  The laptop I use for work also connected to the same gateway (5Ghz band) runs a speed test of 52-146 Mbps varying range.  

The laptop has 802.11ax Wi-Fi 6.  Any ideas why the disparity and how to address the laptop speed?

 

Thanks in advance


2 replies

Update:

The speed is not consistent for my Mac. In general, it’s a lot slower than the phone, but sometimes I could get matching speed with the phone.

---------------------------------------------------------------------------------------------------

Update:

Hi, I rebooted the device and now I can see the speed is also good for my Mac.

---------------------------------------------------------------------------------------------------

Exactly the same here. I got 5 bars. Phone gets like 450Mbps, but Mac barely reaches 100Mbps. I disabled the wifi 2.4GHz signal to make sure the devices all use 5GHz wifi.

I had the same problem.  Netgear Router connected to T-Mobile router.  Everything that connected directly to the TMobile router was blazing fast (@450mbs) but anything that connected to the netgear router was @130mbs.  After going through various tests it turns out that the Netgear has a QOS (Quality of Service) setting that wass the problem.  The QoS setting favors interactive traffic … but the speedtest app is a bulk transfer type of trafic and was getting throttled.  Turned QoS off and desktop/Wifi/phone now all get comparable speeds.

Reply