Question

Peacock not working on T-Mobile Home Internet

  • 21 April 2021
  • 3 replies
  • 72 views

Badge

I got T-Mobile Home Internet a few days ago and after doing some testing I found out that the Peacock app on my Vizio TV doesn't work when using T-Mobile. If I switch back to my Spectrum internet it works fine. Is this a known issue? Is anyone else having similar issues? By the way I'm not using Peacock for live TV, just to watch olld Office episodes. 


3 replies

Badge

Have you tried rebooting your VIZIO TV? I initially had issues with my TV’s apps not working, but a reboot fixed it. (I only use those apps when testing; I generally stream through my Apple TV.)

Userlevel 7
Badge +13

I agree with @n2itivguy . I had issues with Vudu TV and doing a system reboot fixed the issue.

Userlevel 4
Badge +2

Works on my Roku Streaming Stick+ and Windows 10 laptop running a media server.  They both were updated last week though... perhaps there is a versioning issue with your hardware/software?

 

Some built-in solutions aren't as robust as the standalone boxes.  Have seen issues in the past with several services where the TV based solutions would either lack functionality available to the standalone counterparts, or the app just ran horribly or locked up/crashed frequently because of things like less memory or weaker processing/cooling designs.  May want to test it from another platform if possible.

Reply