Question

Plex Remote Access Unavailable.

  • 26 August 2021
  • 13 replies
  • 2372 views

Userlevel 3
Badge +2

I have the T-Mobile router connected to Google Wifi. Obviously double NAT. I get this in Plex settings:

Not available outside your network

Your server is signed in to Plex, but is not reachable from outside your network. Learn moreTip: It looks like your server may be connected to the internet through multiple routers or other network devices. Try connecting it directly to your primary device, or visit our support site for more information about troubleshooting this "Double-NAT" scenario.

I know there is no bridge mode. I’m thinking some kind of port forward may work but that’s not even available. Anyone found a way around this? Gotta have my Plex.


13 replies

Userlevel 5
Badge +5

Port assignments get “filtered” because of their funky XLAT464 CGNAT/VPN style tunnel they set up for dealing with the dual v4/v6 addressing stack.

Their LTE box can do UPNP and even manual forwarding configs--but they can fail because of the issue that exists at the higher layers. (I have a Playon server… a more basic version of what a Plex server is).

Some people have been able to recover SOME functionality with devices/apps that need some form of peer-to-peer functionality with VPN’s--but that can be hit and miss depending on what ports are in play and all.  Some will call for an extra fee to reserve a public v4 address for your use and/or custom port pass-through too, so it may not be worth what it takes to make it function if a standard VPN doesn’t cut it.

If you CAN make it work via VPN, might be something worth looking into setting up on your own router that supports it so you can take advantage of it for multiple devices.

Userlevel 3
Badge +2

Oddly enough I am able to get to Plex from outside the network despite the ‘unavailable’ message. 

With all of the secondary routers out there in millions of households, T-Mobile really needs to add a bridge mode option. I get that the dumbing down of technology is the trend now but it comes at too much of a cost for the rest of us. Choice is a great thing.

Userlevel 1

Still a problem: bump.

Userlevel 3
Badge +2

I’m no longer able to access Plex from outside my network. T-Mobile - Please activate a Bridge mode option in your firmware. Double NAT is a common problem and needs to be resolved. 

I agree.  We need either bridge mode or some sort of port forwarding.

 

Some people were successful setting up a private network using ZeroTier.  I failed.

I second this. We need more advanced features on the router. 

Anyone find a way to get your external info? I finally got into this issue not having time to mess with it before I cut off my other provider. Of course when I cut off my other provider is also when my speed issues started.

 

Badge

I guess you could configure Plex for VPN access but not sure if there is a way to do this. I have Plex on my NAS, and I couldn’t find a way to do this (except for VPN’ing everything, which I obviously don’t want to do on my LAN). Anyone else have any solutions? I thought the problem was UPNP not supported (router). Router behind the TMO router won’t help either without TMO router (trashcan) supporting UPNP.

The other option is custom firmware for the Router side of the gateway. Who knows if anyone wants to put the resources into it. The idea of needing custom firmware for the most basic of features is ridiculous. They need to allow port forwarding or at least Bridge mode. Not asking for much, lets be honest here. 

Userlevel 3
Badge +1

You could get all the features you want in the router for port forwarding, bridge mode, etc. but none of it will help because T-Mobile uses Carrier Grade NAT upstream of the home gateway.

 

The other option is custom firmware for the Router side of the gateway. Who knows if anyone wants to put the resources into it. The idea of needing custom firmware for the most basic of features is ridiculous. They need to allow port forwarding or at least Bridge mode. Not asking for much, lets be honest here. 

It would not work due to carrier setup. You don’t have a unique public IP when connecting to a cell tower. The tower would have to know how to find you and know that someone wants to access that specific port just as treddy said.

so is there a way to get it to work? Zero tier, packetriot? Is there anything. Would love to get this access working again. Any suggestions would be awesome!

I am able to use Plex outside my network. I am setup double NAT (no bridge mode) and have the older 4g gateway. I have everything in the house connected to my router and the router is connected to the gateway with Ethernet. I have the WiFi disabled on the gateway as well. 
 

settings on Gateway:
“Expert → NAT Forwarding → DMZ” DMZ active and select router. Save this. 

“Expert → Security → Access Control” set “Active” “Whitelist” “Add New” “Enable Entry” select router and click “Apply”


These settings also allow me to use VPN on my work PC connected to my router.  I also have other ports forwarded on my router and they all work. 
 

Reply