Question

Printer connection

  • 17 May 2022
  • 8 replies
  • 132 views

Badge
  • First activity
  • 0 replies

Does anyone know how to add a MAC address of printer to permitted devices on Gateway router?  Would appreciate assistance.  


8 replies

Userlevel 5
Badge +4

You should not have to add the printer MAC address to the gateway. Local LAN devices via wireless or wired should not be filtered by MAC address. The Nokia GW offers no filtering for the LAN and it is unlikely the Arcadyan does either given it has fewer configuration options than the prior Nokia T-Mobile gateway. There are firewall rules for the WAN but for the local LAN the printer should be recognized and joined as long as the SSID is a match and authentication is correct. Users have no influence over the open or closed ports on the WAN side so I don’t know how you can do what you are after. 

Of course there are some older printers that don’t seem to play well with the T-Mobile gateway. If you are getting a message about filtering maybe it is not a proper/accurate message. What suggests to you the MAC address of the printer needs to be permitted? 

Post the model of the printer. It may be an authentication issue not a filtering condition.

I have the same issue with an Epson Stylus NX430. When printing the error report upon failed WiFi connection, it states that the “MAC Address Filtering Check” failed and “MAC address of your printer may be filtered. Check whether your router/access point has restrictions such as MAC address filtering.” I use this printer for work, so any help is much appreciated!

Userlevel 5
Badge +4

From the WIFI interface specification i can see it supports 802.11 b/g OR b/g/n depending upon the purchase location. Bottom line it uses the 2.4 GHz frequency and authentication is WPA2 Personal as the most secure so the 2.4 GHz frequency must support WPA 2 Personal. Because of the specifications it appears to be a bit older. There have been a number of users reporting issues with printers that have older WIFI radios. There might be a newer driver for the printer, not highly likely, but worth investigating. The problem could be with the T-Mobile gateway’s backward compatibility. I have the Nokia GW not the Arcadyan KVD21 and I have a newer Epson and an 845 AIO which has similar wireless capability. With the 845 all in one it only supports WPA so I only use it as necessary but it does connect on the 2.4 GHz frequency. 

If you have an older router, you have total control over, which you can use to make a work around for the 2.4 GHz WIFI connection and have it make a bridge mode or AP mode connection to the T-Mobile GW then you might be able to get the network connection working. It might be better to just get/use an extender that supports 802.11 b/g/n and not 802.11 ac/ax and try to get it to link to a wireless extender that links up to the T-Mobile GW. There are a number of user responses on the community related to efforts to get older printers to link to the WIFI. Maybe there are yet clues to be found. Reddit is another avenue to explore for answers as well.

If you cant get the WIFI connection to work you could connect to it via USB. The Windows and MAC OS specifications appear to date the printer a bit back to 6-8 years ago so even though it should work with the newer WIFI radios the drivers written for it may not play well with the newer 802.11 ax capable gateway. If you have the Arcadyan GW it could be there where the problem resides as the software for that router/gateway seems to be not as mature as it should be. I doubt that the “MAC Filtering” is the real issue here. 

OK, so I was being a bit conservative on the generation of the printer. Those were initially released in September of 2011 so it might be considered a dinosaur. A newer, more efficient printer with better WIFI security might be in order. If you like Epson the ET-2760 AIO works quite well and is not that expensive. If you need multi tray, or faster printing capability and more features you might step up to the next level. You can fight with an older printer or upgrade and have a secure WIFI connection. Using a USB connection to print to the NX430 could be a reasonable workaround.

Thank you so much for that detailed reply! After spending a couple hours on the phone with T-mobile “support” staff that got me absolutely nowhere except extremely frustrated, I took your advise and pulled an old range extender I had out of the drawer. I replicated the 2.4 band, hooked my printer’s wifi connection to it, and VOILA! I’m antiquated again :D Thank you so much again for your help!

Unable to add my Cannon printer to T-Mobile Wi-Fi. 

Userlevel 5
Badge +4

You don’t state what Canon printer model you have so that leaves way too many variables. There are way too many models of Canon printers to make any assumptions. If it is a printer from 8-12 years ago then I would guess it could be due to an authentication issue or an older radio and an incompatibility with the newer 802.11ax solution in the T-Mobile GW. If you have an older router that can be changed to bridge mode and it supports 2.4GHz which it should and the same authentication as the Canon printer then you might be able to build a solution with that linking up to the T-Mobile gateway. 

It might be helpful to take the Canon printer and set it to factory default and then perform a manual connection to the WIFI. It is probably 2.4GHz so confirm the authentication on the 2.4GHz channel and make sure it allows what the Canon supports.

Also have the same issue with my Canon Pixma MX922. I can select the SSID but it doesn’t allow me to enter a password.

Userlevel 5
Badge +4

The Pixma MX922 may default to WEP but you need to select WPA or WPA2 authentication and you need to make sure the 2.4 GHz radio has WPA/WPA2 authentication enabled. It is not clear from the info I found what the default wireless authentication is for the MX922. The manual refers to using the WEP key during the WPA setup so you should avoid that and use a “Standard Setup” and then select WPA or WPA2 authentication. WEP is highly insecure and has been for many years. My guess is the reason it will not allow you to enter the passphrase or authentication key is because the authentication type is wrong. That printer hails from 2013 so it is highly possible the default authentication type is WEP. It is only b/g/n compatible but 802.11x is designed to be backward compatible to allow it to communicate. The Nokia GW does not support WEP so I expect the Arcadyan also only supports WPA/WPA2/WPA3 therefore it would ignore a WEP authentication type as it will not understand it. For good reasons.

Reply