Question

Slow upload speed and T Mobile home Internet

  • 1 February 2021
  • 9 replies
  • 4132 views

Userlevel 1
Badge

How do I improve the upload speed of my T Mobile home Internet? The download speed is around 70 the upload is just under one, which is horrible


9 replies

We have to do a reboot via the web interface about every day to keep the upload speed up where it should be, download always seems to be fine.  We have a weak signal but we get avg 50mbps down and 13mbps up. 

Userlevel 1
Badge

How do I improve the upload speed of my T Mobile home Internet? The download speed is around 70 the upload is just under one, which is horrible

 

I am experiencing the same thing.  I typically get 30-70Mbps download, but my upload speeds are always < 1Mbps.  It is causing disconnects for business video conferencing and other issues. As part of my job I also move large media files around. These UL speeds are unusable.

Slow upload speed (1.1 mbps), but 50+ mbps download. Two bars on the device. I cannot figure out how to improve this. Today, the internet has been flickering on and off, too. I cannot find a pattern to fix this.

Userlevel 1
Badge

Slow upload speed (1.1 mbps), but 50+ mbps download. Two bars on the device. I cannot figure out how to improve this. Today, the internet has been flickering on and off, too. I cannot find a pattern to fix this.

 

I’m experiencing exactly the same thing.  Depending on time of day I get 30-80Mbps DL, great latency, but regardless of time of day UL speeds are always 0.3-0.9Mbps.  Nothing I have done has changed that.  The past week has had a lot disconnects too.

Userlevel 5
Badge +4

make sure to test different locations.  They have some localized capacity issues… if you are only testing locally, you may not be getting an accurate picture of how things pan out for how you are actually using it.

for example, I am in the Carolinas, and while the localized testing around the Charlotte area often looks reasonable, it is prone to bouts of bad congestion.  BUT… my usage rarely actually is hitting Charlotte area endpoints, so those results are mostly irrelevant for my needs.

One of my main uses is for games…. games that are NOT hosted in the Carolinas.  Otherwise, it is a lot of streaming--and those CDN’s are not in the Charlotte area either.

When I test to the areas where most of those games are hosted, I tend to see quite a contrast---most often much better throughput to those locations further out.  That is right… I can actually get better results testing to Seattle, Montreal, NY, Dallas, Even areas around Southern California than I do to sites within my more immediate region of NC/SC.

If you see a HUGE shift when comparing results like that, it can be important info to pass on to tech support somehow… as there may be a backhaul issue, or other peering issues that need to be addressed at a higher tier, possibly even with a third party partner.

 

Just as an example, here are some results from some tests done close together in my history:

 

11228943298.png

 

 

11228950776.png

 

Notice how the one all the way up in Montreal faired better than the one that was just 50 miles away that Speedtest defaults to.

My download speed is very fast, but the upload speed is extremely disappointing.

TBH, I have seen download speeds (working with support, around 0230) over 350 and upload speeds up to 10.  That 10 upload speed was immediately after support rebooted the router.

It was suggested that these numbers, might be acceptable for making comparisons, but real-world testing of files uploads may be more valuable.

Userlevel 4
Badge +4

How do I improve the upload speed of my T Mobile home Internet? The download speed is around 70 the upload is just under one, which is horrible

I agree with you that one or under is a horrible upload speed, considering the 70 you get on the download. 

I myself get highest upload speeds on a specific band combination (B2/n41), and with my gateway placed in a certain location where I get a three bar signal. The problem with that for me is that with my gateway in that location, it also switches me to a slow signal. It’s rare but annoying. I fixed it. Haven’t been switched in days. I love being on my two highest speed band combinations all the time.

I can overcome that problem of being switched to that one slow band (4G alone) by putting my gateway where it gets only 2 bars, on the Primary signal anyway. But the sacrifice is in my upload speed. Fortunately, in my case, I am fine with an upload speed of 10 rather than 25. And there is no sacrifice at all on my download speeds by going to 2 bars from 3 bars.

The wireless cellular system is made in way that signals are shifted dynamically and seamlessly as a person moves from tower to tower. The problem is that even if you are in a stationary location at home, and connecting to only one tower because you have only one tower close to you, as I do (some people may be close to two or even three towers), you still get switched to various speed ranges dynamically on the same tower, which correlate to the possible band combinations you are connected to on that tower.

You can reboot the gateway to different bands simply by pressing the button on it to the off position for a few seconds, and then turning it back on. But all this is pointless if you don’t know what bands you are on and learn to use the GUI at 192.168.12.1

I go into all this stuff about how to use the GUI, see what bands you are on, and things you can try with your gateway placement to get a better signal in other posts which can be viewed by clicking on my badge to the left of this post and reading my dozen comments..

The first step to good gateway placement is knowing your tower location, which you can find using a free tower mapping app, and placing your gateway on the side of your house in a window facing that tower, and rotating it to get an optimal signal.

But window placement has a downside, if there is a lot of sun coming in. Shield it with a white cardboard or something, because heating up the gateway too much in direct sun can cause its own set of problems.

I read of one guy whose download speeds of around 50 on the first day doubled on his second day, and he didn’t even touch the gateway placement. In the present location of my gateway, below a window on the side of my house closest to the tower, I can alternate between getting 2 bars on the top and 3, just by rotating the gateway in place. I keep it rotated so it is 2 bars.

I see your main goal as trying to add a bar to your signal strength, and see how that affects upload and download speed each time. Also do a few speed tests when trying out a new location. Sometimes it seems to take a few tries to kind of rev up the speed.

I know what an upload speed of one and below is like because I’ve had exactly that for my last 10 years on DSL, before getting this T mobile home internet last week.

If by any chance you are getting three bars signal strength, it’s possible you are getting a 4G-only connection. Try putting your gateway in a place where you get only 2 bars, and see if that will make you connect to the 5G, and faster speeds. It’s worth a try.

I just happen to have my computer and stuff in the room of my house that is closest to the tower I connect to. If you just happen to have yours at the opposite side of the house from the tower, then the signal is having to pass through all those walls in your gateway, and could be weaker.

The free tower mapper I use on my 4G android phone is called: Network Cell Info Lite. While you are connected to wifi on your phone, if you open the app and slide the top menu to the left until you see “map” that is the selection that will show you where the tower is in relation to where you are. So you by being on wifi, you are connected to the tower through the 5G gateway, and not through the cell signal on your phone.

Get back to us if your upload of 1 improves and good luck with that. I have a suspicion that the speeds below 10 on the download or below 5 on the upload, tend to be worse than the same speeds would be on DSL, because the cellular signal fluctuates so much. It causes lag.

 

 

 

 

 

Userlevel 4
Badge +4

We have to do a reboot via the web interface about every day to keep the upload speed up where it should be, download always seems to be fine.  We have a weak signal but we get avg 50mbps down and 13mbps up. 


By rebooting, you are probably connecting to the band combination which gives you the most desirable upload speed.

Gateway placement can sometimes influence the frequency of connecting to your most favorable band combination, and for you the acceptable upload speed.

You use the web interface to reboot, so look under Status on the left and see what bands you are connected to using the dropdown arrows beside Primary Signal and Secondary Signal. If you have two signals you are on 5G, and that’s usually faster than being on a 4G-only primary signal.

I’m very happy with my speeds now, 5 miles from a tower, of an average of 90 on the download and 10 on the upload, and never dropping below 45 or so. But it took a few days of experimentation to get there.

What surprised me is that even in the various locations I’ve tried around my house where I get 2 bars on the gateway, the speed ranges can vary drastically. Likewise, I can get 3 bars in one window closest to the tower, and 3 bars on the roof, but the roof speeds are terrible comparatively. And the three bars in the window makes me sometimes get switched to a dreaded crawl speed of 4 to 25 4G only signal, even though that was only 5% of the time.

In the OVERVIEW tab on the left on the web interface, it shows separate signal strengths for Primary and Secondary. You may find your ideal combination will show two different strengths. You can control that by rotating the gateway sometimes, or a different placement.

If you are showing a primary signal only, then you are on 4G only. If you are showing an n41 signal in the Secondary (5G), that is about the best you will be doing speed-wise, once you find your optimal gateway placement. If you find an n71 signal in the Secondary (5G), there is a chance T mobile will replace it with n41 in the coming months and your speed could jump up quite a lot.

n71 is T mobile’s long-range low-frequency wave that doesn’t have high speeds, especially as you get farther from the tower. The n41 band is mid-frequency higher speeds. 

If you want to read more in detail about this garbage, I mean stuff, click on my badge to the left of this message, the blue circle with the T, to read my other posts about this.

Your speeds are great if you are 10 miles from a tower, or you are 5 miles with a lot of obstructions. Otherwise they’re kind of low for 5G. But it’s all relative according to what you’re coming from and what you can expect realistically, according to where you live in relation to the T mobile tower(s).

 

I had the same problem. Turned out that the speedtest(.net) by Ookla is not reliable app to test the speed. It assumes that server with the fastest ping is the best server for the test, which is not the case. Mine was almost in another country. That’s why upload so slow. (less that 1Mb/sec).

Change server manually to one that is closer to you geographically and you most likely Ookla will show the promsed 5-20 Mb/s. (don’t you think it’s still too little?, but anyway this is what T-Mobile says is an excellent speed).

Reply