Question

T Mobile Home Internet & Google Home & Alexa

  • 19 March 2021
  • 12 replies
  • 1529 views

Badge

Help.  I am battling to connect either Google Home Speaker or Alexa (Echo) speaker to T Mobile Home Internet.  I have reset the devices but nothing.  Both try to connect but can’t finalize the instal and can’t finalize setup connection. Any ideas please.

Also...how many devices can you add to home internet.  I have the high speed internet gateway (grey tower).  I have read conflicting numbers.  10 or 20 (10 on 5g  10 on 2.4g) or 64.    


12 replies

Yes! I had the same issue with my Google Home devices after the firmware upgrade to .0168. After three long hours on the phone with support and a call back from another expert, T-Mobile sent me a replacement refurb gateway with .0143 firmware installed. No problems (so far).

Badge

Thanks Ripley.  I finally got it to work (not sure how!).  I think it was the 2-hour wait for the call center that motivated me to persevere!  

 

Ok, awesome! Glad to hear it!

Did you get any idea of the cause of this? I have the same issue with my Google devices have stopped working. They act as if they are not communicating out.

Userlevel 1

Yes all of my Google devices that use Google Assistant have the same exact issue. Chasw I'm curious as if you're going to be able to maintain connectivity to the T-Mobile home internet. I also have the gray tower and although my speakers do connect on occasion, they seem to lose connectivity frequently when I activate the Google Assistant.

The problem is far worse with my Chromecast with Google TV. But that is tight heavily with Google Assistant so that is the reason why I'm making that connection with all of my Google devices. Even my Pixel 4 XL mobile phone, which rides on Google Fi's mobile service, also loses connectivity to the T-Mobile home internet Wi-Fi router.

As I have read through other threads, I feel there is definitely an undiscovered issue with T-Mobile home internet and Google devices that use Assistant. 

Did anyone ever figure this out without having to exchange routers?  My google home speakers will not connect or work and when I swapped to my old windstream internet, they connected just fine and continued working, so I know the issue is the T Mobile internet, not the Google. :-( 

This is a ridiculous problem to have. I have been using T-Mobile internet for a month or so and I am not happy at all. Perhaps the Andy is in another thread but I’ve got to waste time looking for it

Userlevel 7
Badge +14

Make sure your Google Assistants and Amazon Alexa’s are using the 2.4GHz WiFi, set manually to 2.4GHz, channel 6 with AES for encryption.  10 devices is about the maximum for devices spread over both the 2.4GHz and 5GHz channels combined.  

Does anyone have an update for this? I just got TM home internet this week and all the same problems with Google Home and Chromecast. They’re on the network so they can pull data but other devices can’t find them nor use casting features.  I’m on the latest tower and firmware.

The disappointing part is I’ve had multiple calls with TMO support and they said their engineers do not report seeing any problems here and they are NOT working on a fix.  I said it was all over their own forums so how do we get that going and they only said if a bunch of people call and report tickets.

One guy told me to try and segment the 2.4 and 5ghz networks which I’ve seen mentioned but haven’t had the chance yet. I really wasn’t planning on setting up my own router.

Userlevel 4
Badge +5

I have had some issue similar that have nothing to do with the gateway since I use my own router. If my laptop is on 5g and my chromecast is on 2.4 it will say it is connected but content does not play. If both devices are on the same 5 or 2.4 it works no issue.

So what has worked for me is to factory reset the gateway device. Once you set it up log into the settings online (192.168.12.1) and divide the 2.4hz and 5gz. But after you separate them go to configure ssid 5, under set ssid to configure make sure to go through all of them and turn off any "enable ssid" other than the ssid 5. For me the ssid 9 was named the same as my 2.4 and Google devices don't like 5gz. Sorry if this is confusing wording but I hope it helps. 

@Danibri5 Thanks so much. That worked.

Reply