Question

T-Mobile home internet slow on only one device. Only download speed

  • 9 March 2021
  • 3 replies
  • 191 views

Badge

I just got T-moible Home internet. I have the grey hotspot. I am getting around 80 mbps down and 25 up on every device in my house except my main computer. I get about 25 down and 25 up on my computer. I’ve tried resetting all my network stuff and reinstalling all network drivers. I have tried both Wifi and ethernet and both give me the same speeds. 

Any ideas?


3 replies

Badge

Thanks djb14336. I tried this when I got home yesterday and it worked. Speed is back to normal

If I have a weakness when it comes to computers it is networking. 

 

Thanks Again

Badge

Thanks. When I get home from work I will try this out. I’ve thought maybe it was a hardware issue and that maybe my networking card in my motherboard might be dying. I’ve tried using a usb to Ethernet adaptor to see if I could circumvent my network card but I am still having the same issue regardless. I’m having a hard time believing that it has anything to do with my hardware on my computer now. Hopefully your solution works and I’ll let you know the results

Userlevel 5
Badge +5

If this is a Windows PC, your recieve window scaling may have gotten mucked up.  Happens sometimes with Windows  Updates... gets set to a static value instead of using the default dynamic scaling.

 

Can go to speedguide.net a.d dow load their TCPOptimizer from their tools section.  Right-click to run as admin, select your network card (or do all interfsces), and tick the option to reset to Windows defaults.

 

It will prompt to make a backup of current settings (has a restore function), and then prompts you to reboot to apply the changes.

Reply