Question

tmobile home internet and samsung tv plus


Badge

I just received my new tmobile home internet gray 5g gateway. All internet items work great! Even all the apps on my Samsung tv. All except for the Samsung tv+ app, it lags and says "there was a problem trying to play the Samsung tvplus channel. Check your network settings and try again later". Anyone have any idea why this is the only app on my TV that won't work with my new internet? Just for more info; Hulu, disney+, prime,  and YouTube all work great, on the same new network.


17 replies

Userlevel 5
Badge +5

Can you post what firmware version you have?

Badge

The firmware of the gateway is 1.2003.03.0178

 

I have the same firmware and noticed the only TV that has a problem with Samsung TV+ was one that is on the 5Ghz WiFi. The other 3 seem to work fine and they are 2.4Ghz only.
I do know samsung TV can use the 40Mhz bandwidth for 2.4Ghz. You can try changing the 2.4Ghz wifi to 40Mhz bandwidth on the channel and see if that helps.
Is you TV connecting to the 2.4 or 5ghz WiFi? Or do you have the SSIDS the same for both?
Is your 5Ghz running on the low channel or the hi channel?
You can try to switch them arround, if its low then turn off the low one and turn on the high one to see if that helps.

 

Badge

Thanks Scottjd,

It has not worked yet. I did only have one ssid, so I separated them to the 5ghz and 2.4ghz then tried changing the bandwidth to auto then 40mhz on the 2.4 still nothing. Put the TV back on 5ghz and tried auto and 40mhz. Nothing. I will keep trying. Next thing I will try is an ethernet cable from the gateway. Thanks agian!!

Thanks Scottjd,

It has not worked yet. I did only have one ssid, so I separated them to the 5ghz and 2.4ghz then tried changing the bandwidth to auto then 40mhz on the 2.4 still nothing. Put the TV back on 5ghz and tried auto and 40mhz. Nothing. I will keep trying. Next thing I will try is an ethernet cable from the gateway. Thanks agian!!


Ok, so your TV does do with 2.4 and 5, good to know.
You should be able to leave the 5Ghz on 80Mhz bandwidth. The 2.4Ghz bandwidth change only made a difference for me on the TV’s that can not do 5Ghz.

Can you tell me the firmware version on the TV? Do you know if the TV has the latest firmware updated on it?
Now you do have me curious. I have two samsung TV’s that only do 2.4,Ghz and two TV’s that do 5Ghz.
I think I will pair the dual band ones back up with the T-Mo gateway WiFi and test this myself again.
Currently I have my old WiFi router behind T-mo with a ethernet cable and all the TV’s are running good.
Ill let you know how it goes after I test, and see if I can find out why its would only be some TV’s for this issue.

Scott

Thanks Scottjd,

It has not worked yet. I did only have one ssid, so I separated them to the 5ghz and 2.4ghz then tried changing the bandwidth to auto then 40mhz on the 2.4 still nothing. Put the TV back on 5ghz and tried auto and 40mhz. Nothing. I will keep trying. Next thing I will try is an ethernet cable from the gateway. Thanks agian!!


Ok, so this is what I did to fix it.

I tested this on the TMHI gateway/wifi for both 5Ghz and 2.4Ghz wifi. This seems to really be a DNS issue on how T-Mobile does the NAT and other things. So I had to change the DNS server on the Samsung TV’s for this to work. This fixed Samsung TV+. Other apps should also work.

I tested Samsung TV+, samsung app store on the TV, AppleTV+, Netflix, HULU, YouTube, and Spotify and everything worked.

So to get this to work these are the changes to make.

  1. Put the 5Ghz WiFi back to the default Auto bandwidth or change it to 80Mhz bandwidth. Your choice, but if some other devices have issue then I would recommend using Auto.
  2. If you don't have any TV’s on 2.4Ghz then I would change that back to Auto. For the 2.4Ghz since its over crowded thing normally run better on 20Mhz bandwidth so just let Auto manage this. Even iPhones and MacBooks wont let you use 40Mhz on the client side.
  3. Connect to your choice of WiFi but I recommend the 5Ghz if you get a good signal.
  4. After it connects go into Settings
  5. The General
  6. Over to Network
  7. Run Network Status (it will say connected to internet, but Samsung TV+ will still fail)
  8. Then choose IP Settings
  9. Go down to DNS Settings (it should say “Obtain automatically
  10. Change this to another DNS server, I changed it the Google DNS server at 8.8.8.8 (or another one)

I tested this with the google DNS server and it worked. Other DNS servers should also work if you have another open DNS servers in the area closer to you. Just don't use a T-Mobile DNS server.

Hope this helped,

Scott

 

Badge

Thank you Scottjd! The dns servers were the answer! I put everything back and changed the dns server to 8.8.8.8 and it's working like a charm! Something in the back of my mind said it was those, but I haven't done anything like this for many years!

Thanks again! 

Thank you Scottjd! The dns servers were the answer! I put everything back and changed the dns server to 8.8.8.8 and it's working like a charm! Something in the back of my mind said it was those, but I haven't done anything like this for many years!

Thanks again! 


No problem. I remembered my one TV did the same thing when I tested the WiFi on the can.
But for some reason since I run a Asus router behind it and the TV’s work fine.

It was just one of those things that caught my attention. I just dont know why out of 5 samsung TV’s in the house only two of them do it, and only the ones that have dual wifi. The older ones only have 2.4Ghz.

You need to change your DNS settings in network settings.  Run a network test, go to IP settings, go down to DNS and enter manually 8.8.8.8.   Trust me that’ll work

This worked for me too. I had the same problem with TVPlus. I called T-Mobile and they could fix it. They suppose to call me back today with a solution. :grinning: Thanks. I was thinking on returning the Box and cancelling the service, now I think I’ll keep it. 

I dont know why but cant connect my samsung smart tv directly to tmobile home wifi. Pls.  Help

I dont know why but cant connect my samsung smart tv directly to tmobile home wifi. Pls.  Help

Right 

Hello! I'm trying to connect my Samsung smart tv to the tmobile internet home but it doesn't work. When I run the Smart hub Connection test show me this "error code 107".I already connected all my devices but this doesn't work. Please help 

 I actually had to call Samsung TV  and the representative mentioned that he had to do a hard reset on the “back end” and it worked !

I haven’t been able to connect my Samsung smart tv to T-Mobile home wireless. Called T-Mobile, but they couldn’t figure it out, so they connected me to Samsung, and after spending an hour with them, was told that the tv isn’t the problem, that it’s on T-Mobile’s end. 
 

The TV finds the T-Mobile wireless just fine but won’t connect after entering password (I think the error code is 107). Tried multiple things, such as the 8 8 8 8 trick and a hard reset. Nothing works. The tv specs show that 5G should work, so I’m at a loss. We got the blooming tv not even 2 years ago. I’m on the struggle bus because I’m not techy at all and not sure what else to do. Any ideas would be appreciated. 

I’m having the same issue. If I use a cable and hardwire my T-Mobile wireless router to the tv, it connects fine. But no connection with wifi. The software on my tv is up to date and I’ve tried the 8.8.8.8 DNS server. No luck. I’m about ready to cave and go back to Xfinity. Another reason is, many of the tv apps don’t recognize T-Mobile as an internet provider, so I can’t activate the apps.

Seems we are all having the same issues but the 8888 is not working anymore.  I just got TMobile and it worked great for  2 days.  Now I can’t get the samsung TV to connect.   I’ve tried chanign the DNS and all but still can’t get TV to connect.     

Any ideas

Reply