Question

Turn off WiFi on T-Mobile Home Gateway


Userlevel 1
Badge

Is it possible to turn off WiFi on the T-Mobile Home Gateway, I would like to hook my wifi router and avoid having both WiFi active 


51 replies

Userlevel 2

I figured out what was going on.  By default, the gateway will broadcast on SSID1, SSID5, and SSID9, populating those with the SSID and password you specified during setup.  I had just disabled SSID1 and SSID5, didn’t notice I had to go into the pull-down menu to also turn off SSID9.  So this makes turning off the gateway WiFi is a little unintuitive, but it’s possible, my bad.  

To T-Mobile:

The Nokia 5G Home Internet Gateway need some serious improvements.

It should:

  1. Allow admins to enable HTTPs access to the Gateway,
  2. Allow admins to 100% turn off the WiFi radios,
  3. Allow admins to access the Gateway’s internal firewall, and be able to create/modify rules, check logs, etc.
  4. Allow admins to set the Public IP address to be passed through to a router or firewall connected to at least one of the 2 Gigabit ports, so that internal devices could be accessed from the Internet.
  5. Allow admins to 100% disable the gateway’s internal firewall if so desired.

I unfortunately started the search for a more serious, and better thought of product, to satisfy my requirements. 

Thank you.

 

Userlevel 2

Logging into the gateway and disabling “Enable SSID” and “Enable Broadcast” does not turn off the WiFi radios on the gateway, it simply hides the SSID.  If you key in the SSID and password on a device, it can still connect to the T-Mobile gateway’s WiFi.  If it’s not possible to turn off the WiFi radios on the gateway, that’s a bit of an oversight on T-Mobile’s part, I hope that’s fixed in future firmware.  On the plus side, the gateway has a pretty good WiFi system, if you want to use it.

To T-Mobile:

The Nokia 5G Home Internet Gateway need some serious improvements.

It should:

  1. Allow admins to enable HTTPs access to the Gateway,
  2. Allow admins to 100% turn off the WiFi radios,
  3. Allow admins to access the Gateway’s internal firewall, and be able to create/modify rules, check logs, etc.
  4. Allow admins to set the Public IP address to be passed through to a router or firewall connected to at least one of the 2 Gigabit ports, so that internal devices could be accessed from the Internet.
  5. Allow admins to 100% disable the gateway’s internal firewall if so desired.

I unfortunately started the search for a more serious, and better thought of product, to satisfy my requirements. 

Thank you.

 

I would like to also add an ability to turn this gateway to have the bridge mode please.

Userlevel 4
Badge +3

I connected my Apple AirPort Extreme to the T-Mobile gateway with a long ethernet (in the wall) cable, and that works perfectly. I did NOT turn off the WiFi on the gateway. I connected the AirPort to the gateway with an ethernet cable. Then I reset the AirPort. When it came back up it automatically did the setup to extend. Make sure you name the AirPort network the same name and use the same password as the gateway. No loss of speed, and now I have strong connections throughout my long house. When I’m near the gateway, that is the connection. When I’m near the AirPort, then that is the connection.

Hi guy’s,

turn off WiFi worked for me under  1.2101.00.1609 firmware,

but it was a lot of pain.

You have to select every SSID to configure,

the two frequencies have a pull down.

here the 2.4 and 5

ssid24
ssid5

The reason I did this, I had to hook up my WiFi 6 mesh to cover the whole house,

because chimney in the way to our new office.

Userlevel 2

Make sure to disable everything for both SSID5 and SSID9 under the 5 GHz section. There's a pull-down. That's what tripped me up the first time.

Ok, I just got it right. I went to each SSID for 2.4GHz, and 5GHz, and finally WiFi is now OFF.

Thanks!

Userlevel 3
Badge +2

From this discussion...
Home Internet- turn off WiFi? | T-Mobile Community

 

  1. Login to your router at 192.168.12.1
  2. Go to wireless networks
  3. For 2.4 and 5 ghz go through each SSID and disable the SSID. (Enable SSD setting to Off.)  

You could disable Broadcast for each SSID as well.

Note that if you do this, you might need to have a computer connected directly to the Gateway with an ethernet cable in order to access the admin page to make setting changes if connecting via your router fails to get you to the admin page.   Or you have issues with your router getting a connection.

 

 

OMG - OK so that’s pretty pathetic.. I just received my grey GW today and set it up. After a few failed connection attempts through the app, turns out that the app needed an update. 

I am very close to the T-Mob tower -like ½ mile. My connection is excellent with 5 full bars and great 5G speed on my phone. 

So far, I am hitting 340Mbits down and 42Mbits up w ~20ms (or less) ping times. Ethernet connection to GW shows gbit up/down but no noticeable difference in internet speeds or ping. (in a handful of first pass tests). 

WiFi coverage from this box doesn’t seem very good. From my office on the same floor and 100ft away, it drops significantly. 

I have an Asus ROG GT-AXE11000 router so it makes absolutely no sense to use the T-Mo GW as my wi-fi router. 

So I ask WTH?!?!

Why not provide an advanced tab on the T-Mo router to allow some advanced settings -or even- frankly a “hidden” unpublished page that would allow an advanced user -or even a basic user with a mesh wi-fi system to go in and configure additional options such as disabling wifi altogether?? 

Hmm… Quite a fail in my opinion - I am sure this was done primarily to reduce support calls -but to be honest -this will have the opposite effect as to increasing calls by frustrated users who are coming off other providers -especially those with owned cable modems who have their own wifi routers.

If it was a hidden page -this would address the concern about a novice messing up settings while at the same time allowing a more advanced user to configure the things they need (like disabling wifi, setting static IP, changing DHCP scopes, etc..) Sheesh.. Come-on T-mobile -At minimum -let us disable wifi! Please… 

So, I will spend the next few days playing around with things but hoping to minimize wifi interference between the Tmo GW and my personal router. 

If anyone has a simple known “secret menu”, “hack” or other means to disable wi-fi please share it.

Userlevel 1
Badge

I wrote a simple Python script to automate the method described in the NaterTater video, above.

See here:
https://github.com/tnixon/kvd21-TMI-util

Can anyone that has successfully done this AND had problems with the connections dropping sporadically answer this question:  Has using an external router reduced/eliminated the amount of disconnects?

 

We’re at wits end with this disconnect problem.  It works for a day or 2 and then just drops (sometimes multiple times in a row)and doesn’t know how to reconnect.  Seems like they can easily build logic to ping or heartbeat, but alas the Can seems too stupid to even recognize that it’s no longer connected.  I’ve contacted customer support numerous times, but they unfortunately can’t help and do know about this issue.  I’m not sure what causes these disconnections, since it easily reconnects after a reboot, but conjectured if I reduced the load on the Can by turning off the routing, that it might stay more stable.  Heeelp!

 

Thanks in advance

Userlevel 5
Badge +5

Logging into the gateway and disabling “Enable SSID” and “Enable Broadcast” does not turn off the WiFi radios on the gateway, it simply hides the SSID.  If you key in the SSID and password on a device, it can still connect to the T-Mobile gateway’s WiFi.  If it’s not possible to turn off the WiFi radios on the gateway, that’s a bit of an oversight on T-Mobile’s part, I hope that’s fixed in future firmware.  On the plus side, the gateway has a pretty good WiFi system, if you want to use it.

Not sure at least on the unit that I have you can. I have a Wifi scanner and believe me they are off there is nothing RF coming from the can.

Also clearly says disabled see the screenshot.

 

 

I am having trouble with the wired connection not knowing my real location. That means without going through the wifi I get incorrect time, weather and any localized information. I think Tmobile knows this is the case. Be careful making a wired commitment to this box. If some body knows how to fix this please post it. My wired mesh has no idea where it is and changes location every time the T Mobile dice is powered off and back on.

I’m having loads of problems with ethernet connection. Half of my devices are wired, I think there is some sort of DNS problem. Some pages time out, then after 10-30 min all goes back to normal.

Hardware Version:

3TG00739AABB

Software Version:

1.2101.00.1609

Several people have got this figured out for the Nokia 5G21 router. Let me summarize…..

1. disable SSID name and SSID broadcast for SSID1 (2.4ghz)

2. disable SSID name and SSID broadcast for SSID5 (5ghz)

3. disable SSID name and SSID broadcast for and SSID9 (5ghz hi)

no need to disable SSID 2,3,4,6,7,8,10,11,12

Several people have got this figured out. Let me summarize…..

1. disable SSID name and SSID broadcast for SSID1 (2.4ghz)

2. disable SSID name and SSID broadcast for SSID5 (5ghz)

3. disable SSID name and SSID broadcast for and SSID9 (5ghz hi)

no need to disable SSID 2,3,4,6,7,8,10

This isn’t possible (yet?) on the KVD21. It doesn’t have the same administrative capabilities. The entirety of the controls consist of either “Combined” or “Separate Networks”, with no ability to turn any SSIDs off.

Behold all my options!

 

Oof. This is disappointing. I was excited to try this out - my ISP has gotten worse and worse. From the research I had done, it looked like it would have been possible to disable wifi on the gateway and just hook up my existing mesh system.

I got the tower today and immediately noticed how limited the options are. I was hoping to come here and find a secret menu like a few other people mentioned.

I know that a lot of the responses to this are “why would you want to disable the wifi?” That’s a good question, so I’ll break it down for myself:

  • I have an existing mesh system that I paid decent money for pretty recently. I’d like to keep that.
  • I have a number of existing wifi devices that I don’t want to program a new network onto. (Yes, I know I could set the new gateway to match the SSID and password, but still.)
  • I have a lot of smart devices on Zigbee, which generally uses the same spectrum as wifi. I just got them to play nice with my mesh network, and I don’t want to be forced to mess with it again. Interference is real!
  • The security/prioritization/device management options for the gateway/router are extremely limited compared to my current system. (Or even the one I had before it.)

Side note - I had read that the gateway would have a battery, allowing me to easily test it in multiple locations. I guess not?

I hope that a firmware update for the gateway could fix a lot of this. The way it stands, though, I’ll have to be blown away by the speeds if I’m gonna keep this service. Has anyone been successful in exchanging the gateway for something with a little better customization?

@Ellencwebb I am having this same issue! Did you ever figure out what you enter as the username?

Perhaps stupid question for many of you, but frustrating for me. I am unable to log in to disable 2.4 and 5 WIFI b/c I don’t know which account I am logging into - my home network? T-mobile? Obviously, I am technically challenged so any assistance is appreciated. Trying to install Dynalink router with T-Mobile Internet Gateway tower, and use the Gateway as a modem only. Thanks. 

I didn’t read all the way through this thread. I too have installed another router off of the Arcadyan gateway - so it’s essentially operating as a modem. Which is fine. However, what I haven’t seen is if there’s a reason to turn off the Wi-Fi from the Arcadyan. Does it improve performance (either general throughput or reducing Wi-Fi conflicts, or other)?

It doesn’t appear possible to turn off WiFi on the new KVD21 gateway, unfortunately. Unless I’m missing something.

This is very unfortunate. Just ran into this. Putting in a call to them to ask.

Is there a way to unplug some connectors internally?  I have ROG Rapture GT-AXE11000 and four mesh 6E nodes.   All hidden ssid.  I do not need the network overlap.

Several people have got this figured out for the Nokia 5G21 router. Let me summarize…..

1. disable SSID name and SSID broadcast for SSID1 (2.4ghz)

2. disable SSID name and SSID broadcast for SSID5 (5ghz)

3. disable SSID name and SSID broadcast for and SSID9 (5ghz hi)

no need to disable SSID 2,3,4,6,7,8,10,11,12

This is helpful but with all SSID's disabled the STATISTICS window still shows the 2.4GHz and 5GHz connections disabled, but the STATUS window shows a green online indicator, along with the transmitted power for 2.4GHz, 5GHz Low, & 5GHz high.  The heat generated is one of my main concerns for longevity. Speaking with the tech support was useless.  They just wanted to send another Gateway.  I have software version 1.2103.00.033B.  Setting the power to 12%helps compared to higher power settings, but still generates excessive heat resulting in reduced life of the Gateway device.

I am absolutely livid with this tmo taking away a CRITICAL feature that had been part of the service for quite some time.
I absolutely have to be able to use my mesh system to reach the edges of my property. The wifi in any single router or node has no chance. The wifi in this router is not very good to begin with. 

I spent a week looking through video reviews of this and EVERY SINGLE one pointed out that A) the wifi in the routers as provided is pretty poor (which it is), and B ) no problem you can turn it off and use your already existing far better wifi and mesh systems. 

So I guess this will be going back. I’m not sure why T-Mobile would want to mess with success and make liars out of all the youtubers that evangelized this system for them. 

 





 

Reply