Solved

Being redirected to Chinese msn


Badge

This is a strange one. I started my laptop yesterday and noticed that the news feed on the taskbar was in Chinese. Clicking any of the news items brought me to msn.cn/zh-cn. Manually trying to go to msn.com redirected me to msn.cn/zh-cn. I thought it was malware on my computer, so I malware checked and deleted my cookies. There was no malware found and deleting the cookies didn't help. Then I tested all the other devices in my house. All the computers and all the phones act the same way. What's more, if I switch my phone over to AT&T towers, msn.com works normally. So, it seems obvious to me that the problem is with T-mobile. I rebooted the gateway and that didn't fix the problem. This may not be a serious problem, but, then again, maybe it is. I don't like that I'm somehow being redirected to a Chinese site. Does anyone have any suggestions/solutions concerning this?

icon

Best answer by syaoran 27 March 2023, 13:50

View original

18 replies

Badge

Thank you syaoran! The rebooting of the gateway that I did wasn’t enough. It needed a factory reset. After the reset, everything was back to normal. Thank you to everyone! This is a wonderful community!

I’m curious to see if your situation was a “one and done” fix. Resetting to factory settings fixed it for me also but then when the gateway did its update the next week I had to redo the factory reset. I’ve now had to do this about 3 times.

Badge

Thank you syaoran! The rebooting of the gateway that I did wasn’t enough. It needed a factory reset. After the reset, everything was back to normal. Thank you to everyone! This is a wonderful community!

Userlevel 5
Badge +7

This is a head-scratcher for sure! I'd try checking DNS on the machine that’s connecting to the Chinese version of MSN. You can't do that on the gateway, but if you're on Windows, you can change the DNS under Network Settings. (Full disclosure, I'm a Mac-guy.)

If the gateway is your first listing (192.168.12.1), replace it with OpenDNS’ servers: 208.67.222.222, 208.67.220.220 and then the third entry would be your gateway’s IP. That will remove T-Mobile from doing the DNS look-up and hopefully force your computer to go to the correct site.

Just to make sure that you're working with the right credentials, reboot your laptop AND the gateway, then try accessing the site.

For the record, I live in S. Florida, but my external IP address (issued automatically by T-Mobile) is Seattle, WA. I use the DNS settings above and don't have a problem with address resolution, so maybe it can help you too.

If that doesn't work, I'd download a VPN client (Mullvad VPN or Nord VPN) and see if forcing your location to be local might not also work. A VPN will replace your existing T-Mobile external IP with theirs, and could also potentially solve your problem.

If neither of these solutions work, I would guess there is something on your local computer that’s redirecting this site.

Good luck, and let us know how it goes!

Userlevel 7
Badge +15

Have they tried factory resetting the gateway?  I would think that would be worth trying before requesting a replacement gateway.

Userlevel 5
Badge +8

@not-a-number to help diagnose your problem I would ask you to do the following:

Open a tablet, smartphone and your PC and ensure they are connected to T-Mobile Internet. Then open up the MSN window on all three devices. do you get the same results (all Chinese)? If so, I would suspect an issue with the gateway. You need to explain your problem and ask for an exchange unit. Otherwise, if your table and smartphone are ok, then you need to reformat the PC and reinstall Windows (assuming that is the OS you are using). What you are describing sound like a virus that you picked up. I know that you said you scanned the PC and found nothing, but the malware or visor is highjacking your browser. 

Please let us know the results. 

Userlevel 7
Badge +14

Maybe @bocaboy2591 or @copz1998 have an idea on why this is happening.

Badge

Unfortunately, T-mobile on Facebook has already told me that they don’t handle home internet.

Userlevel 7
Badge +14

Try contacting tmobile support using messenger on one of tmobile's social media platforms like Facebook or Twitter to see if they can help. This is basically a user to user forum with some tmobile moderation so that maybe the way to gp.

Badge

Here's some additional info. If I go to bing.com, I'm redirected to cn.bing.com/. This page has a menu that has Settings, which shows my country/region as China. When I click this, it brings me to a country/region page that would normally allow me to set my country/region to any country. I tried setting it to the United States, but it doesn't allow me to save this. In other words, I'm being hard set to China! Since this is happening with every device on my gateway, and since it doesn't happen when I switch my phone to AT&T towers, I can only conclude that T-mobile is setting my region to China. 

Badge

I’m signed in with msn.com. That’s what’s kind of crazy because msn has my location, but I keep seeing the Chinese news. It’s another reason I think the problem is in T-mobile’s system. When I go to https://whatismyipaddress.com/ it shows me as being in Fayetteville, Arkansas. That’s closer to me than usual, as T-mobile is often connecting me in Missouri or Colorado or Illinois. So, it’s not showing China, but I’m getting Chinese news. 

Userlevel 7
Badge +14

Are you signed into msn.com? I don't have an account so the only setting I can change is language.

Badge

If you mean in Windows settings, my default location is showing my correct address. 

Userlevel 7
Badge +14

Can you go into the settings and change location?

Badge

This is what I see on my taskbar newsfeed:

 

Badge

No, I haven’t. 

Userlevel 7
Badge +14

Have you recently downloaded a new app?

Badge

Thanks! My son in California tells me that his is also normal. It makes me wonder if the problem is regional or a problem with the local tower. I’m in western Arkansas.

Userlevel 7
Badge +14

Mine is fine.

 

Reply