Question

Internet was PERFECT. Now no connection or weak siginal

  • 1 September 2022
  • 1 reply
  • 173 views

Userlevel 1
Badge

I started using T-Mobile internet in March 2022. From March to May I had a prefect connection. No problems at all. On May 26th it was a extremely bad storm with 65 to 85mph wind that lasted 6+ hours. Everything went out, when it came back on my internet no longer worked. After being on the phone with customer service and tech for several days. I was sent a new modem. While setting it up I only got a weak signal. I was back on the phone and was sent a different modem because the 1st one didn't work. I went through the setup and still got a weak signal. I have empty lots on both sides of my house and a large backyard. I took the modem outside and walked completely around my house. It didn't change at all. It stayed at 2 bars with a weak signal. I went in every room to every window on all 3 floors. Nothing changed. I was back on the phone for hours again with several people helping me. I didn't understand why I was only getting a weak signal. Then I was told to hold on for about 15 minutes. My internet was working not as good as before but working. But my modem still had 2 bars with a weak signal. Since then I had to call over and over again to get it to work. I don't know why it went from perfect to weak. Now I have to reset it several times a day. I stream tv and it's becoming more difficult. I don't want to leave T-mobile if it can't get back to normal I might have to. If anyone can help please respond.


1 reply

Userlevel 3
Badge +2

Possible damage to the T-Mobile tower? Or some new interference between the tower and your home? Those would be things you can’t fix.

Reply