Question

Laptop Does Not Recognize T-Mobile Internet

  • 30 January 2023
  • 14 replies
  • 6275 views

Badge

My laptop is a few years old. It does not recognize the T-Mobile network. My laptop recognizes other networks, cable, fiber optics, etc but not T-Mobile. Is there a setting I can change to get this to work?


14 replies

Userlevel 5
Badge +7

Since you own an older laptop, try this trick.

The first thing to check is to make sure the Hidden switch on your network is set to Off. By default, the Hidden switch is On for the primary network. Use the T-Mobile app to access the settings for your network. Tap the Network tab on the bottom, then tap on your existing network to see the settings. Scroll down to the bottom of the page and you'll see a Hidden switch. Turn it off and then Save.

If that doesn’t solve your problem, try adding a new WiFi network for your laptop. Use the T-Mobile app and tap the Network tab on the bottom, then the “+” button on the lower right. Create a new 2.4 GHz WiFi network with a unique name (SSID), just for your laptop. Make sure the WPA type is WPA/WPA2. This is different from your main network which, by default, is WPA2/WPA3. See if the new network you've created doesn't allow your laptop to connect.

Badge

Hi,

This discussion is very helpful. I just received my T-mobile internet 5G Gateway. The device I wish to connect is a well-functioning and protected Windows 7 computer (yes, it is “no longer supported” but Windows sends daily and often twice-daily antivrus and firewall updates, plus I have other security features).

1.My question is, will the method described here also work for my very old computer? So far it has connected to every router and hotspot I have encountered while visitng friends.

2. Where is the Hidden switch?.

3. Is it better to connect via wireless or ethernet cable?

Thank you!

bda

 

Since you own an older laptop, try this trick.

The first thing to check is to make sure the Hidden switch on your network is set to Off. By default, the Hidden switch is On for the primary network. Use the T-Mobile app to access the settings for your network. Tap the Network tab on the bottom, then tap on your existing network to see the settings. Scroll down to the bottom of the page and you'll see a Hidden switch. Turn it off and then Save.

If that doesn’t solve your problem, try adding a new WiFi network for your laptop. Use the T-Mobile app and tap the Network tab on the bottom, then the “+” button on the lower right. Create a new 2.4 GHz WiFi network with a unique name (SSID), just for your laptop. Make sure the WPA type is WPA/WPA2. This is different from your main network which, by default, is WPA2/WPA3. See if the new network you've created doesn't allow your laptop to connect.

 

Userlevel 5
Badge +7

Yes, the method described here should work for your older Windows computer. Because of your laptop’s age, there is a chance that it will not be able to “see” a WPA2/WPA3 secured network. If that happens, you must use the phone app to downgrade it to WPA/WPA2. The app is downloadable from the Apple App Store or the Android Store.

The Hidden switch is under the Network tab of the phone app. Launch the app, then tap the Network tab at the bottom of the screen. The Hidden slider is at the bottom of the configuration screen, so you will have to scroll down to see it. I leave mine off since hiding a network will not keep a dedicated hacker from using my WiFi.

IMHO, Ethernet is always preferable to wireless, but there are only two Ethernet ports on the back of my TMHI Arcadyan KVD21 5G gateway. I use one to connect to a 5-port, 1 GB switch, which I use to connect one or two devices via Ethernet. The other port is connected directly to an Apple TV. I've also successfully used TP-Link Powerline adapters in my home to extend a wired network to my wife’s computer and a TV mounted outside. They work perfectly and are combined with a WiFi range extender that covers a dead spot in one room of our house. For the record, that dead spot existed with Xfinity as well as TMHI.

Good luck with your new service!

Badge

Thank you, bocboy,2591.

Very helpful and specific answers. I am not at the location where I will be setting up my T-mobile device. Since I only have a 15 day trial period, I will wait til I am at the location in order to see if it works, hopefully in the next week or 2.

Thanks again!

bda

Have similar issue with 2009 MacBook Pro running Lion. See networks, try to connect but box asks for username and there is no user name. Apple had me create hotspot on T-Mobile phone and try to connect to that. Works fine. T-Mobile had me create 2.4Ghz network, but couldn't connect to that, either. Why does my Mac ask for user name when I try to connect directly, but not when I use hotspot? I need to access T-Mobile, but they are not making ANY progress to make this happen.

I have the same issue with my laptop. I had no trouble with 4G LTE router/modem from T-Mobile. The network would show up on my laptop. The new 5G device does not show up. What’s more, the recommendations above -- turn off Hidden, go to WPA/WPA2, and set to a 2.4Ghz network make no difference. Any other suggestions? My laptop works fine everywhere else. What is it with the 5G device?

I, too, have followed the suggested fixes in this topic, but my Dell Inspiron 1735 still does not see the T-mobile 5g network in the list of possible connections... 🤔 🥺

Userlevel 5
Badge +6

Did you follow the last paragraph of bocaboy’s first post exactly?  If so, and if your laptop still doesn’t see the new network, reboot the gateway and the laptop.

No, as the position of the 5G device is not conducive for Ethernet (wired) connection to the laptop. The settings for the gateway allows connection with a QR code, but, alas, my old laptop doesn't have that either. I will look for ways to create a QR code for the laptop... 🤔 

Userlevel 5
Badge +6

you’re not looking at bocaboy’s first post…

Here is the last paragraph from that post -  I added a few words and some bold text.

Add a new WiFi network for your laptop. Use the T-Mobile internet app (on your phone) and tap the Network tab on the bottom, then the “+” button on the lower right. Create a new 2.4 GHz WiFi network with a unique name (SSID), just for your laptop. Make sure the WPA type is WPA/WPA2. This is different from your main network which, by default, is WPA2/WPA3. See if the new network you've created doesn't allow your laptop to connect.

I have an old Dell Inspiron. I tried everything that Bocaboy said. I did both paragraph instructions.  Now my question is when i open the wifi networks, the hidden network is there.  Both hidden buttons are off. I tried logging in to the hidden network with the SSID info for the new network i made for the laptop and i did also try with the main network info too. The laptop still will not login.  And there is no network showing for either networks in my t-mobile app. 

Adding the new 2.4 wifi network worked for me.  Now my older devices are connected.   Thank you bocaboy2591. 

Hello, I’ve tried bocaboy2591 suggestion but was not successful. I even tried all the possibilities with the new wifi network and couldn’t still wasn’t able to connect or see with my Dell Windows 10.

  

I had the same issue.  The instructions are spot on.  Thanks for the information.

Reply