Printing from iphone14

  • 2 July 2023
  • 2 replies


Both our iPhone 14 and Brother printer show as connected to our kvd21.  However when we try to print from the iPhone a warning message comes up saying they cannot connect and the “privacy separator “ must be disabled.  I cannot find any mention of this when I go in to administer the kvd21 settings. What am I missing? Thanks.  Note, we connected our older desktop to the kvd21 by cable and it finds the printer and prints. 

2 replies


Sorry it took so long for me to try your suggestion.  When I entered the network settings the frequency was set to “automatic”. It would not let me choose both 2.4 and 5Ghz so I set it to simply 2.4.  The iPhone gave the same unable to connect/ privacy separator message when we tried to print.  I also tried setting the WPA setting from WPA2/WPA3 to WPA/WPA2.  In that mode the iphone14 would not connect to the kvd21 at all. Any other suggestions? Thanks 

Userlevel 5
Badge +8

@Kuikaut your problem sounds similar to those who have problems connecting to devices that require a 2.4Ghz connection. 

Question - did you setup a separate 2.4 & 5Ghz wifi network when you setup your TM gateway?

On your TM Internet app, from the Home Screen, tap “Network” at the bottom, then then see what you have. Many devices like printers and thermostats require a separate 2.4Ghz network connection. If you do not see both frequencies there, take a moment ad add both 2.4 & 5Ghz frequencies, then restart your gateway. You can use the same login as your original setup. 

I hope this solves your problem.