Solved

TMobile home internet connection issues

  • 25 May 2023
  • 9 replies
  • 1347 views

Badge

I have had Tmobile home internet for a couple months now, and I'm having issues with the modem restarting every hour and a half to 2 hours. This has been since the day I put it in. Do I have a faulty unit? Has anyone else been having these issues? Are there any updates that will fix this? 

 

Also the past few days my connection shows to be good but things won't load properly and are taking abnormally long to load. Are the servers having maintenance done to them? 

icon

Best answer by james.koon 27 May 2023, 13:47

View original

9 replies

Userlevel 5
Badge +7

The gateway rebooting on its own is not normal.

Badge

The gateway rebooting on its own is not normal.

Should I just take my gateway back to tmobile to exchange for a new one?

Userlevel 5
Badge +7

Call them first.  Good luck.  🤞

Userlevel 4
Badge +4

I have no first-hand experience with this, but I think some folks have had success by re-seating their SIM cards,,,may be worth a shot.

Userlevel 5
Badge +7

I have no first-hand experience with this, but I think some folks have had success by re-seating their SIM cards,,,may be worth a shot.

Interesting.  I would try that first.

@Brewsky0104 let us know what happens.

Badge

Thank you both for yalls help. I just spoke with a tmobile team member. She said this is a known issue with the gateway that I have and that they are sending out a new gateway to me. 

One thing to keep in mind too, especially as summertime starts to heat up. (ESP if the gateway is near a window to get good reception...).

5G Connections Create heat. Windows with Sunlight create heat. Warmer air in general removes the ability to remove heat. 5G + Sun + Warm Air = Overheating SOC = Restarts and instability.

Make sure your 5g gateway is kept cool. If needed, get a fan stand to set it on. You can get what is basically a case fan for a computer in a small enclosure for like 7 -15 bucks on Amazon. I found one that fit perfectly on top of the trashcan and it hasn’t left it.

You can find them with a USB connector for power. I bought a little A to C converter adapter, which I plugged into the otherwise unused USB port on the back of the trashcan.

Going back since I tried that a couple years ago now, the thing has been rock solid. Sometimes I’ll get to uptime of 45+ days before I need to restart, and even then it’s because it’s just a little sluggish on initial webpage loads. 

Important point: If you’re forcing air through any electronic device, be ready with compressed air at least once every couple of months. Dust on the inside is almost worse than direct sunlight. If you have a really dusty house you may need to do it every three or four months.

I’ve had a solid experience now with the trashcan for a couple of years and pull 400+ Mb/s and 60 Mb/s up. Hoping it’ll last for quite a while!

what is going on with TMOBILE?? again we have no internet connection!!! its spotting all day but extremely worse around 7:30. circling, pausing, no sound, intermittent connection, latency!!! Its so nad we cant watch TV! I'm getting ready to drop them like a hot potato! Im paying for something we cant watch!

Well glad to know I am not the only one with this issue….

 

I will say that my router was restarting on its own, and they upgraeded me to a newer version. The device should not be restarting on its own. However I am still having connectivity issues like the rest of you above. I thought it was just my router being faulty but no. Its now just straight losing connectivity. 

Reply