Can't send/receive texts that contain ""

Can't send or receive SMS text messages that contain "" so any Google short code such as those used by Google Maps & Google Photos to share just won't go thru.

This problem occurs on my Google Nexus 6P and my wife's Google Pixel too.

I can text myself a test message and it sends and receives fine but when I text myself anything that has it shows sent but is never received back.

I use T-Mobile Digits so all text messages sent and received can be seen on the Digits website... those texts that contain are not showing up.  I thought my phone was to blame so I sent text messages out directly from the Digits platform to myself, my wife and a friend containing "" and no one received them.  I thought maybe Digits was the problem (even though the Pixel is not registered with Digits) so I turned it off under the Multiple Devices section of my Profile and after 3 hours the problem hasn't been resolved.

To be fair, MMS messages that contain "" are being sent/received just fine.

Based on my testing it seems that T Mobile is filtering SMS messages that contain "".  But why and more importantly can this filter be turned off??

I am very frustrated and if this can't be resolved I'll have to find a different carrier, maybe Google Fi.

Please help! Thanks.


Best answer by tmo_marissa 12 April 2018, 00:24

View original

12 replies

Userlevel 3

Hey, @miketx​! This had me stumped a little so I turned to a colleague in the engineering department, and definitely learned a few things. Basically, it seems like your assumption is right. The links may be identified by our vendor as spam.

Even though I'm sure you're not attempting to mass market or piggyback on popular short links (like or in order to send out spam messages, because spammers can hide behind links like this (use them to circumvent detection), the system may not be able to distinguish between a good and a bad and might block them. 😥

We'd hate to see you go, but I understand if this is imperative to your business that it's a big deal. Can you try sending a full URL instead?

Userlevel 4

Hey there! Any luck with sending a full URL?

Sending a full URL is not an option when using the share button from within Google Maps & Google Photos.  The app automatically creates a tiny URL which I cannot modify.

The Google Maps mobile app creates URLs that are in the following format:

The Google Photos mobile app creates URLs that are in the following format:

I understand T-Mobile or your "vendor" wanting to block potentially harmful links hidden within a shortened URL but there's got to be a smarter way to do it because right now it's blocking some very useful sharing features built into mainstream Google/Android apps that are using these same tiny URLs.

Google disabled the URL short service for that domain. They have a new one now though. I don't know it off the top of my head though.!topic/websearch/5qWEyTSIQ9s

I read a recent article about it but can't find it now

Userlevel 4

Would you be able to user your PC browser to get the full url and see if that sends through okay?


3 years and this is STILL an issue! I just got burnt on sending a link to a Google Form over MMS.

THIS NEEDS TO BE FIXED! If T-Mobile had any sense they could at least send back a notification that they blocked your text!

@tmo_chris I understand trying to block spam, but doing it with no notification to the sender is just wrong! I have to take these same considerations as an IT Manager when I protect my network.

I sent a short url and it just doesn’t get to the other person, no idea until someone asks why i never sent the link.

Send the FULL link to the SAME place and it goes through just fine.

This is unacceptable. 

Looks like this is still ongoing. I just got blocked sending a link!! WHAT THE HECK T-Mobile??

Userlevel 5
Badge +8

Looks like this is still ongoing. I just got blocked sending a link!! WHAT THE HECK T-Mobile??


Have you tried the suggestion in the other thread?



There is a FIX. We confirmed this issue on our phone. Tested with T-Mobile. Tech found problem is "scam shield" a T-Mobile app. Fix is remove scam shield.Then go to Play store, reinstall.

One phone had issue, other two never did. Only reinstalled on one phone with the issue and it fixed it

We checked Scam Shield settings before deleting it. We did not find any setting to account for this.

Scam Shield has "Favorites" which is supposed to whitelist sources but Favoring the sender didn't fix it

Scam Shield has an adult/malicious site blocker. It was not on.

Hey I did see that in the other thread. I’ve never had Scam shield installed on any of my phones. I did go ahead and install it and made sure everything was off and the sms was still being blocked.

I tried from another T-Mobile phone and it was blocked there too.

Try sending your self a sms with the link and see if it’s blocked for you. seems to be working now but who knows what import text T-mobile will block next.

Just found my last conversation with the twitter t-mobile helper and they were blocking

Looks like that is still being blocked as well.

Userlevel 7
Badge +15

It would be nice if people were faithful and honest then all you wouldnt be so freaked out. I feel sorry for all you cheaters, scumbags, and ho's.. Hope life is good for you cause the devil gonna have fun when its his turn with you.

and yet again.

Apparently it also happens with confirmation messages from Instagram or Facebook for example to verify phone number or some change with the account. I have tried to send a message from the web to confirm my company's Instagram account but the message with the code never arrives, do any of you know how to fix this? Yesterday I was able to open my company's WhatsApp because I chose the phone call option and although I never received the call, I received a voice message where I could confirm the code but in the previous case I have not been able to.