Digits line on iPhone 11 - can call but not receive calls

  • 26 July 2023
  • 0 replies
  • 107 views

Badge

Thought I’d share my experience here, & IF anyone else is having the same issue, perhaps it will help…

 

Switched over to T-mobile (3 iPhones, 1 iPad, 1 iPhone for a DIGITS line to serve as our old home phone#).  27 years as a customer of Verizon Wireless.  Ported all numbers over, not a call or text from them.  Tha’ts about $60,000 in payments to Verizon.  Oh well, I’m glad I switched because now I actually have coverage around the college here when the kids are in town.  The students drain the cell towers to where my old non-5G provider struggled to do anything.  Even texting in this area was a struggle.  I’ll stop rambling…

 

So, I had to get this DIGITS thing to work as our home# on an old iPhone, or else my wife would ring my neck for letting that number go.  We certainly didn’t want to pay for a full phone/data line to just receive home phone calls.  Everything was smooth with the switchover until I got to this DIGITS.  Here’s what went down…

 

  1. Old iPhone 11 - set up separate Apple ID just for this phone, but not to be used for any other data use.  Need the Apple ID in order for the DIGITS App to download and work.  Would NOT need it, IF the iPhone came w/DIGITS already integrated.  moving on…
  2. Installed DIGITS App and logged in.
  3. Enabled my old Home# using the Toggle slider
  4. Set my E911 location
  5. Set ringtone
  6. Made a test call out - it worked!  Great
  7. Made a test inbound call - it worked!  Great
  8. Now I’m feeling awesome
  9. Next entered the setting for the Home# again to set a “Personal Voicemail” greeting, vs. the default greeting
  10. Recorded a custom greeting
  11. Made a test inbound call - it did NOT work!  The phone did not ring, no indication of missed call.  All I heard was a robot message saying “Please wait while we connect the call”,  Then after about 5 seconds, the same voice said the same thing.  Then it dropped me to my new personal voicemail greeting.  Alas, the bump in the road.
  12. I tried many things to get the phone to ring including restarting the phone, nothing worked.
  13. I called T-Mobile customer service... (odd, this is #13, hmm).  Anyway, this was 1 of 3 calls over a week, last week, to tech support.  I explained exactly what I had done in the above steps.  Each time they walked me through many steps, the same steps each time, including reprovisioning the phone number, numerous restarts, and the same results.  The same problem as I stated in #11 above was happening still.  The technician said they had followed all the steps they had to try to correct the problem and they needed to create a ticket for their engineers to review it and call me back.  No one has ever called me back.  This is the disappointing part.
  14. I let the weekend go by, had to travel to where our daughter is living to help her move closer to her new job.  I’d have to play with this problem again later.
  15. Today, still the same problem exists.  I had tried testing again just to see if perhaps the engineers worked their magic on the backend but not such luck.
  16. I fixed it!  Here’s how…

SOLUTION FOR ME:

  1. Went into DIGITS App, and again accessed the setting for my DIGITS number.
  2. I figured the problem must have had something to do with the setting up of my personal voicemail greeting.
  3. I toggled off to disable my personal greeting, which reset my greeting back to the default system greeting.
  4. I made an inbound test call, and voila! the phone rang again, and after several rings, I got the default system voicemail greeting.
  5. I then toggled back “on” my personal greeting, and to my surprise the inbound test call WORKED this time.  The phone rang, I could see it complete as a missed call, and my personal greeting was produced.
  6. Happy camper!!!  except for the no call-back thing.
  7. In 27 years I’ll be almost 80, that’s another $60-$70g’s to someone, Lord willing.  Perhaps it will be T-mobile, it’s their call...

Sorry for the storyline.  Cheers everyone!!

 

 


0 replies

Be the first to reply!

Reply