Question

New Phone, not getting texts from son

  • 7 February 2021
  • 13 replies
  • 8752 views

Badge

I upgraded my phone 4 days ago to the S21 Ultra, and since then I am not receiving texts from my son, who lives with us and is on the same account.  He receives my texts fine, and I seem to have no problem receiving texts from other people, including my wife in the same house. I’ve gotten texts from at least 5 people.  

I’ve restarted my phone, and tried turning off wifi to make sure it’s not a wifi calling issue.  Any ideas what else I can do?

 


13 replies

Userlevel 7
Badge +11

If you upgraded from an iPhone, he may have to mark your address to not use iMessage.

Badge

If you upgraded from an iPhone, he may have to mark your address to not use iMessage.


Thanks. No iPhone in play here.  My new and prior phone were both Samsung, as is my son’s phone.

 

Glen

 

Userlevel 7
Badge +11

If you upgraded from an iPhone, he may have to mark your address to not use iMessage.


Thanks. No iPhone in play here.  My new and prior phone were both Samsung, as is my son’s phone.

 

And you’re using the default messaging app? Not Signal or WhatsApp? Strange.

Badge

And you’re using the default messaging app? Not Signal or WhatsApp? Strange.

Yes, the Samsung default messaging app. I actually tried switching to Google’s Messages app as a test, but still no messages from him. I’ve since swapped back to Samsung Messages.

Prior to changing phones, I have messages every few days from him.  After replacing the phone, he’s sent me 8-10 messages, and not one has come through.

In that same time I’ve gotten dozens of messages from at least a dozen senders, including people and computer-automated texts, like password resets.

In case it’s relevant, I did use the new SIM card that came with the phone upgrade.

 

Glen

Userlevel 7
Badge +16

the sim itself shouldnt affect texting one person though. when you switched to the new phone did it transfer all the text history etc from your prior phone? you might try deleting all of his info from your phone including text history, voicemail history, call history etc..restart the phone..double check that nothing was missed..then put all his info back in.

Badge

the sim itself shouldnt affect texting one person though. when you switched to the new phone did it transfer all the text history etc from your prior phone? you might try deleting all of his info from your phone including text history, voicemail history, call history etc..restart the phone..double check that nothing was missed..then put all his info back in.

Thanks for the suggestion.  Yes, I did transfer text history from my prior phone.  I just deleted all texts and call history for him, rebooted, and had him send a message.  Unfortunately, no change.  

 

I just checked my own settings again.  I don’t have any blocked numbers, and “block unknown/private numbers” is turned off.  I looked for other settings that might  be relevant, but can’t find anything. 

 

This seems to be a T-mobile issue.  Does T-mobile monitor this  board?

Thanks,

Glen

 

Userlevel 7
Badge +16

unfortunately no..this site here is mainly peer to peer with a few moderators/admins to keep order.

 

you can also contact their TForce via Facebook or Twitter..personally have not contacted them that way but have heard its a bit easier than calling in

 

yeah it usually isnt a common thing but switching from one phone to another can at times jumble up some of the info being transferred..

I don’t think switching or changing phones would jumble things up. If you had an iPhone previously, sure, but another Android? I had the last Galaxy phone, last year, and ended up returning it for an iPhone. One problem I was having was it was not sending messages to certain individuals and it would sometimes not receive. Come to find out the Default Samsung messaging app had a little button on the bottom right, that floated, that let you either choose how you want to send the message via phone or SIM CARD. The phone was glitching and would randomly revert to phone when it needed to be in SIM CARD mode to send the message. I had nothing but problems each time I went to try the new “Galaxy” regardless of whatever the revision. They skin the entire UI and bloat it down with Samsung APPS where you have to be logged into their services. SAMSUNG = DA DOO DOO in my Opinion.

 

I was in the T-Mobile store for over a hour and everyone had to chime in to see if they could fix it, then telling me it was my fault till they found it it was the device and was like oh well, want to upgrade?

Badge

We tried again today and suddenly it worked.  No idea what changed, but it seems to be resolved.

 

Thanks,

Glen

I had a similar problem where some texts would hang while other would go through just fine. Naturally, it would happen at critical times when communicating with my spouse… but, I digress. My S9 had similar issues until I found that clearing the partition cache and disabling the wifi calling resolved the issue. I did the same with the S21 and so far, so good. We’ll see. But, it’s a little disappointing to get a new phone and have these sorts of problems out of the box…

I’m seeing this thread a couple months late, as I noticed the same problem on T-mobile this morning after upgrading to their new 5G Samsung (great price: free) a couple days ago, while keeping my same phone number. This is with Google chat on both phones (v. 7.8.064 on old, v. 12.1.10.192 on new.). My old phone no longer has a sim card in it and was powered off, but still the chats were going there.

I found this pair of articles put up by a different carrier (Republic) via a web search just now, and they worked for me too on T-mo. This solution does require having access to your retired phone - nothing needs to be done on the new one. There are just a couple  steps: 1) on the old phone, open the Chat app, click the 3 dots at top right, and click on “Settings” (2nd option from bottom); 2) from “Settings”, click on “Chat features”, its top-most option. 3) In “Chat features”, click on its own top option, “Enable chat features. Use Wi-Fi or data for messaging when available.” Slide that toggle from right to left, to disable.

That’s it. Once I did that, I was able to receive a fresh text from my wife’s phone immediately, whereas just a couple hours before that her texts and others’ were going to my old phone instead.

Hope this helps other users, too!

Jim

https://help.republicwireless.com/hc/en-us/articles/360041204053-Messages-Still-Delivered-to-Old-Phone-After-Activating-New-Phone

https://help.republicwireless.com/hc/en-us/articles/360022451294

 

Perfect.

I am having the same problem, it started last night. I stopped receiving and stopped sending. After doing all these steps as well now i can send not receive. I already called customer service. Side note i switched from sprint to tmobile, same brand Samsung s10 plus to s21 ultra and a new number. I used google Messenger and default Samsung app. When i was able to start sending every message my wife sent in 24 hours flooded my phone. I received a few more then an hour later same deal nothing coming thru. I do have access to the old phone but its a completely different numer I don't think that would help. Please help me

Reply