Google Chat FeaturesRCS status stuck at: Setting Up, Trying to Verify my phone number

  • 25 July 2021
  • 9 replies
  • 5017 views

Badge

Hello All. I have great news. My Google Messages RCS is finally working. Here is how I did it, please read this very carefully. Read my original post in Recommemded Answer green color above link.

You must disable chat on all previous devices by going here and (on bottom of this site) follow directions:  https://messages.google.com/disable-chat

Then you must TURN RCS CHAT FEATURES OFF in GM and wait exactly 10 days.

If you turn RCS ON before 10 days are gone, the clock starts all over again for 10 days.

You literally have to be patient and wait 10 days with the RCS OFF for 10 days.

After 10 days, turn RCS ON and you will see CONNECTED !!!!

 

I repeat to you again, STEP 1 is: You must deactivate all prior devices' GM phone number associations by following the bottom instructions on this site:  https://messages.google.com/disable-chat and if you get error message like: contact your carrier or you requested code too many times, disregard it. 

Then STEP 2, TURN RCS OFF FOR 10 DAYS in GM and wait 10 days. If you potz around and turn on RCS in GM BEFORE 10 days are gone, you must start 10-days clock all over again! Just be patgient for 10 days.

STEP 3: On day #10, Clear Cache in GM and turn on RCS and you will see that you are GREEN LIGHT in RCS as CONNECTED. The best thing to do for this step 3 is to: completely uninstall Google messages and completely uninstall Carrier Services and then reinstall Google messages and reinstall Carrier Services. If you do this in this step, your cash and Data will be cleared.

 

I am an expert in this now as I have triued everything: Contacted carrier, contacted device manufacturer, uninstalled Carrier Services and Reinstalled Carrier services. This has nothing with the carrier nor device manufacturer nor Samsung nor Motorola nor OnePlus. This RCS trying to verify.... occurs because when you switched your device, or when you switched SIM, or when u ported a number, or when you activated Google account email on another device, you DID NOT turn OFF RCS in GM or did not turn OFF RCS in the native Messages App, and  now Google's RCS sees that you have RCS active in multiple devices/accounts/phone numbers, in which RCS remained TURNED ON, and Google RCS Server gets confused. What you need to do is STEP 1, STEP 2 and Step 3. Step 1 will deactivate ALL the shmootz you created and Step 1 will DEACTIVATE ALL devices' and all phone numbers' and all accounts' RCS GM once and for all. Step 2 does the "reset with google". Step 2 takes you OFF of "blacklist" at google. I see some people waited 8 days-not good. You absolutely must wait 10 days (not business days) - 10 CALENDAR DAYS and the day you do step 1, and step 2 is day #1.

 

And  by the way: Please make sure you have CARRIER SERVICES INSTALLED AND UPDATED from Google Play Store as well as latest updates of GM, and please update your device firmware by checking for update in SOftware Update in Settings. Basically please update your device firmware and all device apps in Google Play Store  all aroung before proceeding with Steps 1,2,3.

 

Let me know, but dont tell me that it doesnt work because you did not wait 10 full days. You must wait 10 days and then reply here and let me know.

 

If you are unable to send or receive messages on Google messages app, this post does not apply to you. What I recommend you do is to:  completely uninstall Google messages and completely uninstall Carrier Services. Then reinstall Google messages and reinstall Carrier Services. Then contact your cell phone carrier and ask them to refresh your connection and make sure that your messages and data features are turned on on the carrier side and make sure that Short Code Programming is also turned on, on the carrier side. So make sure messaging, data and short code programming is also turned on, on the carrier side. And meanwhile do not touch the toggle for full 10 days. In 10 days toggle ON and u will be set.

 

I wrote 3 steps: make sure you read this twice to fully understand and follow my directions.

 

From now on, you need to understand the concept, to make sure that this RCS feature not turning on again never happens to you again, you FIRST must make sure that before you change your devices, or change SIM cards in devices, or change Google accounts in devices, you absolutely must make sure that the first thing you do is: TOGGLE RCS CHAT OFF in GM FIRST before changing devices, sims or accnts! Otherwise, the Google server will be very confused and will Blacklist Your account, your device and your phone number by yourhaving too many RCS features toggled on in GM everywhere. To get UNblacklisted and turning RCS back to ON, you must read the steps 1,2 and 3.

When i say 10 days, i mean 10 calendar days, not 10 business days. Day #1 starts the moment you toggle OFF rcs and keep it OFFfor 10 calendar days.

 

You absolutely must respect the 10-DAY TOGGLE OFF, as i explained to you in Step 2. This step 2 is the only step that will UN-blacklist your phone number, you GM, and your GM account from the Google server.  Please respect the 10day toggle off. If you potz around with toggle, you will not have RCS, and your 10day clock will start all over again with every time u potz around with Toggle.

 

ALSO: ON DAY # 10, WHEN YOU TOGGLE THE RCS ON, IN THE GOOGLE MESSAGES APP, THE GOOGLE MESSAGES WILL ASK YOU TO RE-TYPE YOUR CELL PHONE NUMBER TO VERIFY IT WITH GOOGLE (THAT SAME DAY 10), PLEASE RETYPE THE PHONE NUMBER VERY SLOWLY AND CORRECTLY-BECAUSE: IF YOU TYPE YOUR NUMBER INCORRECTLY, EVEN BY 1 DIDIGT, YOUR STEPS 1,2 AND 3 (WITH 10-DAYS TOGGLE OFF) MAY START AGAIN. PLEASE SLOW DOWN AND BE VERY CAREFUL WHEN YOU RE-TYPE YOUR CELL NUMBER INTO GM APP WHEN IT RE-ASKS YOU TO VERIFY YOUR CELL NUMBER ON THAT  DAY #10. PLEASE SLOW DOWN AND BREATH SLOWLY WHEN TYPING YOUR CELL ON DAY 10 (AFTER YOU TOGGLE RCS on ON SAME DAY #10.)


9 replies

this actually worked for me you just need to wait at least 10 days before you do it. I tried at 7 and it didn't work. 

I have this issue but I didn’t change phones. I only changed from Google Fi to T-Mobile.

I have this issue but I didn’t change phones. I only changed from Google Fi to T-Mobile.

I have the exact same circumstance. Trying this now; we'll see if the method works for me on Feb 2

And it worked! I didn't uninstall and reinstall GM and Carrier Services; I just cleared the GM cache and made sure everything was updated. Thanks @GM90764 !

I am glad this trick has worked for others, but its not a fix for everyone.  I have attempted multiple times to follow this and many other instructions to get RCS back on my unlocked Samsung S22 Ultra with no success.  I have tried Esim, 2 new physical sims, reset the phone multiple times, waitied 8, 10, and 15 days… removed Google Messages via ADB, and used another for that time, just in case… tried beta versions of Carrier Services and Messages, and nothing works.

I can pop the sim in one of my Pixel phones, and instantly I have RCS working, back to the S22 and nothing.

The only constant here is that Tmobile is providing RCS services when the sim is in the S22U, and the Pixel is using regular Jibe server provided by Google.

All of this started when I had eSim and Physical sim both going at the same time, and it worked fine for a while, but then quit when we started getting RCS server provided by Tmobile.

There needs to be a way that TMO can reset a customer on thier RCS server via their IMEI or something, because mine seems perm stuck, and there is no way on the customer side to do it, other than buying a new phone or requesting a new phone number.

Userlevel 6
Badge +12

This method only works with iDevices switchover.  Been a while… Google Jibe servers don’t work well with Dual Sims.  It’s something Google needs to fix on their end to fix your issue.  I read it somewhere on Google Forums a few months back.  T-Mobile has little control on fixing it.  T-Mobile can’t just flip a switch on their end and fix it.  What you are looking for Google would need to implement that on their end.

Userlevel 6
Badge +12

did you try this?  This is from Google which may fix your issue

https://messages.google.com/disable-chat

Thanks for the comment.  Google Jibe worked fine prior with dual sime…  the issue is that this is Tmobile RCS server, not the Google Jibe server.  I have no issues with my sim in the Pixel using Google’s server… works fine.

 When on an unlocked S22 series, the Google messages client defaults to the Tmobile carrier provided RCS server, with the “custom” samsung version of the Google Messages client.

I don’t even care about dual sim at this point, and I guess I shouldn’t care about RCS, but we were using it with my family, and when it works, its very nice.

This is why RCS sucks for now… it can’t get acceptance when we have to go through hoops for such a simple thing.  They should have never let the providers do their own servers.. I see AT&T users complain about their provider based jibe server as well.

 

Userlevel 6
Badge +12

I have an unlocked S22U and Pixel 6 as well and it works fine for both.  Google support forums have thousands around the world with your issue.  Especially when playing around with dual sim.  It’s not T-Mobile servers causing the problem.  Some people had to leave their sim in a single device, and/or stop using dual sim and wait then magically it fixed itself.

Google didn’t invent RCS.  They just bought out Jibe and began marketing it heavily. Google messages isn’t modified.  Only carriers did the right thing.  Google services combined they have your whole history and if you think they can’t Identify you that is a major problem.  They have your browser, location, view, phone number, who you text, your bank/card account, devices you use, and a slew of other things.  Remember you are the product for Google.

Did you disable RCS on your Pixel 6 before switching?  Also did you turn off RCS server side on Google?  I posted another post before your reply it’s under moderation.  Try going to Google support forums for messaging there should be a sticky/pinned where you can disable RCS server side.  Just give it a few.  Clear Cache on both devices, and then try turning on RCS on your S22.

Reply