MMS not working with Data off and WiFi on for Samsung Galaxy S20+ (NEW)

  • 25 August 2020
  • 8 replies
  • 1780 views

Badge

So I purchased a new phone and switched from Verizon. Only 2 days later, I noticed that I can’t send a regular basic picture text or Image (MMS) to anyone or receive them while on my Work WiFi and my Data turned off. I can’t even text in a group text that consist of 6 to 7 people?

 

I have always owned Samsung and my previous Galaxy S9+ for 3 years, I have always turned my data off and turn my wifi on and everything ran Smooth. I am needing some help or clarification on whether if this is a T-Mobile thing compared to what Verizon was working for me? 

 

No 1 at the store seems to be of any help or understanding unless they use Samsung. They would just say, they’re an Iphone user and so forth. 

 

I have NEVER had to turn my data on just to send a Picture text or receive and text in group chat (MMS) I have always turned my WiFi on and data off for years and it worked fine until I switched to T-mobile. Please help. 

 

jeff702777 20 days ago

 was driven mad by this until today when I found a solution...copy the apn settings and make sure to put port 80 in!
 

View original

This topic has been closed for comments

8 replies

Userlevel 4
Badge +7

if memory serves it came in a few updates back..basically the phone must authenticate via mobile data prior to it sending via wifi… was never an issue before however now you see quite a few devices out there running into this now right after an update..cant remember if it came in with a OS update or a security patch..

 

keep in mind..my memory isnt the greatest at times..but i DO remember this not being an issue until a update pushed through from the OEM and then complaints started rolling in..but same scenario..no to barely a mobile data signal and you run into this..

Badge

Thanks for the feedback. I don’t have much knowledge of using a phone much and don’t know if it was an update out of the box, brand new? or when I took it to the T-Mobile store 2 days later from fresh out of the box, they updated at the store. 

 

I just never had any issues up until switching from Verizon to T-Mobile a few days ago. 

 

My Samsung galaxy S9+ was updated and ran fine and everything worked. I just don’t understand how a Brand new phone can’t send MMS on Wifi with no Data on. Must be a T-Mobile thing or my phone is defective?

Userlevel 4
Badge +7

nah..i can snag numerous same scenario threads from the Verizon site as well  lol. ...and Sprint..the main thing i have came across with this has usually been all Samsung devices (not sure if they went a tad bit to aggressive with its authentication process or what exactly)...with a decently small amount of scattered other devices..a small enough amount that i cant remember which devices they were lol.

Badge

I had this problem, then found a solution on reddit.

the APN type needs to include internet+MMS.

if you cannot edit your current APN, add one and make all settings identical.

in the APN type field, if it has internet, simply add +MMS. if not, add internet+MMS.

should look something like this:

default,xcap,internet+MMS,supl

No guarantee but I removed and added this several times on my Moto G7 to prove it.

 was driven mad by this until today when I found a solution...copy the apn settings and make sure to put port 80 in!
 

 was driven mad by this until today when I found a solution...copy the apn settings and make sure to put port 80 in!
 

Hey Jeff, where do you add port 80? I have a new S20+ and it's driving me CRAZY that I can't send MMS

 was driven mad by this until today when I found a solution...copy the apn settings and make sure to put port 80 in!
 

Hey Jeff, where do you add port 80? I have a new S20+ and it's driving me CRAZY that I can't send MMS

  • Multimedia message port: 80

 was driven mad by this until today when I found a solution...copy the apn settings and make sure to put port 80 in!
 

Hey Jeff, where do you add port 80? I have a new S20+ and it's driving me CRAZY that I can't send MMS

go to settings then connections then  mobile networks then access point names then click the apn you created