Solved

My number is showing up Private after new s22+ software update!

  • 18 May 2024
  • 3 replies
  • 155 views

Badge

So today out of no where my number started showing up private when I call my husband and daughter's phone (they both have Galaxy S22+ as well). So I restarted it. That didn't work.  Called Tmobile customer service they had me try some things but it hasn't worked.  Now my daughter's and husband's number show up as private when early today it was only mine doing it. But when I call my other son (Galaxy S21+) and daughter (iPhone 14) my number shows up with the name they stored me under.  Only thing I can think of is the new software update we just did on our phones. We 3 have the same phones (Galaxy S22+) One UI version 6.1 Android version 14. Anyone else having this issue? Help please!

icon

Best answer by syaoran 18 May 2024, 11:53

View original

3 replies

Userlevel 7
Badge +15

Samsung hides this option fairly well.  Go into your dialer app, tap on the 3 dots in the top right corner, tap Settings.  Scroll down to where it says, Supplementary Services and tap that.  It will take a moment to load.  The first option should be, Show your Caller ID.  Network Default should be selected but you can tap on the option and select, Always, if Network Default is hiding your Caller ID from being sent when making outgoing calls. 

Badge

Thank you, Syaoran! Customer service did have me try that when I was talking to them yesterday. But the Good news is that my number and my husband's is showing up again. I'm just waiting for my daugther to call, to see if hers is working now too. I wonder what caused it. It was really weird and the fact it was only doing it with our Galaxy S22+. Thank you again I appreciate the time you took to reply to my post.  

I am having this issue with multiple phones on my plan. Has something changed recently on T-Mobile’s end? I have an S22 Ultra but it is also happening on an Iphone and a OnePlus phone where incoming calls that are contacts show up as private number.

Reply