Question

Pixel 6 Pro doesnt work on 5G UC

  • 13 November 2021
  • 6 replies
  • 225 views

Userlevel 2
Badge

Anyone have any ideas? I can't call or text on 5G UC. It's shows signal and on network but nothing works.

 

I had to disable 5G and reboot my phone to get it to work. The Pixel also has trouble moving from wifi calling to mobile and will say disconnected like this even though it shows mobile connectivity.

 

Pixel 6 Pro. Purchased from and shipped by T-Mobile. On T-Mobile network. Northern Colorado.

 

 


6 replies

Userlevel 7
Badge +14

I’m guessing that the network for 5G in your area either isn’t 5G SA compatible or the Pixel 6’s need an update to make use of 5G SA.  5G NSA is data only.  In your network settings, is your device set to use 2G/3G/4G LTE/5G?

I bought the unlocked Pixel 6 Pro from the Google store, and it's working just fine for me. I activated it on the eSIM through my Sprint account. 

Have you tried accessing Testing Phone Information? It has all sorts of options to choose different combinations of LTE, 5G, 4G, GSM, WCDMA, NR, and etc. Dial this code *#*#4636#*#* like you're making a phone call, then tap Phone Information, and next tap on Set Preferred Network Type. You'll see a drop down selection of network choices, and toggle switches for VoLTE, Wi-Fi calling, and many more.

 

I had this issue on my S21U once UC started showing up. This is what worked for me.

 

Go to device settings. Then connections. Then sim card manager. Deactivate the SIM. Wait about 15 seconds. Reactivate sim. Enjoy faster speeds.

 

Hope that helps. 

Userlevel 2
Badge

I had this issue on my S21U once UC started showing up. This is what worked for me.

 

Go to device settings. Then connections. Then sim card manager. Deactivate the SIM. Wait about 15 seconds. Reactivate sim. Enjoy faster speeds.

 

Hope that helps. 

I did this tonight. Tomorrow I'll be in the UC area again. We will see!

Userlevel 2
Badge

Still not working unfortunately, I can get internet no problem. Phone calls and text messages do not work. Text messages say sending and then they don't send and it shows error 111.

I have the exact same issue in my pixel 6 pro in Maryland. I'm in the DC suburbs. This seems to happen most when I'm driving. Once the 5gUC icon appears,I lose call and text functionality. Only a reboot works and not always the first time. TMobile / Google - please fix this for us! 

Reply