Solved

apple watch series 6 no data on cellular

  • 6 December 2020
  • 14 replies
  • 2851 views

Userlevel 1
Badge

I have been having serious issues with Apple Watch cellular plan on T-Mobile. When my phone is on cellular, Even if I have 3 or 4 bars of reception, doesn’t matter, I cannot do anything that needs data. It just says, no internet connection. In cellular under settings it shows plan as T-Mobile, status: no connection. Interestingly, I can make calls on my watch over cellular, but no data connection. I have had discussions with different T-mobile reps, including senior technical support assistants, but no solution so far. I also talked to Apple support, they run a remote diagnostics on my watch, and I was told that nothing was wrong. I tried unpairing, deleting the watch and pairing again, removing the cellular plan and adding again, doing a network reset on my iPhone, unpairing and pairing back the DIGITS number associated with my Apple Watch. None of these worked. I can occasionally get data connection when I move far away from my neighborhood with my watch, leaving my phone home, but that needs turning airplane mode off and on, when I am miles away from my phone. Interestingly, when I come back to my neighborhood while the data is working on the watch, it stays in data-working state, where the location I cannot normally get data connection. After my watch connects back to my phone and disconnects again in my neighborhood, same story goes on, no data connection on watch, can make calls, and I need to move miles away from my region and toggle airplane mode on and off to get data. It is being super frustrating and nobody could help so far. Is there anyone who can have a solution for this?

 

 

icon

Best answer by tmo_mike_c 31 December 2020, 17:34

I’d double check for software updates to make sure it’s running the latest software. If the issue is following you to multiple locations, checking on or filing a Trouble Ticket with our engineers is the best route. If you’ve filed one already, are Tech Care team can check on it.

View original

This topic has been closed for comments

14 replies

I’m having the exact same issue with Series 6.  If I remove T-Mobile from the watch, and re-add, cellular data works for around 5 minutes (the ‘Cellular’ section of the ‘Settings’ shows ‘Connected’).  Afterwards, it only ever shows ‘No Connection’ and I cannot ever get it to work...

Phone calls works on it regardless of the ‘No Connection’ message.

Did you ever figure the problem out?

Userlevel 1
Badge

I’m having the exact same issue with Series 6.  If I remove T-Mobile from the watch, and re-add, cellular data works for around 5 minutes (the ‘Cellular’ section of the ‘Settings’ shows ‘Connected’).  Afterwards, it only ever shows ‘No Connection’ and I cannot ever get it to work...

Phone calls works on it regardless of the ‘No Connection’ message.

Did you ever figure the problem out?

Unfortunately not. I had too many phone conversations with customer support, I talked to two different technical support specialists, one of them told me they cannot offer more support because my Apple Watch is not a T-Mobile Apple Watch (I did buy it directly from Apple). I didn’t even know there is such a thing as T-Mobile Apple Watch. The second specialist told me the issue I am having is “weird” he would create a ticket with network engineers, and he thinks the problem is related to my location, and he would call me back, which never happened.

I ended up switching to another carrier that supports Apple Watch cellular, paying more, but everything just works fine.

End of story with T-Mobile. It only lasted a month.

 

 

 

Userlevel 6
Badge +14

I’d double check for software updates to make sure it’s running the latest software. If the issue is following you to multiple locations, checking on or filing a Trouble Ticket with our engineers is the best route. If you’ve filed one already, are Tech Care team can check on it.

I am having this same exact issue.  Two different watches same issue.  Calls go through but that’s it.  Tech support has repaired the watch so many times now I’ve lost count.  Not sure what to do at this point. 

Exact. Same. Issue.  Filed a ticket… got it escalated twice.  Rep finally told me they give up.

At my house, when I go for my run, I get “No Connection” for the first mile or so even though it shows 2-4 dots of signal.  Calls will come through, but no data.  Once I get a mile or so away from the house, I can get things working again by toggling cellular off/on, but that only works until the next run.

Have a AppleWatch 6 cellular. It will make outgoing calls cellular but will not receive incoming calls.  If you call the AppleWatch phone number you will get a message the “the subscriber line you have reached can not accept calls at this time”.

Obviously the incoming call is stopped by Tmobile somewhere along the line so it never gets to the watch.  I have spent over 20 hours on hold and visiting a store.  Paired, unpaired, deleted and re-activsted, etc. etc.

After my last attempt I was able to make outgoing calls, but that only lasted one hour.  Now, again, only outgoing call on cellular.

The people customer support are are of no help because this is a technical issue beyond their expertise and the people at “Digits” never get back to you.  Bottom line is that will soon will be switching carriers just like the gentleman above, and pay a little more, but at least the hardware will work properly.  Is like tech. support ad digits is completely blind to this particular issue and they just go round and round ….

There is a bug in your system guys … go find it and fix it … is not a “watch - phone” problem … is your buggy Tmobile software.

First time ever writing a review or making a comment on a message board.  Wish I was cool enough to have a Twitter account because I’ve heard commenting directly on a company’s Twitter account will actually achieve something.  I know me writing here won't change anything because T-Mobile/Apple are too large to know (or possibly care) about this thread but I’m writing for the customers that are confused or think they are going crazy.  

Let me assure you, you’re not going crazy.  The cellular “add on” line that is connected to the Series 6 Apple watch simply does not work properly.  I just spent 8 solid hours making sure everything had the latest update, resetting my Iphone and Apple Watch, starting from scratch multiple times only to find out that it just does not work.  

When your iphone is right by you, the Series 6 Apple Watch will work perfectly.  As soon as you are out of range of your iphone, you will have ZERO cellular data on your Apple Watch.  Can’t use Siri, can’t stream music, can’t email or text or do anything.  I do not have the technical vocabulary to explain what is happening but I can tell you that it has something to do with the two lines (iphone number and the ‘add on’ phone number given to the Apple Watch) not communicating properly.  

I sat on hold for an hour last night while my phone call was escalated to “advanced technical support”.  After an hour, I was hung up on.  I’m not even calling back now.  It won’t matter anyhow.  Nobody at T-Mobile has a clue how to fix this.  I’m sure their “advanced technical support” is just waiting on the two or three engineers that have a clue to just fix this issue at the highest level and then the problem will go away.  Until then though, THE SERIES 6 APPLE WATCH WILL NOT CONNECT TO T-MOBILE’S CELLULAR DATA PLAN WHEN YOU ARE OUT OF RANGE OF YOUR IPHONE.  That is the bottom line.  

When I talked to Apple about the problem, their rep didn’t even know that it was possible to have an Apple Watch that could be out of range from the paired iphone AND make calls and text and stream music and so on.  I almost fell out of my chair when he told me that.  Anyhow, after being put on hold, he came back and said, “You need to contact your carrier with any cellular problems you have.  The Apple Watch is not defective”.  

So, I’m not even going to spend any more time on it because it will just be another waste of a day.  I’m just going to return the watch and either exchange it for an earlier version that actually works or just wait 6 months for them to fix this glitch and buy one then.

Honestly, I just hope writing this will save someone hours in research, phone calls and online searches trying to figure out what they’re doing wrong.  Let me help……….you’re not doing anything wrong.  It just does not work.

This is the first post I found on the T-mobile site that explains my situation perfectly. I am in the exact same boat, I cannot get T-mobile cellular data on my apple watch series 6. I have spent a grand total of 8+ hours talking with customer representatives/being escalated/waiting on hold. I am hoping that somebody from T-Mobile will see this and respond. Really would like a path forward on this one.

TMobile is either unwilling or unable (or both) to fix the issue described in this forum.  Apparently TMobile doesn't read these forums, and their replies about “download the latest software” is a “pass the buck” non-answer.  TMobile doesn't even acknowledge the issue exists, so as not to invest the resources needed to fix it.

Hour and hours and hours and hangups with their alleged “technical support” is great experience at playing merry go round forever.

In my particular issue APPLE WATCH MAKES OUTGOING CALLS ONLY WHEN ON CELLULAR.

    INCOMING CALLS ARE BLOCKED WITH A MESSAGE “The subscriber you are trying to reach is not available at this time”      

Was planning on trying out an adding the “new” TMobile tv and streaming service … no chance, … where is the customer service if I have an issue with it?, or any future TMobile add-ons.

 

 

Having similar issues with my Series 6 watch. If I am at home I can connect to cellular and receive and make calls. However if I go to settings on my watch and check cellular, always no connection. So I can’t pull any data. As a runner in the northeast this is a pain becase I have to go a ¼ mile north from my house to have a connection that allows me to get data. When it is cold I dont want to play with my watch to start streaming music. I have a series  3 that does not have this issue, so it must be just the series 6. I dealt with Apple but they don’t have a clue. This is obviously a software glitch. When I purchased the watch last September everything was ok. One of the Apple watchOS updates caused the problem I believe.Also, sometimes if I get a call I lose the data connection. Very frustrating, maybe time to try another carrier.

Same issue. Why did I 1) buy the Apple Watch with Connection for the extra cost 2) pay the monthly connection fee to TMobile. This is ridiculous.

I’m having the exact same issue as mentioned before with the apple watch SE. The watch is bought from Apple directly and I just added the plan that was suggested via T-Mobile. 
I just want to pile on in the hope that T-Mobile does something about this issue. 

I remember that there were similar problems with my same T-Mobile plan and the apple watch series 3. So it can’t be an entirely new issue. 
That is exactly the kind of problem that will get people like me with 4 lines to change the carrier for everything. 

Same issue as described above except with a different watch model.  I’ll head out for a run miles away from my phone or WiFi.  Watch shows full cellular signal.  Calls come in just fine as do SMS messages.  Siri, music streaming, and other applications that require data do not work.  I’ve spent hours on the line with support for this with no resolution.  Very frustrating.  

 

Apple Watch Series 4

Model A1976

WatchOS 7.3

I’d double check for software updates to make sure it’s running the latest software. If the issue is following you to multiple locations, checking on or filing a Trouble Ticket with our engineers is the best route. If you’ve filed one already, are Tech Care team can check on it.

I really hope that y’all try to get this problem fixed. I have a series 6 and it will show “no connection” for the status of my plan. And I’ll still be able to make calls but I can’t send or receive my texts. I’ve spoken to about 6 different people and there seems to be no solution. It’s very frustrating to be paying for cellular and not receiving  what I have paid for. And I’ve pretty much been getting the run around from tech support and digits representatives. They will keep saying that it is working since I can make calls which is not the case at all. It isn’t working when it saying “no connection” since I cannot send and receive my text messages. I didn’t always have this problem. And I see many people on this forum have the same problem with the no connection and also with the iccid saying “no sim” it does it on and off. hopefully the engineers can do something about this. They need to acknowledge that this problem does exist and try to find a solution for it.  I am highly disappointed right now. I have just file a ticket with someone in the digits department & they said they will get back to me, which I have a GREAT feeling that they will not. As others on here have said they not got a response back. This needs to be fixed.