Solved

Cannot connect to home internet app.

  • 29 November 2022
  • 11 replies
  • 854 views

Badge

I cannot connect to the setup app unless I do a factory reset. After I connect to the app one time that is it, it will not connect a second time. I reset the iPhone but that doesn't help. I have the most current version of the app and it will not connect. Wi-Fi works during this the only issue is the iPhone not opening the app.

-Current version of IOS, did a full restore as well.

-Current version of T-Mobile Home Internet app.

-Wi-Fi working well.

-Cellular and Wi-Fi enabled for app.

 I talked to T-Mobile, and they supposedly fixed this but here I am. By the way unless you have a whole lot of spare time, I would not talk to them over twitter, horrendous service that way.

icon

Best answer by iTinkeralot 13 December 2022, 16:18

View original

11 replies

I have had the exact same issue.  I own two of them for two different homes, and both devices are doing the exact same thing.  I have used this service for going on two years.  I’ve had very few issues with it, but it is clear that the device interfaces are either purposely designed to lock us out or the programming is poor.  I can’t knock the performance, but there are times I want and need to go into the app.  This is beyond irritating.

Userlevel 7
Badge +8

The T-Mobile home internet mobile application on an iPhone is a very frustrating experience. My phone reports it is connected to the proper SSID and it IS. If I pull up the mobile application it wants to get me started. It is too stupid to know this from the start that everything is setup and working. So, I tell it to connect to the network which the phone is connected to. It does its normal dance and presents me with the connect button and then spins and just presents the same screen. OK so here we are. I have discovered just WAIT FOR IT. I mean lay the phone down and WAIT. Give it 30-60 seconds and it will sometimes whoohoo connect. On a good day that works. On average it is a battle playing that game of connect 4-5 times if I am determined. 

I have an OLD Pixel with no SIMM that of course is Android and that seems to work more as it should. They have not managed to make the application function very well on iOS. It has been doing the exact same behavior for the past 2 years so I am not optimistic that the programmers will ever fix it on the iPhone. So, patience seem to be the key. You can’t rush the application. It does what it wants in its own time. 

The iPhone app was working fine for 8 months, then I had the router replaced and now it doesn’t work.   Does anyone from T-Mobile moderate this and can we get advice?

Ok I fixed my issue.  I deleted the app, then went into the Wi-Fi settings on my iPhone and ‘forgot’ the network, rejoined the network, reinstalled the app, then it worked.  Hope that helps others. 

Badge

Some good suggestions all of which have been tried over and over to no avail yet nothing from T-Mobile. I guess for me I’ll just ignore the problem just like T-Mobile does, even though the app is useless the internet itself seems to function ok. I noticed an onslaught of T-Mobile home internet commercials so maybe after a bunch more people sign up they will work on it. Maybe not.

Badge

No working app NO F***ING PRINTER! Need the app to finish the setuo for AirPrinter.

But spinnning ball won’ t let me get there. Seems this is worldwide, didn’t know this when I got my gateway last week, Still better than AT&T 13mps download!

 

WE NEED TO CALL THE FCC AND COMPLAIN!!!!!!!

Run Away from t-mobile internet if you use YouTube tv! It is constantly dropping! I guess they just don’t understand the concept of streaming service requires Fast Internet WITHOUT INTERUPTIONS!

Badge

So it’s been a few weeks and there seems to be a massive improvement in using the app. I randomly tried it and it signed right in. Over the past couple weeks I kept randomly trying it and it consistently works. 
 

Thank you T-Mobile for correcting this issue, I for one really appreciate the attention put on it. For me it was my only issue with the service I am happy otherwise.

 

Thank You!!!

It’s not just iphones.  I have a Google Pixel 6, and the “updated” version of the Internet App sucks big time. My gateway failed this week, and I had to replace it.  MULTIPLE ISSUES WITH REPLACEMENT!!!

But one big one is that the app simply does not work. Even though the gateway is working, and I am connected to the gateway network through my phone, the app refuses to see this and gets into a loop where it insists I need to connect to the network. I can’t manage the connection or anything.

And to top that off, even the regular t-mobile app (for managing my account, phones, etc.) is not working, either.

No matter how much I despise Elon Musk, I’m ready to contact Starlink. It’s available in my area.

The horribly flaky phone app re-aggravates the COERCION to a phone app.

Why did they fully disable wired Ethernet access for admin/setup?

SOLVED! T-Mobile tech support got me through this issue.  I have a Motorola stylus 4G phone, running Android, of course. I had Microsoft Defender running which has a VPN function. That’s the key -- a VPN can block local (LAN) traffic which is a great protection in a hotel, but not in this case.  I instructed Microsoft Defender to forget the local network and I was immediately able to login.  Score one for T-Mobile tech support.  

Reply