No connectivity on Canon MG3620 printer

  • 26 January 2024
  • 10 replies


I have tried all the suggestions for wireless set up. No go.

i do not have laptop. Just IPhone an IPad. IOS message shows unsecured message when changing WP settings to suggested fixes 

I  do have a wireless router. My next  try. I assume the network cable connects from router to back of T mobile gateway. Not sure if the router is compatible. It’s brand new but probably old. Lyncsys E 1200.  This shouldn’t be that  difficult but  I am obviously missing something and patience is not my strong suit. 

Lyncsys E1200.


10 replies


I have it. Did that as well. Multiple times. Nothing.

The only thing I need it for was to print shipping labels  for online sites.

 I can easily get a blue tooth  label printer which should solve the problem I would think.

Userlevel 5
Badge +7

Don’t give up!  Can you get the Canon PRINT App from the Apple App Store?

Canon Knowledge Base - Wireless LAN Connection with the Canon PRINT App on an iOS Device




My guess is it’s a lemon. Mess produced.Thanks for trying to help.  Canon is no longer supporting driver updates on website. just an fyi.

Userlevel 4
Badge +4

So after your set-up a new WiFi network, you got into your printer driver routine and tried to set it up with the new SSID, right?  (I’m not an apple guy, so this may not even apply!)

Not that this helps at all, but I have a cheap Canon TS3522 that is about a year and a half old, and it connects fine with no fiddling….but that is with Windows 10 and 11 machines.



I added network.

Shows up in settings.

Went to print.

Shows No Air Printer found.

Printers have always been the Bain of my existence.

This also was tried on another persons Verizon network…same result.

Fortunately the dumpster is a short walk. 



I will give it a try. Thanks!

Userlevel 5
Badge +7

@Angus65 you will want a printer that supports AirPrint.

About AirPrint - Apple Support

Edited to add:  Your printer is on the list, so it should work.  Did you do what @Rogracer2000 suggested?  That is usually the fix -- to set up a 2.4 GHz network for your printer, with security downgraded a bit to WPA/WPA2.  You need to add this new network with the T-Mobile Internet App on your phone or iPad

How to create additional Wi-Fi networks | T-Mobile Internet app | iOS | T-Mobile Support


My question is how do I know a new printer won’t have the same problem?


 Went to Canon website. Followed set up.   Showed the printer listed in Settings. Clicked on it and “ Unable to connect” appeared briefly and disappeared . Noticed that Canon no longer supports driver downloads?

I guess that printer is not going to work in wireless environment?


Userlevel 4
Badge +4

If the printer is “older”, it may not be happy with the newer WiFi protocols the gateway is using.  You can try setting up a 2.4 Ghz-only network, and downgrading the security settings to WPA/WPA2.  Your printer may be happier with those.  You make all these changes in the TM Internet App...not hard.