Question

Why do my SharePoint links and files not open? (on T-Mobile 5G Home Internet)

  • 29 June 2022
  • 9 replies
  • 471 views

Badge

I'm having issues with some Microsoft Office services, e.g., SharePoint and Teams files. Started around 2022-06-15.
This is on my T-Mobile 5G Home Internet

- Issue: Most of the times I try to open a SharePoint link (Excel, PowerPoint) in a browser (on my laptop, on my home network), it can't find the page. Sometimes after 3 refreshes (F5 button), I get the file, and sometimes not.
- Issue: Sometimes when I try to open a MS Office file in a native app (Excel, PowerPoint), it tells me the login isn't working.
- Issue: Often when I try to open the Files tab inside a team channel in the MS Teams app, it tells me it can’t connect.
- Works well: On another network (same laptop, same apps, same account, but via the phone's hotspot or via a public WiFi).
- Works well: On another device (same T-Mobile 5G home internet, but on my phone).
- Works well: On another account (same laptop, same T-Mobile 5G home internet, but my personal Microsoft Office account).

... This is surprisingly specific to my work laptop && my home network && my work MS Office account && unexpectedly works for a bit sometimes.
I don't have much knowledge on networks, so my creativity is limited. Any ideas are welcome.


9 replies

Badge

Couple more observations:

I get an issue with another Microsoft account (at another client enterprise) on another browser (Chrome) - when I try company.sharepoint.com, 2 of every 3 tries give me “This site can’t be reached”. So, it’s probably an issue between T-Mobile and Microsoft.

Spoke with T-Mobile’s website chat. They said they are not aware of any issue. They said they’d check with Microsoft.

I am having a similar issues, anyone found a resolution for this? 

Badge

When I use VPN, the problem doesn’t come up.

The issue may be T-Mobile’s bandwidth with Microsoft’s SharePoint servers. So, the issue is probably between those two entities, and they should look into it. IN my calls to T-Mobile, they insisted the issue isn’t on their side.

Next step - calling to cancel my service with T-Mobile due to the bad connectivity and the decline to take responsibility.

I am having the same problem with my Sharepoint and Teams files.  It takes multiple refreshes of the browser tab to sometimes work.  Works fine when I’m on my company’s VPN. 

I am having the same issue.  It takes multiple tries to open.  Works fine on other internet services.

Userlevel 2
Badge +1

Could be in the security of the MS applications? MS apps may not like the IP changing rapidly. As noted on other threads T-M flips the IP’s really fast, that kicks people off of their web pages and apps. No use calling T-M support as you will end up offshore with someone that has no clue because it’s not in their book of answers. I worked my way to a USA Tech in Albuquerque (T-M Headquarters). That helped answer a few questions I had, not on this issue. At least I could understand him, and he wasn’t just reading from a book of answers.

If you’re using a VPN, MS apps can get confused and drop you thinking you are in Costa Rica, then Canada etc, when it knows you’re in say Los Angeles.

 

JMHO on all of this.

I live in So Cal. Same issue with all my microsoft office 365 applications. Issue is specific to my connection to the T Mobile Home internet. 

I don’t know what the problem is… but I’d blame Microsoft.  🙄

I called Tmobile support. They removed my home internet modem , physical home address then re added it. I think that resetted something and problem fixed, for now. 

Reply