Solved

Alcatel Go Flip not reading SD cards

  • 2 February 2019
  • 10 replies
  • 1193 views

My Alcatel Go Flip will not recognize my 4GB micro SD card. Is there some kind of "trick" to getting it to recognize a card?  I've tried re-formatting the card on my computer with no luck.

icon

Best answer by snn555 3 February 2019, 04:57

View original

10 replies

Userlevel 5

Have you tried to format the card inside the phone using the phone's settings to format the card?

No, because the phone doesn't even acknowledge that an SD card has been inserted - there's not even a choice in the settings menu to format the card.

Userlevel 5

Try another card and if it is not readable then it is probably the phone having the problem if it is read then it's the card you originally used that is the problem

Userlevel 4

Just checking in here to see how things are going. Did you get a chance to try another SD card?

No, not yet.  The only other card I have is 64GB, and the specs say the phone can't read cards bigger than 32GB. Strangely, though, I was able to import contacts from the 64GB card (did this when I first got the phone), though I had the same issues regarding the card not being recognized for storage purposes.

Userlevel 4

That is very odd. Please do let us know what happens when you get your hands on a smaller SD card.

I tried a Lexar 4GB card, and it worked this time.  Thanks!

Userlevel 3

Awesome! Thanks for the update 😊

I just purchase a Alcatel Go Flip 4 (2021,12,16) and cannot get the phone to recognize my SD card.  I have tried 3 different SD cards from 16GB to 32GB with the same result.  I tried xfat and NTSF formats.  Loaded music through my computer onto the card and still no results.  Is there a specific brand of SD card that I need to purchase?  Can anybody help me with a solution?

Went to the tmobile store today to find out the issue.  They said that some of the fast read/write sd cards will not work.  Went to microcenter and purchased for $4 a generic sd card 16GB and it is working perfectly.

Reply