Inseego M2000 connected but no devices see it

  • 7 March 2022
  • 1 reply


Hello all - I am really hoping someone here can help with some kind of a settings or way i can fix my hotspot so i dont have to go in to get a new one…

I live and work full time in an rv, so i use several devices on several different carriers.  So i use hotspots - a lot….  I have never had this issue though..

My m2000 is connected and happy looking at the box.  In the admin panel, everything looks totally normal.  But none of my devices - mac, iphones, ipads, tvs….etc show it as an available to network.  I tried tethering it directly to my laptop and that actually worked.  Also it seems like it randomly powers itself off when it isnt connected to power.

I am guessing its just dead and i am going to have to replace it - its only a year old, but RV life can be rough on equipment….

Thanks in advance if anyone has any idea on things to try before i chuck it….


1 reply

same problem here.  had to replace it.  it was covered under warranty, so t-mobile replaced it.