Unable to download group MMS

  • 20 April 2018
  • 15 replies

I have a Pixel XL that was originally Project Fi. I switched to TMobile two weeks ago and my group MMS are not downloading, either on wifi or mobile. Sometimes they come through, other times I have to go to the individual messages and download them. 90% of the time, they fail to download. I've done all the troubleshooting, including resetting the network and creating the new APN from this forum. My husband has the same phone and same network and is not having this issue. The message app also crashes after a few tries at downloading.

Google support was not helpful, telling me I can't use wifi for MMS, which is incorrect because I've always used wifi. Plus, it's also happening on data.

Below is the APN I have done according to TMobile support doc. Although, my phone does not have a "MMS protocol" option. This helped my phone to be able to receive them more frequently, although, I still have to download them.

Android APN settings

  1. Open the Access Point Names or APNs menu.
    1. In Settings, look under Wireless & Networks or tap the Connections tab.
    2. Touch Mobile network. You may need to touch More settings, More..., or More networks first.
    3. Touch Access Point Names.
  2. Touch the T-Mobile APN if one is available. If not, press the Menu key and touch new APN.
  3. Verify and update the following settings for the Data APN.
    • Name: T-Mobile
    • APN: (for LTE devices) or (for non-LTE devices)
    • Proxy: <Not set>
    • Port: <Not set>
    • Username: <Not set>
    • Password: <Not set>
    • Server: <Not set>
    • MMSC:
    • MMS proxy: <Not set>
    • MMS port: <Not set>
    • MMS protocol: WAP 2.0
    • MCC: 310
    • MNC: 260
    • Authentication Type: <Not set>
    • APN Type: default,supl,mms OR Internet+MMS
      • Default Android provides a text field to enter: default,supl,mms.
      • Samsung provides an Internet+MMS radio button to select.
    • APN Protocol: IPv4/IPv6
    • APN roaming protocol: IPv4
    • Turn APN on/off: Grayed out unless there are multiple APNs
    • Bearer: Unspecified
  4. Press the Menu key.
  5. Touch Save.
  6. Delete any other APNs that appear in the list. The FOTA APN can remain if available.
    • Touch the APN that needs to be removed.
    • Press the Menu key.
    • Touch Delete APN.
  7. Verify there is a circle next to the remaining APN.
  8. Perform a soft reset. Hold down the power button until the device turns off and restarts.
  9. Test the data connection and/or MMS by accessing the Web or sending a picture message.
  10. Complete additional troubleshooting if the APN settings are correct, but customers still experience issues.

Best answer by tmo_marissa 23 April 2018, 19:42

View original

15 replies

Edit to note that I have mobile data enabled and still have the issue.

Userlevel 3

Hey, @pkgal21​! It looks like you've done a good job of entering everything from the @plyboy​ had asked a few questions there. Do you mind clarifying these details for us?

For your specific issue, if individual MMS are downloading but not MMS in group messages, this is going to be a setting on the phone and not the T-Mobile network. In your situation, is your phone currently still receiving and downloading individual MMS messages with no issue? If not, are you able to browse the web while not connected to WiFi?

Also, are you using Google Hangouts as your messaging application? If so, would you be able to try downloading another messaging client from the play store like GoSMS or Textra and seeing if the issue persists? I just want to narrow down if this is an issue with the default app or if there is setting that is wrong in the phone somewhere.

I too am having the same issue and still waiting for a response from T Mobile Customer Service. MMS messages say "downloading" from the sender, but the message sometimes takes a few days to a week for the message to download. I am having this issue both on and off WIFI. Please let me know if a viable solution is possible. Thanks community.

I have a similar issue on my iphone 12 mini. In my case, I’m not receiving the Group MMS at all but other people in the group who are not on T-mobile receive it immediately.

I had this issue about a year ago on my OnePlus 7Pro but it somehow just resolved itself after several months. I just started having this same problem today on my Samsung Galaxy S20+ 5G.  Mine also asks me to “tap to download” but then never downloads the message and this is happening whether I’m on WiFi or not.  Can’t T-Mobile figure out why this is happening and fix it?  Thanks!

Userlevel 7
Badge +16

on the Samsung device the problem can also end up being the texting app itself..which Samsung would need to fix..

In order to receive texts as part of a group without getting the annoying pop-up messages about downloading group MMS, I found this change solved this problem on my Samsung Phone using T-Mobile:

Enable Data Usage   
1.  Tap Settings > Connections > Data usage > Mobile data usage.
2.  Scroll down the list of apps and find your SMS Texting app (Messages etc.).
3.  Select your SMS Texting app (Messages etc.)
4.  Enable two settings:
    A.  "Allow background data usage"
    B.  "Allow data usage while Data saver is on"
5.  Close the Settings App and restart your phone

Jazz360, Thank you, thank you, thank you!!! I recently switched to T-Mobile from AT&T and was unable to send MMS messages. I’ve tried all the other suggestions and the two settings you suggested was the answer. I was tearing my hair out. Thanks so much for your input.

I believe I have found the setting that fixed it for me.  I went in to the messages settings, Advanced, and then enabled “Auto-download MMS when roaming”. I am not roaming but it seems to have fixed my issue. 

This has been happening on my Pixel 4 XL for the past couple of weeks and it's totally random, I have tried the above mentioned tips to no avail.

Never a problem with Sprint. T-Mobile service is so bad… so bad. I though Sprint sucked until they merged with T-Mobile. Seriously? It’s messaging. It’s basic functionality. I can’t even use group messaging for my businesses anymore with any degree of confidence. WTH?

While not ideal I upgraded to the Pixel 7 and no longer have this issue 

Userlevel 7
Badge +16

Never a problem with Sprint. T-Mobile service is so bad… so bad. I though Sprint sucked until they merged with T-Mobile. Seriously? It’s messaging. It’s basic functionality. I can’t even use group messaging for my businesses anymore with any degree of confidence. WTH?

are you saying the entire state of where ever you live is a TMO dead zone when it comes to MMS?


the issue is either with your phone or something bugged up in your account..

I have the same issue, I was trying to figure out if it was my phone or T-Mobile. Everytime I do group messages most of them go to individual messages and I have to download them, which causes me to miss many messages in the conversation. It makes me so mad and I’ve been ready to switch carriers. I have the Samsung Galaxy S21 ultra, I have reviewed all the replies for ideas but none are on my phone to try. 


same issue. Began when I came to Alaska. Must be some issue with MMS via the partnered GCI network. One user said that they had success by changing the MMS port to 80, and changing default,supl,mms to default,mms,supl. This did not work for me however.