SyncUp Drive not working

  • 26 September 2019
  • 8 replies

I bought a SyncUp drive from Tmobile and tried to connect it with my car. But it did not work. I literally tried everything so I just thought it was defective. So I exchanged with a new one. I tried the new one out, plugged it to my car, and still did not connect with my car. The app says “unplugged“ and when I try to connect to the hotspot, it takes me to the website that says “Get Started” but it greys out and says error, “can’t open page”. This is literally the only product from Tmobile that I’m really disappointed. I already talked to many people from support and were no help. I wasted 150 dollars for nothing then. And yes my car is compatible. The only thing that works on this drive is the GPS


Best answer by tmo_amanda 2 October 2019, 17:46

View original

8 replies

Userlevel 4

Hey there! I'm sorry the second SyncUp device isn't working for you. When you talked to support over the phone, what exactly did they test? Do you show any lights on your device when it's plugged into your car? When you access the app does it display your vehicle's info?

They haven’t tested nothing. They just checked if the drive was activated and all that. They said everything is okay and they’re not sure why it’s not connecting with my car. I believe it has something to do with my account. And also, the drive does show green lights. When I go to the app, it just says device unplugged. It displays nothing of my vehicle.

Userlevel 4

That's weird that they didn't do any troubleshooting after confirming it was activated. I'm wondering if your plan has the proper SyncUp feature attached to it (only Care over the phone/chat or T-Force on Facebook/Twitter will be able to tell). We also need to verify that the SIM number on file matches on our end. There's definitely some troubleshooting we can complete after confirming it's activated. Try working with T-Force over Facebook or Twitter and let me know how that goes. You can also link them to this thread, if needed.

I'm having the same problems. I have 2 green lights on and my account is saying it is active on the Sync up.

I have the exact same issue and have been troubleshooting for 2 months. Had the device swapped. Called in and went into a store. Still not working but paying for service. 

This was marked as solved, but what was the solution?

hi everyone , i got my syncup drive this last Friday and i have not got my to work, led light 1 is blinking green, led light 2 is solid green , how do i fix it ??? i will call T mobile in the morning before i bring back it the store. i need to get it going Because i am going to Arizona in june 7 and i will be living full time in my RV Trailer thanks

just got 2 of these.  i’ve tried deleting and reinstalling the app multiple times.  i’ve deleted and reinstalled the device in the app. i’ve tried pressing the reset on the device.  nothing seems to work.  led 1 light continues to blink.  bluetooth often times has a hard time finding the device (not sure this is even necessary). device consistently says it’s unplugged.  doesn’t have anything to do with “going for a drive” because i’ve driven 15 minutes a couple of times and for an hour yesterday after spending about 30 minutes talking to t-mobile, who could offer no solutions.  said device was probably bad, take it to a store and let them check it and they’d mark the account for exchange.  went to store this morning who said they didn’t have any way to check the device and also that they didn’t have any in the store and even if they did they couldn’t exchange it because it was bought with “telesales” and would have to come out of their inventory not the store.

daughter hadn’t tried her device yet, we just tried the original device and the second device in her car with the same results.

i’m ready to return these and get them off my bill.  what a waste of time.

Im going through this right now. This is sickening.