Unable to create profile on Syncup kids app using iphone


I’m trying to setup my profile on the syncup kids app, but I get an “update profile error” popup that says:


“There was an error while updating your profile.  Please try again.”   


I tried at least 10 times.   Has anyone encountered this issue?


Best answer by RivFam1224 21 July 2023, 17:01

View original

14 replies

when trying to log in to the SyncUP kids app on my iPhone this comes up. I have deleted it and reinstall it several times. 



When I tried to follow the steps, I encountered no issue.  I’m not fully sure of this, but by calling them the next day, they were able to see that the line was active and the phone imei was detected in their system.   The support technician used that info somehow and I tried the steps and it worked.


I was able to get it resolved the next day when I called them.  They were able to see the watch information in their system

Did your issue ever get resolved? I've been trying since Friday have spent over 10 hours dealing with 5 different tech support people and 2 different stores and nothing.

Yes, I enjoy T-Mobile’s cellular service, but their customer needs work.  
I thank you both for your messages because I knew immediately it was an issue with either the app or the server.

Userlevel 1

Thanks for the update, I just tried now and I was able to proceed past the create profile step I was stuck at last night.  I will continue setup and I assume it will work now.  It would have been nice to not spend 2 hours on with support having me reboot the watch when I could clearly tell it was an issue with the app as we weren’t even at the watch pairing step yet.

Update: I tried again this morning and it worked. I was able to get my kid signed up and add her contacts. She’s using her watch.
Might have been a server issue. Hope things work for y’all too. 

Same issues here. Picked up a watch today at my local store for my kid and when the sales rep asked if I wanted to pair it in store I declined because we had other things to do. But now I’m trying to set it up and I’m getting the same error. Tried on my iPhone, hub’s iPhone, and my iPad (several times each). 
I’m hoping it’s just a server issue or something. I’ll try again in the morning and if it doesn’t work, I guess it’s being returned. 


Tech support was not very helpful. They had me restart my watch several times.  I installed and uninstalled the app several times.  I even added the app to an iPad to try to login and the issue persisted.   The nice gentlemen on the phone mentioned that there might be an issue going on with all syncup servers…, drive, etc and he will create ticket with the engineering department and call back tomorrow.


Userlevel 1

100% agree, I did a lot of research on similar devices prior to purchase and they all had issues/bad reviews.  I figured I'd be testing the Syncup watch myself and the backup plan is returning the watch and buying a basic cellphone.


Honestly not a good first impression for a device that I’m trying to trust to help manage my kid’s whereabouts.

Userlevel 1

They called me back and are opening a ticket with developers to investigate this. 


Thanks @Blk94civ I’m currently on the phone with customer support now.  If they get the issue resolved, I will post my update here.

Userlevel 1

Same issue on Android with new watch delivered today.  Customer support is of no help.