Question

30 seconds to connect new clients to internet

  • 22 July 2023
  • 2 replies
  • 71 views

Badge
  • First activity
  • 2 replies

When a new client connects to my Sagemcom 5688W gateway (i.e. to the wifi SSID broadcast by the gateway), it takes up to 30 seconds for the client to connect to the internet.  During this ~30 second timeframe, the newly connected client gets DHCP and it can ping the gateway, but it cannot connect to the internet.  This happens on all clients regardless of the client OS.  This makes it impossible for some clients to connect to my wifi SSID (specifically, neither of my printers will connect because they time out before the gateway allows them to connect after 30 seconds, so I have to print like a caveman via USB).

 

I tried factory resetting my gateway, no change.  I called T-Mobile support, they sent me a replacement gateway, it has the same problems.   In my home, I have a full 5g T-Mobile signal, no obstructions around the gateway, and no wifi interference (I have confirmed this with advanced wifi testing tools on Linux, and an Aruba UXI sensor).

 

Does your gateway have the same problem?


2 replies

Userlevel 5
Badge +8

@ggva your problem seems to be related to your SSID setup. You might try using your T-Mobile Internet app to delete and reset your SSIDs. but, make sure to set them up individually - 2.4Ghz and 5Ghz (not “automatic”). Many devices need to see the individual frequency/channels when trying to connect. I have the Sagemcom gateway with individual frequency bands for each. 

T-Mobile Home Internet app > Network tab at the bottom of the screen > highlight your SSID and use the delete option, then use the “+” button to add both 2.4 and 5 Ghz SSIDs (e.g. home2.4 and home5).

Let us know how it works. 

Badge

@copz1998 thanks for the suggestion.  I tried changing the frequency band of the existing SSID to only 5ghz, creating two separate SSIDs with different frequencies (one for 2.4, one for 5), and resetting my gateway to factory default, and nothing fixed this problem (nor did replacing the gateway entirely).  I tried connecting a different router to my Sagemcom 5688W gateway (TP-Link Wifi 6 AX1500), and when clients connect to SSID’s broadcast by my TP-Link router they do not experience the 30 second delay.  There must be a bug in the Sagemcom 5688W gateway that causes this long delay for new clients, but it’s impossible for me to tell since it’s essentially just a black box and I have zero visibility into even basic settings/logs for things like DHCP, NAT, DNS, etc.  I will just use the TP-Link router, but it’s a shame that I had to buy something that the Sagemcom 5688W gateway should have no problems doing.

 

I appreciate your reply, @copz1998!  Thanks for the helpful suggestions. 

Reply