5g home internet - some sites won't load

  • 15 August 2021
  • 40 replies


My big gray cylinder 5G Home internet has good signal and works reliably. But some percent of websites I visit simply refuse to load via the TMo 5g device, yet they work fine if I use my Verizon cellphone data, or a coaxial cable modem (which I have not canceled service on yet). I am guessing it’s either a DNS issue between my Mac and the T-Mobile cylinder (eg: settings requiring technical help or updates), or a problem in the T-Mo network that is blocking some sites. 

After spending too many hours on the phone already with Tmo tech support for 5G Home, I am not excited about the prospect of engaging on the phone again. It takes too long, and the agents need more training and support. 

Has anyone experienced and solved this issue? Do you have technical insights? Is there actual written documentation somewhere that I could access? Thank you. 

(Honestly Tmo, you need to rethink your support infrastructure for 5G Home.)

40 replies

I called T-mobile tech support and told them about the entry above that mentions the applied content filter. The tech talked to a supervisor and then told me they were not aware of any such thing existing. After much searching and reading articles I was convinced it was related to network security or encryption protocol. I attempted to update the driver for my network adapter, but it said it was up to date. However, Windows Update found 4 other updates that were available for my Windows 11 Pro system. One of them was a cumulative update for the dot NET versions. I ran the four updates and rebooted about 3 times during the installs. Then, my connection to all websites started working. If you can connect to Google, Youtube, and other popular websites, but cannot connect to others, like, try updating all your drivers and applying Windows updates. It worked for me. Good luck. 

So I ran into the same issue where even my LG smart TV would play any content even though it was connected to the internet.  Lowkeyhitech was correct that TMobile has a filter applied by default on some accounts (business ones usually) that block specific sites.  The solution is to call TMobile and have it removed, but it needs to be done with technical support because customer service won't know anything about it. 

It’s an applied content filter from T-Mobile. You have to call and get it removed...

I have the same problem too. Some websites does not work when I use T-mob 5G but works on ATT Router.

It’s an applied content filter from T-Mobile. You have to call and get it removed...

I just got 5G Home Internet and had same issue over ethernet, but WiFi worked fine. So i compared the IP settings of both connections on my Mac. I noticed the ethernet connection was missing the router IP in the DNS settings. Once i added that everything worked.

Adding to the data points here… I’m having the same problem (any device or browser connected to TMobile Home Internet/5G) not rendering certain web pages. It cleared up when I used a VPN.

I started to use Tmobile home internet 15 days ago. It had been working fine until I paid my first payment. Some websites are not loading, even one of my work VPNs cannot be connected to. Nothing wrong about browser, cache, or OS. One of my friends lives few blocks away, he is having the same issue. We tracked down with other ISP’s, NTT said this: It is very interesting that forcing the return path over Telia worked. That effectively removes Sprint<>Tmobile (Telia routes through Zayo->Tmobile) and futher indicates the trouble is somewhere along that Sprint/TMobile LAX handoff. 

I guess it is a Spring<>Tmobile merge issues which they have never really resolved. It works if we re-routed a website to skip Sprint<>Tmobile router.

Tmobile Tech support team is not helping much so far. This is just pushing customers away.

Userlevel 6
Badge +9

T-Mobile Home Internet has blocked Consumer Cellular for me.


Doesn’t appear to be a DNS issue with my devices, because when I switch to a T-Mobile cellular connection or use the hotspot, the link works fine.


Wonder if T-Mobile is limiting access to competitors?



Does anyone from TMobile answer questions on this site? Anyway, I am having the same issue on one site. Everything worked fine for the first month and now I am having problems getting info to load on a site I need for work. It works fine when I use my Verizon  Hotspot. Since this is a work laptop I have limited capability to change things on it. Is there a simple solution to get the site to work?

We are having the same issue.  My wife is having problems working from home when connected through the 5G router.  All pages load fine when connected through the CenturyLink router, but do not load when connected through the 5G router.  Doesn't appear to be a workaround or solution yet.  Will have to cancel T-Mobile internet.  Disappointing since it is much faster than our DSL.  But if certain web pages won't load....

I am having the same issues, some websites not wanting to load. My friend who has the same service is experiencing the same problems. can ya’ll try to load this website?

Same issue here with Netflix, Hulu and Paramount+ on TCL Roku, iOS and MacOS. Tried via router (Airport TimeCapsule) with the same result. Spent a whole day talking to Tmo/hulu/Netflix customer support but no help.

I have yet to look into DNS settings etc as that’s beyond my comprehension for now, but I wished any of the folks I spent the whole day with would’ve only mentioned that. Extremely frustrating, but I also know that is a hardass job.

If anyone could direct me to resources re: changing DNS setting (esp on TCL TV, is that even possible?) I’d be real grateful🙇🏻‍♂️

I’m having the same issue accessing one website I NEED to use for work from home. When I connect in my workplace, website works perfectly. I may have to switch back to my old provider because of this one site. A shame, because the service works great otherwise. 

We’ve been using Tmo home wifi for a week and this just commenced with one site only so far.  I’m piling on in case someone comes up with an answer.

Userlevel 4
Badge +3

I don’t have a solution--just another data point. Everything (including that URL for Judi Glove) works fine on my MacBook, on all three gateway wifi bands (2.4 and both the 5G bands). My MacBook is wifi 6 capable.  

I’m using an M1 MacBook Air, macOS Monterey 12.3, using mostly default network settings. Configure IPV4: Using DHCP. Configure IPV6: Automatically. I did add the Google DNS servers in my network configuration ( and, as J-Mac did, but I always do that very first when setting up new networks, so I don’t know how it would have been with different ones.  I also have the gateway itself ( in the DNS server list.

Works fine with Safari, Firefox, and Chrome browsers.

I know it doesn’t help solve the problem, but I add that info as another data point. As a retired IT guy (database, security, and network), most of the time when I faced problems connecting to only some (but not all) web sites, it was a DNS issue.

Same issue started happen to me today with webmail site (other sites are fine), regardless the device I am using as long it connected to the T-Mobile wifi network. I’ve tried modifying DNS, IPV6 etc. does not matter. I ran tracert and It time out along the way, so I am confidence it is on the t-mobile cell network.

Don’t know if they aware of it, I am not sure what to do next

I have the same odd failed page loads on specific sites, so I am monitoring this thread too.  I am a new user and usually service is good and speeds are 200Mbs down, 30Mbs up if not congested.  If I come up with new information then I will post back here.  For now I am using as a test (it always loads fine on cellular) .


I am not up to filing a tech support case now - maybe later.

Userlevel 7
Badge +8

If you want a quick low down on your IP addressing open the terminal and type in /sbin/ifconfig

It takes a few seconds for the terminal to render the report on my MAC as it is older but be patient. With that information you will know more than you ever thought you wanted to know about the IP addressing on your MAC. 

You can select and copy that information into a text file and provide that to support as well. If there is anything out of sorts a good engineer should be able to pick it apart.

Userlevel 7
Badge +8

I should add that I have the IPv6 configuration on my MAC set to automatic so I do run both IPv4 and IPv6. I am not sure if it is related but it is another datapoint. I am wired to a Thunderbolt adapter via CAT-6 Ethernet cabling so I know the traffic rides the Ethernet connection. Maybe it is related to running a dual stack IPV4 and IPV6. I tend to leave default settings alone. 

Don’t poke the sleeping dog.

If you load Wireshark and take a packet capture of the period of time when you initiate the session to the site you can save the capture and deliver that to T-Mobile support. I am sure they have engineers there that can read packet captures. Installing Wireshark and saving a packet capture is pretty easy.

Userlevel 7
Badge +8

When using Safari on my MacBook Pro I have taken a packet capture of the link to the site. With a quick nslookup I can see the DNS to IP resolution shows IP address associated with the host name. The session starts with IPv4 from my client to the IP and I can see the TCP source port 443 so I am sure of the conversation establishment. The page renders in a timely manner. The curious part I have not taken apart is the IPv6 flow that follows the initial IPv4 conversation setup/establishment. 

Open a terminal window and see if you can ping - the IP should be resolved by the DNS and if it is not blocked then the ping should be successful.

J-Mac where did you find “DNS settings in System Preferences/Networking to and “ when I log onto the Ethernet connection settings I don’t see that option.  I feel like the problem is something with the IPv6 as someone else said.  When I turn on my VPN everything loads fine, but if I turn the vpn off nothing will load on Safari, Firefox works which is really odd. 

I can’t get discovery plus in the evenings. YouTube load YouTube TV loads but not discovery plus I can get discovery plus in the daytime which doesn’t really help me. Any ideas what to do about that? I did have a Netgear box that I used with my former Internet service but I don’t need it because the signal strength is excellent. I’m not very tecky and appreciate any advice

I’m having the exact same issues.  The service worked fine for almost a month and then in the past 4-5 days i’ve been having to reboot the router multiple times per day because of certain websites not loading.  Youtube and netflix will always load, as will google, and yahoo. But my bank website won’t connect, and many others.   I’ve been on the phone with tech support twice for over an hour and keep being told there’s an upgrade being done to a tower in my area. I find this highly suspect since so many others are experiencing the exact same quirks in connectivity.  

I have the same issue reported above with various random websites not loading on my 5g iPhone.

Yesterday, I went to get a covid test and my iPhone would not load the website to submit my insurance info…


This would not load on multiple browsers and I had no WiFi access.


As soon as I connect to my work VPN, I was able to load this website perfectly fine. Good thing I had a VPN accessible.


Any insight into why these websites are not loading? Is this a UDP issue as mentioned above?


FYI. The website mentioned earlier in this tread does not load for me either via 5g on my iPhone…

I just got the Gray cylinder and neither of the MacBooks I own would see the internet although they were connected to TMo wifi.  I tried again but used a vpn and they worked like a charm.  This made me very confident the issue was DNS. I changed the DNS settings in System Preferences/Networking to and and the MacBooks worked great even without using VPN.  It was a very simple fix.  What is beyond frustrating is I spent 90 minutes on the phone with TMo support trying to fix this problem and they were absolutely clueless.  Actually, beyond clueless.  All they would do is keep having me reset the device.  I truly find it hard to believe they haven't resolved this issue for other Mac users and documented it for the support folks who have to deal with the public.  C’mon T-Mobile, you're better than this.