5G -How to do a push-button wifi join?

Userlevel 1

Where is the WPS push-button join feature for the 5G Home Internet gateway? There is no button on the body of the gateway and I’ve looked on the gateway’s screen, in the phone app and in the web browser interface. I don’t see any hint of an “accept join request” action. 

My printer is having difficulty joining the wifi network so I’m using it via ethernet cable, meaning I can’t move the gateway out of the same room. It would also be so much easier to join all my other devices that don’t have a keypad to enter the password like my bathroom scale, Filimin, etc. Every device has a separate management web portal. Annoying. 

15 replies

Userlevel 1

Currently, WPS isn’t an option, as you’ve discovered. If possible, are you able to perform an advanced setup on the printer to manually connect to the gateway? I have a printer that allows me to do a manual connection where I can enter the password once I’ve selected the gateway’s WiFi name after it searched and found available networks to connect to. My printer is an HP OfficeJet Pro 8710. 

Userlevel 1
Badge +1

I have a HP LaserJet Pro M15W printer. Since switching to T-Mobile Wi-Fi, I cannot get it to connect to my net work. When I look up instructions, it says I need to push a WPS button on my router. The problem is my 5G router does not have a WPS button. Is there anyway to connect my printer to T-Mobile Wi-Fi or am I just going to have to ditch a perfectly good printer that I had absolutely no problem with when I had AT&T Wi-Fi? Any suggestions would be appreciated. I have search the web for an answer until I am half blind. Thank you.

I have an HP Officejet Pro X476dw and am unable to manually join the wi-fi network via the T-Mobile gateway. Is there a workaround for this that anyone has discovered?

Userlevel 3
Badge +2

Can you print a network info page on your printer? If you can you can get the IP address there, or look in the T-mobile phone app and see if the IP address is listed for your printer there. If you can find the IP address you can go in the setting on your computer and add the IP manually.  

In the app, under security, make certain the WPA/WPA2 is selected and not the WPA2/WPA3 protocol.  That might help. 

Let be be more clear.  In the app, go to NETWORK

Choose 5 GHz or 2 GHz band (If in Automatic choose Advanced settings.)

In Advanced settings you can select the 2G and 5G separately and assign unique SSID’s

Scroll down to WPA Version:  Select WPA/WPA2 for each band.

Scroll down to Save and press it to save your new settings. 



You are a genius!  2 teams of T-mobile engineers have been trying to figure this out for a week with no success.  You're better than them!  You solution worked first time I tried it!  THANK YOU; THANK YOU; THANK YOU!



I tried your method, and lost my laptop connection. So I went back to the original settings, and SURPRISE! the printer connection showed up. So, you helped, in a way.


This is what I did to wirelessly connect my Canon MX452 printer:

In the T-Mobile Internet App, go to Network Settings, select your network and change the WPA settings to WPA/WPA2.  Then, make sure your password is 15 characters or less (some printers won't accept longer passwords).  Save your changes, then on your printer you should be able to do a standard entry of your password, by bypassing the WPS setup (press STOP on a Canon MX452) and doing a standard LAN setup.

Oh, if you needed to change your network password, you will need to go back to all your other wireless network devices and enter your new password.

Thanks are due to RickOnTheRoad, who's tip about the WPA settings helped me solve this problem.

Thank you Medic2296 and RickOnTheRoad!!! I have a Canon MG7120 and was going crazy, trying to get it to connect to my 5G router. Your solution worked! Thank you, thank you thank you!

We have an old wireless printer that doesn't have a screen, only a WPS button for wireless setup. There is no WPS on the T-Mobile gateways, so we used to work around.

Found an old wireless router sitting in storage that has WPS button. Programmed the old router with the same Wi-Fi name and password as the T-Mobile Gateway. Set up the printer to the old router using the WPS buttons on both. Then unplug the old router. The printer will automatically connect with the T-Mobile Gateway in the future.

I did the steps that Rick and Medic noted above (WPA, resetting the pw to less than 15 characters) but was still having trouble with my HP M102w. This video, method 3 in combination with changing the network settings, got me up and running!

I added the printer app. So easy to use. When you select your printer from the last a pop-up print icon comes up. Volah it prints. I had a long password, who wants to put that in.

Thanks All ! you save me !

I did Medic steps but before I create an other network just for my Canon MX492. 👍


I have a Canon MG4200. When I tried to connect to the 5G gateway, the printer skipped the password step for some reason, and it won’t connect. Changing WPA2/WPA3 protocol to WPA/WPA2 on the gateway works for me, ( the printer lets me to input the password like normal now). I don’t like the “not secure “ warning though ,so I tried to change the setting back to WPA2/WPA3 protocol to see if the printer is still connected. Looks like it is still connected so far.