Question

Home internet speeds extremely inconsistent and connection drops intermittently

  • 12 March 2021
  • 41 replies
  • 16424 views

Userlevel 2
Badge

We jumped on home internet service as soon as we heard about it. For a long time now, Comcast has been the only choice in Baltimore City and it feels like they squeeze city residents to subsidize lower prices for their customers in the counties where they have competition. Our current Comcast bill is just over $100 per month with their most basic service, a bundled Internet + TV. We don’t even use the TV service but they wouldn’t give us a plan with just internet service. This costs us about $110/month. I can plug my brother’s address (he has  VZ Fios) in on the Comcast website and get offers for $39.99/month. I’ve been looking for a way to break free of Comcast for years now so I want to love this service but it’s just not measuring up.

We had one of the mobile internet gateways delivered on 3/9. I started testing it immediately and was consistently getting speeds well over 300Mbps down on the first floor of my house. I even hit above 400Mbps a few times. So I went ahead and put that gateway at the head of the network, replacing the cable modem. The good speeds continued for a bit but, not long after that, I noticed the gateway would intermittently lose it’s connection and the speed had dropped quite a bit. I’ve seen as low as 3Mbps down but that it generally stayed at just about 25Mbps. Checking the LCD at the top of the router, I could see that it was disconnected when our internet stopped working or that I had between 2-3 bars. I have 2 kids in school zoom meetings from 9am - 3:30pm and my wife and I are in and out of zoom meetings from 9am - 5pm. We were constantly getting disconnected due to the internet going down completely or due to the DSL speeds I haven’t seen since 2005. WiFi in my house is problematic due to plaster walls and metal lath so I figured it had something to do with that.

I went to https://www.cellmapper.net/ and found the closest T-Mobile 5g tower was about 3.25 miles away. Luckily, my house is in one of the highest areas of the city and my 2nd floor bedroom window faces the nearest towers with a fairly unobstructed path to them. I drilled some holes and ran an ethernet cable down to the living room router. At this point, the gateway was sitting just far back enough from my bedroom window to avoid direct sunlight and had a pretty clear path to the closest tower. The display showed 4 bars consistently. However, the speed and connectivity issues persisted.

I just got off the phone with T-Mobile Home Internet tech support and got a line that seems a little too much of a coincidence when you take into account the other coincidences. The support rep asked me if I experienced this trouble before 3/9 because their engineers just started working on the tower I was connected to on 3/9 and it explains my trouble. I’m willing to wait for this work to be completed but he said it could take up to a month.

So these are the coincidences so far:

  1. Most of the time, I get right around 25Mbps. It happens enough that the support rep was able to ask me to retry a speed test immediately after getting a <10Mbps speed test back and it would be >25Mbps. Then he’d say, “There you go. I made an adjustment and now you’re getting 25Mbps, which is the base speed”. The speed issue seems more like throttling since it’s keeping me right at 25Mbps most of the time.
  2. The problem I’m seeing started on the day I received the equipment and just happens to be affecting the only tower my gateway is connecting to.
  3. The work their engineers are doing could take up to a month. Just enough time for them to charge me for another month before I cancel.

Maybe this is just paranoid me talking but I’m not trusting some of what I was told. I’d love to be wrong about this though. Anyone had a similar experience? Was it eventually fixed? How long did that take? My whole neighborhood is waiting to hear how this pans out. So many people are sick to death of Comcast that they may have to abandon Baltimore altogether once most of us jump ship for T-Mobile.

Rant over but I’d love to hear from people who’ve had similar experiences or who may have advice for improving my service.

Thanks,

Matt


41 replies

My speed this evening is .11 mbps.  Yes, not 11, but .11 which is less than one.  I had the same problem this morning at 2:00 a.m.  I have had speeds as fast as 156 mbps.    1When I first installed my T Mobile internet it was blazing fast.  Now, it is sometimes blazing fast, and sometimes, it takes over a minute before my speed indicator moves.  My problem is I need consistently high speed internet when I am working.  And it isn’t slow because of low priority, as I have this problem when I begin my work, which is 2:00 a.m .  So, what gives.  I am now looking into returning to COX internet.   If you are just going to use it for surfing the web or Netflix, it will work ok.  But for streaming, it will only work occasionally.

hi, thanks for posting this. I had it. I had T-Mobile Internet for a week now and I called maybe five times and every time I called they said they are working on the tower near me and I promise you within a couple days, you will have perfect servicethey are always working on my tower, it’s a joke they must be trained to say that. I live in Philadelphia. Thanks for your post. It proves me that they are lying to me and their service is horrible home Internet anyway, thanks again, Ron

We jumped on home internet service as soon as we heard about it. For a long time now, Comcast has been the only choice in Baltimore City and it feels like they squeeze city residents to subsidize lower prices for their customers in the counties where they have competition. Our current Comcast bill is just over $100 per month with their most basic service, a bundled Internet + TV. We don’t even use the TV service but they wouldn’t give us a plan with just internet service. This costs us about $110/month. I can plug my brother’s address (he has  VZ Fios) in on the Comcast website and get offers for $39.99/month. I’ve been looking for a way to break free of Comcast for years now so I want to love this service but it’s just not measuring up.

We had one of the mobile internet gateways delivered on 3/9. I started testing it immediately and was consistently getting speeds well over 300Mbps down on the first floor of my house. I even hit above 400Mbps a few times. So I went ahead and put that gateway at the head of the network, replacing the cable modem. The good speeds continued for a bit but, not long after that, I noticed the gateway would intermittently lose it’s connection and the speed had dropped quite a bit. I’ve seen as low as 3Mbps down but that it generally stayed at just about 25Mbps. Checking the LCD at the top of the router, I could see that it was disconnected when our internet stopped working or that I had between 2-3 bars. I have 2 kids in school zoom meetings from 9am - 3:30pm and my wife and I are in and out of zoom meetings from 9am - 5pm. We were constantly getting disconnected due to the internet going down completely or due to the DSL speeds I haven’t seen since 2005. WiFi in my house is problematic due to plaster walls and metal lath so I figured it had something to do with that.

I went to https://www.cellmapper.net/ and found the closest T-Mobile 5g tower was about 3.25 miles away. Luckily, my house is in one of the highest areas of the city and my 2nd floor bedroom window faces the nearest towers with a fairly unobstructed path to them. I drilled some holes and ran an ethernet cable down to the living room router. At this point, the gateway was sitting just far back enough from my bedroom window to avoid direct sunlight and had a pretty clear path to the closest tower. The display showed 4 bars consistently. However, the speed and connectivity issues persisted.

I just got off the phone with T-Mobile Home Internet tech support and got a line that seems a little too much of a coincidence when you take into account the other coincidences. The support rep asked me if I experienced this trouble before 3/9 because their engineers just started working on the tower I was connected to on 3/9 and it explains my trouble. I’m willing to wait for this work to be completed but he said it could take up to a month.

So these are the coincidences so far:

  1. Most of the time, I get right around 25Mbps. It happens enough that the support rep was able to ask me to retry a speed test immediately after getting a <10Mbps speed test back and it would be >25Mbps. Then he’d say, “There you go. I made an adjustment and now you’re getting 25Mbps, which is the base speed”. The speed issue seems more like throttling since it’s keeping me right at 25Mbps most of the time.
  2. The problem I’m seeing started on the day I received the equipment and just happens to be affecting the only tower my gateway is connecting to.
  3. The work their engineers are doing could take up to a month. Just enough time for them to charge me for another month before I cancel.

Maybe this is just paranoid me talking but I’m not trusting some of what I was told. I’d love to be wrong about this though. Anyone had a similar experience? Was it eventually fixed? How long did that take? My whole neighborhood is waiting to hear how this pans out. So many people are sick to death of Comcast that they may have to abandon Baltimore altogether once most of us jump ship for T-Mobile.

Rant over but I’d love to hear from people who’ve had similar experiences or who may have advice for improving my service.

Thanks,

Matt

I get the same response. They are working on a tower near me every time I call they are trying to say that it is horrible. I just bought a new Samsung UHD for 8K TV and the picture is horrible since the home T-Mobile Internet. I called three times in four days and got the same response that they are working on my tower. I guarantee you tomorrow you will have a great picture. I need to switch ASAP thank you for your comment approve me that they are bs me. 

Thank you for sharing the negative and erratic download internet speed from 5G-TM-Home Internet.

1-The slow and erratic slow internet speed is VERY REAL + SYSTEMATIC.

2-The technician support team have been taught to go through routines to BUY TIME, not to solve the SLOW SPEED SIGNALS, bc it was beyond their pay-grades and related to financial feasibilities and city permits. Meanwhile they counted on these support team to “CALM + MANIPULATE” customers to just “HANG ON + TIGHT” but still need to pay.

3-The indicator of number of bar-graphic is very MISLEADING; for example, the gateway shown 4 bars, but the Oookla, shown ping of 2025ms, the DL 0.05 Mbps, and UL 0.00 and keep buffering til the final message: Sorry, there was no connection ….in that manner.

We hope that TM take note and solve the signal speed congestions, aka, dropping.

I feel bad for 8 support technicians’ pain (so far in the last 41 days)  for keep apologizing on behalf of those MAX profit grabbers. 

 

 

Speed swings and useless offshore customer service aside, T-Mobile has the worst account management Web site in the industry (worse even than TracFone before Verizon acquired that company). You’ve all read about repeated data breaches, which are evidence that software development is not a priority for this company.

In my case, it has proven impossible to link the phone number of the Internet gateway to the T-Mobile account I created at the T-mobile store when picking up the gateway. I was able to finish the account creation process, which involves creating a password, but every time I log in, I am immediately asked to link a phone number. When I enter the gateway’s phone number, I get the notorious F451 error.

I tried the other way, by starting with the phone number and creating a new account. If I enter the e-mail address I provided at the store, the site recognizes it and won’t let me create a new account. If I provide a different e-mail address, the site says I have to use the same e-mail address that I provided at the store. This makes sense because, as with any T-Mobile postpaid account, the account I created in-store has my biographic data, Social Security Number, state ID number, etc. (In the prepaid world, T-Mobile has none of those data, and one can associate any e-mail address.)

Since it’s impossible to link the phone number to a T-Mobile account, you can’t manage T-Mobile’s home Internet service online. You might be able to pay the bill as a guest (I haven’t tried), but that’s it!

It’s a particular concern for me because only downtown areas of major cities are eligible for the unlimited service. I live in the San Francisco Bay Area, and in an urban city, but addresses in my city qualify only for the capped “lite” service. I’d want to be able to monitor my usage and know when I was approaching my monthly cap. (In the Bay Area, only addresses in San Francisco, Oakland, Berkeley and San José are eligible for the unlimited product, and even within those cities, only addresses in the high-value downtown areas will qualify. T-Mobile hasn’t made any network investments outside those areas -- you get LTE, rebranded as fake 5G.)

My box is going right back to the store tomorrow. The only good thing I can say is that T-Mobile is now using a more modern gateway, powered by USB-C (although you can’t use your own USB adapter unless it is a large one that supports laptop voltages and current levels -- 15 V 3 A, according to the manual).

The new gateway has no external antenna port (I’m not sure that the old one did, and I wouldn’t risk modifying a device I don’t own, that’s marked up to $370.)

T-Mobile is the worst of the three remaining US cell carriers, and its home Internet offering is essentially unusable. Do yourself a favor and keep your current ISP until some other company comes up with a truly good alternative.

 

We jumped on home internet service as soon as we heard about it. For a long time now, Comcast has been the only choice in Baltimore City and it feels like they squeeze city residents to subsidize lower prices for their customers in the counties where they have competition. Our current Comcast bill is just over $100 per month with their most basic service, a bundled Internet + TV. We don’t even use the TV service but they wouldn’t give us a plan with just internet service. This costs us about $110/month. I can plug my brother’s address (he has  VZ Fios) in on the Comcast website and get offers for $39.99/month. I’ve been looking for a way to break free of Comcast for years now so I want to love this service but it’s just not measuring up.

We had one of the mobile internet gateways delivered on 3/9. I started testing it immediately and was consistently getting speeds well over 300Mbps down on the first floor of my house. I even hit above 400Mbps a few times. So I went ahead and put that gateway at the head of the network, replacing the cable modem. The good speeds continued for a bit but, not long after that, I noticed the gateway would intermittently lose it’s connection and the speed had dropped quite a bit. I’ve seen as low as 3Mbps down but that it generally stayed at just about 25Mbps. Checking the LCD at the top of the router, I could see that it was disconnected when our internet stopped working or that I had between 2-3 bars. I have 2 kids in school zoom meetings from 9am - 3:30pm and my wife and I are in and out of zoom meetings from 9am - 5pm. We were constantly getting disconnected due to the internet going down completely or due to the DSL speeds I haven’t seen since 2005. WiFi in my house is problematic due to plaster walls and metal lath so I figured it had something to do with that.

I went to https://www.cellmapper.net/ and found the closest T-Mobile 5g tower was about 3.25 miles away. Luckily, my house is in one of the highest areas of the city and my 2nd floor bedroom window faces the nearest towers with a fairly unobstructed path to them. I drilled some holes and ran an ethernet cable down to the living room router. At this point, the gateway was sitting just far back enough from my bedroom window to avoid direct sunlight and had a pretty clear path to the closest tower. The display showed 4 bars consistently. However, the speed and connectivity issues persisted.

I just got off the phone with T-Mobile Home Internet tech support and got a line that seems a little too much of a coincidence when you take into account the other coincidences. The support rep asked me if I experienced this trouble before 3/9 because their engineers just started working on the tower I was connected to on 3/9 and it explains my trouble. I’m willing to wait for this work to be completed but he said it could take up to a month.

So these are the coincidences so far:

  1. Most of the time, I get right around 25Mbps. It happens enough that the support rep was able to ask me to retry a speed test immediately after getting a <10Mbps speed test back and it would be >25Mbps. Then he’d say, “There you go. I made an adjustment and now you’re getting 25Mbps, which is the base speed”. The speed issue seems more like throttling since it’s keeping me right at 25Mbps most of the time.
  2. The problem I’m seeing started on the day I received the equipment and just happens to be affecting the only tower my gateway is connecting to.
  3. The work their engineers are doing could take up to a month. Just enough time for them to charge me for another month before I cancel.

Maybe this is just paranoid me talking but I’m not trusting some of what I was told. I’d love to be wrong about this though. Anyone had a similar experience? Was it eventually fixed? How long did that take? My whole neighborhood is waiting to hear how this pans out. So many people are sick to death of Comcast that they may have to abandon Baltimore altogether once most of us jump ship for T-Mobile.

Rant over but I’d love to hear from people who’ve had similar experiences or who may have advice for improving my service.

Thanks,

Matt

I have same issues in Minnesota. Although I never had anything over 100mbps. I used to average 70-80 for the 1st 6 months. Now the last 1.5 years Ive been averaging 30mbps. But the service constantly cuts out and can’t keep up with 1 device….A sales Representative at the store said that he thinks the tower is overloaded because they are no longer offering  5g home internet to new customers in my area anymore. 

Badge

It's always a tower "being upgraded" and there are always two towers near you that they'll swear your gateway is switching between. They'll tell you they're rooting your gateway to one tower and then hang up. Nothing is ever resolved. I'm this close ||.

We jumped on home internet service as soon as we heard about it. For a long time now, Comcast has been the only choice in Baltimore City and it feels like they squeeze city residents to subsidize lower prices for their customers in the counties where they have competition. Our current Comcast bill is just over $100 per month with their most basic service, a bundled Internet + TV. We don’t even use the TV service but they wouldn’t give us a plan with just internet service. This costs us about $110/month. I can plug my brother’s address (he has  VZ Fios) in on the Comcast website and get offers for $39.99/month. I’ve been looking for a way to break free of Comcast for years now so I want to love this service but it’s just not measuring up.

We had one of the mobile internet gateways delivered on 3/9. I started testing it immediately and was consistently getting speeds well over 300Mbps down on the first floor of my house. I even hit above 400Mbps a few times. So I went ahead and put that gateway at the head of the network, replacing the cable modem. The good speeds continued for a bit but, not long after that, I noticed the gateway would intermittently lose it’s connection and the speed had dropped quite a bit. I’ve seen as low as 3Mbps down but that it generally stayed at just about 25Mbps. Checking the LCD at the top of the router, I could see that it was disconnected when our internet stopped working or that I had between 2-3 bars. I have 2 kids in school zoom meetings from 9am - 3:30pm and my wife and I are in and out of zoom meetings from 9am - 5pm. We were constantly getting disconnected due to the internet going down completely or due to the DSL speeds I haven’t seen since 2005. WiFi in my house is problematic due to plaster walls and metal lath so I figured it had something to do with that.

I went to https://www.cellmapper.net/ and found the closest T-Mobile 5g tower was about 3.25 miles away. Luckily, my house is in one of the highest areas of the city and my 2nd floor bedroom window faces the nearest towers with a fairly unobstructed path to them. I drilled some holes and ran an ethernet cable down to the living room router. At this point, the gateway was sitting just far back enough from my bedroom window to avoid direct sunlight and had a pretty clear path to the closest tower. The display showed 4 bars consistently. However, the speed and connectivity issues persisted.

I just got off the phone with T-Mobile Home Internet tech support and got a line that seems a little too much of a coincidence when you take into account the other coincidences. The support rep asked me if I experienced this trouble before 3/9 because their engineers just started working on the tower I was connected to on 3/9 and it explains my trouble. I’m willing to wait for this work to be completed but he said it could take up to a month.

So these are the coincidences so far:

  1. Most of the time, I get right around 25Mbps. It happens enough that the support rep was able to ask me to retry a speed test immediately after getting a <10Mbps speed test back and it would be >25Mbps. Then he’d say, “There you go. I made an adjustment and now you’re getting 25Mbps, which is the base speed”. The speed issue seems more like throttling since it’s keeping me right at 25Mbps most of the time.
  2. The problem I’m seeing started on the day I received the equipment and just happens to be affecting the only tower my gateway is connecting to.
  3. The work their engineers are doing could take up to a month. Just enough time for them to charge me for another month before I cancel.

Maybe this is just paranoid me talking but I’m not trusting some of what I was told. I’d love to be wrong about this though. Anyone had a similar experience? Was it eventually fixed? How long did that take? My whole neighborhood is waiting to hear how this pans out. So many people are sick to death of Comcast that they may have to abandon Baltimore altogether once most of us jump ship for T-Mobile.

Rant over but I’d love to hear from people who’ve had similar experiences or who may have advice for improving my service.

Thanks,

Matt


I’m with you on this, my internet completely drops! that’s the only thing that is Consistent

Userlevel 1

I've figured out how to fix this problem.

1. You call Verizon.....

Userlevel 1

Many people post about poor speed but never post there signal levels and readings. IMO 95% of the issues are signal quality that can be solved with an external antenna. It’s really to bad the connection is not there by default.

 

I live in an apartment that does not allow that. 

Badge

I've never had any problem with T-Mobile in home 5g broadband before I live only 0.29 miles from the T-Mobile tower. I'm getting a constant 700Mb/100mb on my gaming desktop night and day with no slow downs at all. I can stream multiple TVs at the same time. I use at least a terabyte a month.

I had excellent service with the TMobile home internet.  The moment I had troubles is when I switched my cell phones from Verizon to TMobile.  Turns out that we are de-prioritizing the Nokia gateway when our family is using magenta Max data on our phones.  I wasn't connecting the phones to the gateway to keep the load off of it and the phones had unlimited premium data.  Turns out all the devices in the house are sharing and fighting over the same bandwidth even if each individual device is on its own data.  It is causing so much issues.  I guess I should have kept Verizon phone services and just keep TMOBILE home internet only.  If you live close to someone using T-Mobile or Metro they will also be sharing your data.  My family lives next door and they are hurting our speeds as well when they use their metro phone (same tower as TMobile) to watch YouTube and want not.  They don't have home internet so they are always on their phones and they are close enough to our house that I know when they are watching YouTube.  Did some crazy testing to figure out our issue.

Badge

I installed a mimo panel antennae it helped a littel with the signal but im like everyone else 3mi from tower 50 hours on phone with tech in singapore telling me they are working on towers for 2 months noe they are finished and its just as bad as ever. i range from .2 to 25mbps 25mbps is rare and in theearly morning hours until 8am it drops immedialty to maybe 1-2 and signal bounces between that and .2 mbps ping is fairly constant 25-45 upload runs fairly consistent around 8 mbps all the time so tmobile can recieve my signal in a consistent matter. the dumps are always as people come online i live in a very rural area so not a lot of people my tower is along the I5 interstate hwy as are most of the towers but i can only connect to the one im on. ive driven and tested every tower with amazing speeds  until i get to my tower and got 6 mbps looking right at it. alll the others were 50-90 mbps total run around from tech support. network allocation is garbage. really cant wait to change as soon as im able.

rsri ,92-94

snr 10

rsrq -13

rssi -69

Userlevel 5
Badge +5

Same here like everyone, home internet was working fine then started to slow down 👎👎👎

Nothing I do fixed, 007bondM16 mentioned an external antenna!!

Never heard that there is an external antenna, where you can get it? How to get it? Price?

Anyone knows??

https://www.waveform.com/products/mimo-panel-kit-for-hotspots-routers?variant=39349359476839

I tried to post a discount code but got moterated

 

Userlevel 5
Badge +5

Same here like everyone, home internet was working fine then started to slow down 👎👎👎

Nothing I do fixed, 007bondM16 mentioned an external antenna!!

Never heard that there is an external antenna, where you can get it? How to get it? Price?

Anyone knows??

Ah ask.

 

https://www.waveform.com/products/mimo-panel-kit-for-hotspots-routers?variant=39349359476839

 

FYI from the TMHI Facebook page

Hi folks! Waveform.com will be having a Black Friday/Cyber Monday sale starting on 11/22. I talked to our online sales team and they created a early access 15% off coupon for our popular MIMO antenna kits and individual RSRF-branded antennae just for this group!

This early access code is only valid until 11:59pm on 11/21, after that there will be a different code and discounts for other products.

Coupon code is: TMOBF21

Clicking this link will automatically apply the code as well:

https://www.waveform.com/discount/TMOBF21

Remember, if you guys ever have any questions, comments, or suggestions, feel free to message/@me or contact one of our sales associates via live chat, email, or telephone.

Same here like everyone, home internet was working fine then started to slow down 👎👎👎

Nothing I do fixed, 007bondM16 mentioned an external antenna!!

Never heard that there is an external antenna, where you can get it? How to get it? Price?

Anyone knows??

Userlevel 5
Badge +5

Many people post about poor speed but never post there signal levels and readings. IMO 95% of the issues are signal quality that can be solved with an external antenna. It’s really to bad the connection is not there by default.

 

Well, 4 weeks and 4 “Customer Support” sessions later, the silver cylinder is on its way back to TMobile. Despite the promises and good will of the front line support and their Manager, Engineering never really addressed the problem of dropped packets and inconsistent speeds. I think the two are closely related and, most likely, are a function of cell traffic. The nonsense “fixes” that Engineering came up with were: 1. Downgraded the speed to 50 Mbps and 2. Looked at the distance from the cell tower and the signal strength/quality. Since these criteria are OK then, I don’t have any problem and case closed.

This thinking is so flawed in so many levels that I decided it was time for me to move on. So, for the time being, I am staying with my Frontier Fios (consistently 50/50Mbps, 9 msec ping). In a year or so I may give TMobile 5G another try.

Userlevel 1
Badge

Just hit 3 weeks of Tmob home internet and am not impressed. Constant dropouts while watching the tube. Slow loading internet pages. Less than 1 mbps download speeds between 4pm and midnight. Currently 0.12 mbps at 7 pm. Definitely not worth $50 a month. Spectrum cable just lowered their price to $49.95 a month. I'm ready to switch. 

I got my TMobile gateway today. Set up was quick and painless using the app but that’s where the fun stopped. Performnce was disapointing: Latency in the 40 to 130msec, Download speed anywhere from 1.8 to 74 Mbps, Upload speed, consistently higher than download, anywhere from 5 to 80 Mbps. My home is less than ½ mile from the cell tower, signal is 4 bars anywhere in the house.

I spent over 2 hours with Tech support, running tests and collecting data. I was also told that by the end of the month, when work on the neighboring tower is completed (sounds familiar?), performance will improve. I asked for an escalation of my problem but no such group exists; the data collected will go directly to engineering and I’ll hear back in a couple of days.

I am eager to dump Frontier and wanted this thing to work but, unless I see consistent performance (I’ll settle for a predictable 20 Mbps) I may have to look elsewhere.

I will update when I hear back from Support

Got excited and switch to TMo 5G Internet. At first, the speeds were good, 50-150Mbps up, 25-60Mbps down. Then when I started using it on the daily basis, I started to notice it’s very inconsistent. Sometimes both the down & up speeds are even lower than 1Mbps, especially starting around 6pm. The down speed does recover most of the time after a few minutes to an acceptable speed, usually 15-25Mbps, but the up speed often takes longer time to recover. Even when it recovers, it stays below 15Mbps. 

My tower signal is always 3 bar for 4GLTE b66, and 4 bar for 5G n71.
My previous provider Spectrum speed was always consistent 150+Mbps up & ~10Mbps down. 

 

TMOHI is a joke. I am in my first week of service and never get more than 3bars, in 5 different locations in my home. speed is never more than 12/8Mbps D/U and constantly drops internet connection completely, making it useless for online gaming -in addition to being unsuitable for a home with 13+ devices accessing my home network. paying $150+/mo for Xfinity was awful, but not as awful as this weak excuse for home internet and it's inability to provide even the most basic internet connectivity for the 21st century (absolute minimum 50/10Mbps D/U, IMHO).

I do find myself connecting to my VPN for slightly greater download speed, but packets still drop frequently, and ping is generally in excess of 60ms.

hopefully this "update" everyone speaks of arrives soon, or I am returning to Xfinity's highway robbery racket, post-haste.

Having exactly same problem with home internet. If it doesn't get fixed soon may have to go back to cable which I really don't want to do as I left them for a reason. Tm home internet Started out at about 100 to 200 mbps. Now it's about 20-30mbps and videos buffer all the time. My phones still get good speeds, the 5g phone gets 300-400mbps on speed test but my 5g home internet is only 20-30mbps. If management is throttling home internet to only 20-30 mbps then I'll have to leave b/c cable is 200+mbps or greater consistently. Was expecting to get similar service on home internet as I do on my phone but it isn't happening. Spending a lot of money with t mobile and expect high speeds on ALL devices all the time. Especially the home internet, which should be highest priority on their network as we use it for work, meetings, school etc... 

Badge

Thank you for the cellmapper website. very useful. I was able to determine to which tower my gateway is connected just by looking at the PCI # and the band. In my case only the secondary signal is a 5G. Most of the time the gateway does not even connect to a secondary signal. My speeds are as high as 150 at 2am but as low as 1-2 Mbps during the day.

For those who don’t know already if the band starts with n (ex: n71) then it’s a 5G connection. if it starts with b its LTE.

In my case I mainly get LTE.

The Gateway has a miserable firmware and I cannot get the functionality I need. Can’t access my security cameras or NAS from internet because of no port forwarding. My VoIP phone does not work because the firewall blocks the SIP ports and there is no way around it. VPN works.

Frankly this service is not worth 50$

We jumped on home internet service as soon as we heard about it. For a long time now, Comcast has been the only choice in Baltimore City and it feels like they squeeze city residents to subsidize lower prices for their customers in the counties where they have competition. Our current Comcast bill is just over $100 per month with their most basic service, a bundled Internet + TV. We don’t even use the TV service but they wouldn’t give us a plan with just internet service. This costs us about $110/month. I can plug my brother’s address (he has  VZ Fios) in on the Comcast website and get offers for $39.99/month. I’ve been looking for a way to break free of Comcast for years now so I want to love this service but it’s just not measuring up.

We had one of the mobile internet gateways delivered on 3/9. I started testing it immediately and was consistently getting speeds well over 300Mbps down on the first floor of my house. I even hit above 400Mbps a few times. So I went ahead and put that gateway at the head of the network, replacing the cable modem. The good speeds continued for a bit but, not long after that, I noticed the gateway would intermittently lose it’s connection and the speed had dropped quite a bit. I’ve seen as low as 3Mbps down but that it generally stayed at just about 25Mbps. Checking the LCD at the top of the router, I could see that it was disconnected when our internet stopped working or that I had between 2-3 bars. I have 2 kids in school zoom meetings from 9am - 3:30pm and my wife and I are in and out of zoom meetings from 9am - 5pm. We were constantly getting disconnected due to the internet going down completely or due to the DSL speeds I haven’t seen since 2005. WiFi in my house is problematic due to plaster walls and metal lath so I figured it had something to do with that.

I went to https://www.cellmapper.net/ and found the closest T-Mobile 5g tower was about 3.25 miles away. Luckily, my house is in one of the highest areas of the city and my 2nd floor bedroom window faces the nearest towers with a fairly unobstructed path to them. I drilled some holes and ran an ethernet cable down to the living room router. At this point, the gateway was sitting just far back enough from my bedroom window to avoid direct sunlight and had a pretty clear path to the closest tower. The display showed 4 bars consistently. However, the speed and connectivity issues persisted.

I just got off the phone with T-Mobile Home Internet tech support and got a line that seems a little too much of a coincidence when you take into account the other coincidences. The support rep asked me if I experienced this trouble before 3/9 because their engineers just started working on the tower I was connected to on 3/9 and it explains my trouble. I’m willing to wait for this work to be completed but he said it could take up to a month.

So these are the coincidences so far:

  1. Most of the time, I get right around 25Mbps. It happens enough that the support rep was able to ask me to retry a speed test immediately after getting a <10Mbps speed test back and it would be >25Mbps. Then he’d say, “There you go. I made an adjustment and now you’re getting 25Mbps, which is the base speed”. The speed issue seems more like throttling since it’s keeping me right at 25Mbps most of the time.
  2. The problem I’m seeing started on the day I received the equipment and just happens to be affecting the only tower my gateway is connecting to.
  3. The work their engineers are doing could take up to a month. Just enough time for them to charge me for another month before I cancel.

Maybe this is just paranoid me talking but I’m not trusting some of what I was told. I’d love to be wrong about this though. Anyone had a similar experience? Was it eventually fixed? How long did that take? My whole neighborhood is waiting to hear how this pans out. So many people are sick to death of Comcast that they may have to abandon Baltimore altogether once most of us jump ship for T-Mobile.

Rant over but I’d love to hear from people who’ve had similar experiences or who may have advice for improving my service.

Thanks,

Matt

I agree.  I am in Massachusetts and Comcast is screwing us big time.  I decided to try Tmob internet and was amazed.  Its just as good with weak signal (2 bars best I can get) as Comcast cable.  I couldn't believe it.   

Reply