Internet App Gives a 500 error on Devices when Amazon Kindle connects to Internet


I recently got a 5G Gateway S1 TMobile Internet for my home.  Using the Internet App and selecting DEVICES to see all devices connected started giving me a “Gateway error code:500”.  I finally figured out this occurred when I connected my Amazon Kindle Fire HD8 to the internet.  The internet connection is fine on the Kindle but the TMobile App gives the above error when trying to access the DEVICES option.  If I turn off the internet connection on the Kindle the DEVICES option works properly again thru the app.  We have 2 Kindles which this issue occurs so it is not an issue with the Kindle.

I am using the Internet App on an iPhone.

Has anyone else had this issue with the TMobile Internet App? 

13 replies

I have the Fire HD8 as well, and can confirm I can reproduce this and have the exact same error code 500 when it is connected to the gateway. The instant I disconnect it, the DEVICES would work. The gateway seems confused about the FIre HD8. 


Thanks for the confirmation!

I can add to this that I have an older 7th Generation HD8 Kindle which does not cause this 500 error.  Looks like the 10th generation model causes the error from my testing.  Since this model started in 2020 I’m guessing we’ll be lucky to see a fix anytime soon.

I did contact support and it is suppose to be sent up the ladder to app development, but I’m not holding my breath.  At present we switch off WIFI on these HD8 10th generation Kindle Fires to look at devices.

I am doing the same for now. I hope they can figure it out! Thanks for making them aware of the issue. I just got the gateway and was confused why it happened til I saw this thread!

After a months frustration and back and forth calls to support i came across this post. We have amazon fire tablets and after i read this i turned the internet off on those devices and it worked. I was finally able to get into my devices on the app. But as soon as the internet was turned back on the first fire tablet the error code popped back up. 


It would be great if you could provide the Kindle Fire generations of your devices. 

I’m glad that my 45+ year career in the IT industry has helped uncover the reason behind this issue.

Sure thing, we have two Amazon fire HD 8 tablets and two Amazon fire HD 10 tablets.


Sagemcom 5688 for T-Mobile home internet gateway here, and I have no Kindle devices. I see the same 500 error in my Android internet app when my desktop PC is powered on (and no error when desktop is powered off). That PC is wired to the gateway Ethernet port.


The 500 error may have to do with identification information sent from your home devices into the devices app. I'm sorry I don't have any other details on this effort, that's all I can offer.

My case suggests that the error isn't just Kindle, isn't WiFi only.

Also experiencing an error code 500 when trying to see connected devices. Thankfully came upon this thread. Although I do not have a Kindle tablet, I DO have a Toshiba Amazon Fire TV. As soon as I disconnected it from the gateway, connected devices showed up. It appears for some reason, Amazon devices have an issue. Although multiple Alexa devices are ok. 

I get the same error code when looking at the Devices tab. I unplugged my Firestick and could see connected devices. As soon as I plug the Firestick back in error code 500 is back. Hopefully T Mobile can fix this.

Sagemcom 5688

I get the error code 500 every time I try to select ‘DEVICES’ on the android app. I discovered this while trying to determine why my home security software starting failing once I switched to T-Mobile. 

I am having same problem but did not occur until I linked a second fire stick to the network. I am going to try disconnecting one at a time.

so has anyone figured out how to fix this issue? 

Same issue here.  I have the Sagemcom Fast 5688W T-Mobile gateway, with a TP-Link Archer C7 router connected to one of the gateway’s gigabit ports.  All my devices connecting through the TP-Link router’s WIFI work fine (including Amazon devices).  But when I switch my Fire TV to the T-Mobile gateway WIFI, I get the Error 500 message on the T-Mobile gateway.  I can connect my Pixel 4A (Android) phone to the T-Mobile gateway WIFI, no problem.  Have not experimented with my other Amazon devices (Fire Tablet, Echo, etc) to see if they cause the same behavior for me.

It’s interesting that my Amazon devices don’t cause any problems if they’re sitting on my TP-Link router’s WIFI.  Hoping the engineers at Sagemcom can figure this one out.