Question

KVD21 WIFI connected with no or weak internet

  • 14 September 2023
  • 3 replies
  • 144 views

Badge

I have had the service for about 10 months started with a consistent 4 bars, everything worked fine for the first 9, recently I started having problems, signal dropped to 3 bars, occasionally 4, ethernet is working with OK speeds (250-290) but WIFI is sometimes connected without internet and when it is connected some sites work, others won’t load.

After several conversations with tech support, they were helpful but only solution they had  was to send me a replacement gateway, another KVD21, it works worse than the original, won’t even connect to the phone App, tried Android and I-pad.  

I asked about one of the  newer gateways which are advertised as faster/better, was told all I could get from tech support was a direct replacement but I could check with local store, seems like a stupid way to provide support, anyway store was willing but all they had was same unit.  I really would have liked to get the new TMO-G4AR with external antenna connections to see if I could get a better signal, kinda hard in my single story home.

Right now I’m thinking only solution is back to Comcast.


3 replies

Userlevel 7
Badge +11

Yeah, sadly many companies are in the point of:

  • Discounts/good gear for ‘new’ customers  (i.e. they have budget to obtain new customers, but not to keep existing)
  • or
  • We have great sales (again same budget) and service to get you started.  Once you’re a customer … if service is poor (or became poor!) there’s no incentive to fix/upgrade.

 

Badge

Just had another discussion with tech support, very nice but informed me again that only new accounts get the new better gateways.  I did have a Sageway for a few days and it worked better, but they made me send it back and sent me another KVD21 which worked as poorly as the original. So they would rather make new customers happy while old customers become former customers.  I just called xfinity, only good thing is thanks to T-Mobile prices xfinity is now a little more reasonable.  It’s a shame because I was very happy with T-mobile until my connection slowed down and the refused to fix it.

Userlevel 7
Badge +11

The main difference would be external antenna for service.  4 bars is good … assuming the advanced cellular metrics also show 5G n41 or 5G n71.

I’d recommend checking those.  I’ve seen 4 bars of LTE + no 5G (prior to T-Mobile rebuilding the tower), and service was good when LTE only and really unusable with 5G (weak from another site) + LTE.

I have the same modem, and its been good for me since last December.  A bit weaker in the summer (leaves) with only ‘good’ service in the ~400Mbps/20Mbps range on n41 + B2 LTE or 170Mbs/50Mbps on the n71 + B66 LTE.

Placing it outside (or opening the window) goes to ‘Very Good’ signal and speeds go up to ~500Mbps/60Mbps on n41 + B2 LTE.

I did check local stores where I am, and they haven’t even heard of the new device.  May be a while (closer to Xmas?)

Also, check with T-Mobile home internet support .. its possible that you’re being “deprioritized” , but that wouldn’t explain why the app won’t connect (factory reset ?)

Reply