Solved

New 5G Gateway - dns issues for Ubuntu (Linux) 22.04

  • 18 March 2023
  • 4 replies
  • 362 views

Badge

I have chromebooks that can access internet correctly using the wifi to 5G gateway.  But desktop can’t access all websites using wired connection to 5G gateway.  For instance, desktop can access google.com, but duckduckgo.com doesn’t resolve.  So I’m expecting there’s something about the dns lookup that is set incorrectly.  what does Ubuntu 22.04 need to be set to in order to get access to all the internet sites?

icon

Best answer by bbqbailey 19 March 2023, 18:45

View original

4 replies

Userlevel 5
Badge +8

@bbqbailey take a look at the following article on wifi settings with Ubuntu. I have a Ubuntu server at home as a Plex server, and it works fine with a ethernet cable. My DNS looks like: 192.168.12.1, 8.8.8.8, 1.1.1.1

https://www.makeuseof.com/connect-to-wifi-network-on-ubuntu-server/

Starting all DNS with the T-Mobile gateway (192.168.12.1) is always a good idea.

Good luck!

Badge

copz1998, thanks for the suggestion.  This didn’t fix the problem, since I was not trying to set up wifi on this desktop.  I just mentioned that my other wifi chromebook devices were working.

 

Thanks again for your help!

 

Badge

I was able to fix my problem.

 

In case someone else has this issue, I wanted to post what I found that lets my desktop work on either the main comcast lan, or my new T-Mobile Home Internet lan.    I switch the cables from my desktop to either lan as needed.

 

How I fixed: on Ubuntu 22.04, go to Settings, Network, Wired 1 (yours may be named something else), settings wheel, ipv6 tab.  Change ‘IPV6 Method’ from ‘Automatic’ to ‘Automatic, DHCP only.

 

I was able to then click between the two selections, in my case “Wired 1” and “Profile 1”, and that case, it toggled my ip address from 192.168.1.208 to 192.168.12.79, and changed the default router from 192.168.1.1 to 192.168.12.1.  

 

If after you changed the settings, it doesn’t work, try restarting the service using:

sudo systemctl restart systemd-resolved.service

 

Thanks everyone for your assistance!

Userlevel 5
Badge +8

@bbqbailey thanks for sharing the fix!

 

Reply