Question

Tech Support Call Wait Times/Slow Speeds

  • 3 November 2020
  • 9 replies
  • 888 views

Badge

Hi all, new T-Mobile Home Internet customer here. Just subscribed to the service last Tuesday and have been closely monitoring speeds. I have yet to get above 4 Mbps with 4-5 bars service as reported by the app. App also confirms that I am on 4G LTE connection. I tried giving support a call today and have been on hold for 2.5 hours without any human interaction. I want to keep the service but don’t see a reason to if my my only other ISP in the area is cheaper and provides faster speeds (albeit not too much faster at 10 Mbps). Anyone else having this experience with reaching support? Should my speeds be this low consistently?


9 replies

Badge

That speed is too low.  You need to report this to support.  I had good luck on their Facebook page when asking about an issue unrelated to home internet.

Turn off WiFi Gateway with slide switch. Wait until all lights are out.  Turn back on.

Badge

@Amos54 This was the first troubleshooting step that I took. I have restarted the gateway completely and have also tried multiple different locations in and around my house, all providing “Excellent” coverage as indicated in the app. 
 

@NikonD7500 Thank you for your input. I didn’t think this was normal but wanted confirmation. I finally got through to support but did not receive clarification on what could be causing this problem.

 

i have continued to monitor speeds and still have the same results. I cap out at ~5 Mbps.

I have been getting around 0.4-10.0 Mbps no matter where i put the gateway in my apartment. In the app the highest connection quality i get is “good” and if it gets that its a shaky 10Mbps. Most of the time the signal is weak. If i take the gateway outside away from any walls i get 30 Mbps download and 40 upload and in the app it says my signal is very good. But still never see excellent signal. I have factory reset the gateway completely multiple times and I still cant get fast speeds inside my place so I think its time for me to cancel. 

Badge

I spent 6 hours on hold yesterday and started my call to TMO about an hour ago this morning and have yet to talk to a human.  At least you have some level of service; I have what is apparently a bad router where the sim card won’t be read at all so i’m paying for completely non-existent service

Userlevel 3
Badge

I was about to recommend this service to friends and neighbors as the first week of service was so much better then my 3MB end-of-the-loop Frontier DSL with speeds ranging from 25mb to 70mb. Sad to report though, for the last week it’s been off/on (the reason for my tech call) and is fairly unusable. Speeds are wildly all over the place from .02mb to 40mb down (up is fine). The first tech after an hour wait time went over several things, but  ]gave up and put in a ticket to the cell tower group and promised to call back the following day. My 2nd call to tech support, when the first never called back as promised had a wait time of over 2.5 hour and could only tell me there’s been no activity on the ticket. This morning speed tests again all over the place, sometimes with no internet at all. I’ve had to put of cancelling my overpriced $50 3mb Frontier DSL until this can be solved. :worried:

Badge

I was about to recommend this service to friends and neighbors as the first week of service was so much better then my 3MB end-of-the-loop Frontier DSL with speeds ranging from 25mb to 70mb. Sad to report though, for the last week it’s been off/on (the reason for my tech call) and is fairly unusable. Speeds are wildly all over the place from .02mb to 40mb down (up is fine). The first tech after an hour wait time went over several things, but  ]gave up and put in a ticket to the cell tower group and promised to call back the following day. My 2nd call to tech support, when the first never called back as promised had a wait time of over 2.5 hour and could only tell me there’s been no activity on the ticket. This morning speed tests again all over the place, sometimes with no internet at all. I’ve had to put of cancelling my overpriced $50 3mb Frontier DSL until this can be solved. :worried:

 

Your comment is very timely as I just got a replacement gateway late last week and set-up the service over the weekend.   Unfortunately, my experience with speeds sounds very similar to yours.    

I’ve found that upload speeds are usually great, typically seeing over 20 Mbps.   However download speeds are only good (> 30 Mbps) between maybe 9PM and 7AM, and in the middle of the day I am frequently seeing rates well under 1 Mbps and huge latency issues.   But, upload speeds are almost always good regardless of time of day.  I tried calling a few times but gave up after about an hour on hold each time since I had way too many other things going on.

I still have my old internet (at over $100/mo) which I had hoped to get rid of, but a this point I can’t.  If I could consistently get around 30 Mbps down I’d probably be fine, but dial-up speeds aren’t going to cut it unfortunately.  I have spent a lot of time moving the device around my house to find an ideal location, but time of day is a much bigger impact on speed than gateway location.  

Good luck with getting to a solution.  Please let us know if your persistence gets you anywhere.

Thanks.     

Same as everyone else. Super slow download speeds; good upload speeds. Support impossible to get to; I have finally hung up after excessively long wait time.

Userlevel 2
Badge

I have been have real problems with downloads.. ping times are sky high and dropping packets.. but i also got 4 bars and great upload speeds.

something is not setup right on their end… the modem itself seems to be working, but traffic is terrible

Reply