Unable to reach site in T-Mobile - cell or home internet

  • 22 October 2023
  • 3 replies


Wondering if anyone can check this out and see if you have the same problem.  I am trying to make Yosemite lodging reservations.  After starting at the NPS website,  I get shuffled off to  That handoff works just fine.


Clicking through to Lodging and selecting any of the options sends me to


This breaks and never goes anywhere.  The message is that the server unexpectedly dropped the connection.  

I have tried this on several computers ( Windows and Mac ), via cell and via TMobile Home Internet with zero success.  Other people have been able to reach this site using different ISPs, so I assume the problem is T-Mobile at least in my area ( northern San Diego county).

Can anyone give me this a shot and let me know?

3 replies

Userlevel 4
Badge +3

You know that second link says the reservation system is off-line for maintenance. 

Userlevel 4
Badge +5

Works fine for me on cell.

Userlevel 4
Badge +6

It worked for me on Windows

Yosemite Valley Lodge in Yosemite National Park CA |