Question

Cannot log in to my t-mobile account on website or in the app. A new customer's frustration.

  • 15 September 2021
  • 4 replies
  • 65 views

Badge

I’m a new customer with T-Mobile and have had nothing but issues trying to get everything working. Spent 5 days trying to switch to t-mobile. I made the mistake of thinking ordering a prepaid plan and home internet from the website would work, but I should’ve just gone to the store.


My current issues relate to trying to log in to my t-mobile account:

  • I set up my t-mobile ID and my home internet is showing in it on the website.
  • I’m trying to add my separate prepaid cell plan account to it.
  • When I do add my cell number, next time I log in, it correctly shows the two accounts and asks me to choose one.
  • When I click on the prepaid account, the little purple circular progress spins and spins. Nothing happens. The javascript console is full of errors, so there are major issues on that page and I doubt it will ever work.
  • When I try the t-mobile app, once again I’m correctly shown my two accounts.
  • In the app, when I click on the home internet account, it goes to a page asking me to log in. I log in, and then it sends me back to the initial page showing my two accounts and asking me to chose one. It goes round and round in a circle and I can never get into either account.
  • I go back to the website and unlink my prepaid account from my t-mobile ID, thinking I can set up a new t-mobile ID just for it.
  • I start creating a new t-mobile ID, and it gets to the part where it asks for my PIN. I enter the correct one and it says it’s wrong.
  • I call 611 from my phone to reset the pin just to be sure, then go back to the website and try setting up the new t-mobile ID. Once again, it complains the PIN is wrong.

 

This is really beyond ridiculous how something as simple as being able to log in to view your account doesn’t work. Does anyone have any suggestions at all?


4 replies

Userlevel 6
Badge +14

What browser are you using?  I don’t have any issues using Edge on Windows 10 and Windows 11.  

Userlevel 2
Badge +1

Aren’t prepaid accounts handled differently from postpaid and home internet accounts?

 

https://prepaid.t-mobile.com/home

 

Badge

What browser are you using?  I don’t have any issues using Edge on Windows 10 and Windows 11.  

 

I’ve tried it on Windows Chrome & Firefox, iOS Chrome & Safari, and MacOS Chrome, Safari, & Firefox, and it’s always the same issue unfortunately. I’m just surprised no one at t-mobile can help. The guys in the store saw the issue firsthand, but they couldn’t fix it either.

Badge

Aren’t prepaid accounts handled differently from postpaid and home internet accounts?

 

https://prepaid.t-mobile.com/home

 

Yes, but you can add multiple accounts under one T-Mobile ID. Whenever I log into my T-Mobile ID, it shows the two accounts separately (home internet and prepaid) and I have to click on one before proceeding.

Whenever I click the prepaid one, it gets stuck and doesn’t load, but the home internet account works. In the app, it also shows the two accounts when I open it, but neither account works.

I’m shocked how hard it is to get something so simple working at t-mobile. Their phone support is clueless and have no idea how to fix this. The guys is the store saw it when I showed them, but they had no ability to fix it.

Reply