Epson Printer will not connect to 5G gateway

  • 16 March 2022
  • 9 replies


My Epson ET-M7120 printer is unable to connect to the 5G Gateway.

9 replies

Having same issue. Any luck yet?


Userlevel 5
Badge +5

Where does it fail and how are you trying to connect? For example if you are trying to use WPS, TMO has no WPS support.


The printer does not see the 5G hub.  Can’t use printer…..

Userlevel 5
Badge +5

Have you contacted Epson support? Your model is fairly new and high end so it should work fine with your TMO router.

One thing you can try is to separate your TMO router wifi into separate 5 and 2.4G SSIDs to see if that helps. Several users have solved their printer connectivity issues this way. You can search on this community on how the separate the wifi SSIDs depending on your TMO router model, but it’s generally pretty clear on the TMO home internet mobile app since it’s one of a few features in setup.


What I found was that the frequency band on the gateway hast to be set at either 2.4ghz or automatic. For some reason the printer doesn't support the 5ghz band alone. 

I had the same problem with my Epson WF-7520.  However, I was reading a thread on a Cannon connection problem and they solved their problem by changing the Gateway 5G default WPA setting to WPA/WPA2.  That person’s complete explanation is below.  Hope that helps someone else.

For my Pixma MG5420, I had to change the WPA version on the Tmobile gateway app (Network tab, select your wifi network, under WPA version, change to WPA/WPA2 from WPA2/WPA3).  Then on the printer, go to Device Settings ->LAN settings, ->wireless lan setup, ->Other setup options, ->Standard setup,->select access point, → Directly enter the access point name, then manually enter your wifi network and the passcode.

Thank you so much. Changing the WPA version to WPA2/WPA3 worked to connect my older Epson printer.

I’ve read the posts about changing the WPA to connect my Epson to the network.  If I do this, does it interfere then with the computers, tvs, etc. that are already connected to my TMobile modem?

I setup the additlonal connection as 2.4g only with wpa2 specifically for my Epson et-2400 to finally work after the router upgrade so my thanks goes to whoever discovered this solution