Solved

How do you get rid of this stupid web guard crap?


Userlevel 1

And it blocks a LOT more than porn.

icon

Best answer by tmo_marissa 29 June 2017, 02:14

@magenta2012879​, we hear you. Based on your plan, it sounds like you're paying a grand a year for service - and that's service you want to work. We'd want it to work even if we charged $50 a year for it, so I get it.

I'm sorry for any confusion in my wording, I could have been more direct when referring you to Care or T-Force.

Without taking a peek at the account side, I can't say for sure if this is an error with the Web Guard functionality on both the app and the site, or an error with your account's PAH provisioning. Whichever it is, we want to get it fixed. If it's the latter, then it's a simple fix on our side to make sure your line has the appropriate permissions. If it's the former and is a system error affecting multiple customers, then we need tickets to be filed with those users' account information included so that our engineering teams can recreate the problem on their side in order to resolve it. Since the Support Community is a public forum, when an issue requires account access to resolve, we need a team like Care or T-Force to help.

I know you're not stoked with the way any of this has played out - from the problem in the beginning to the help we offered here in the thread. I hope you'll give us another chance and reach out to one of our teams that can look into this to get it fixed, though -- because what we want is for you to get what you're paying for.

- Marissa

View original

22 replies

Userlevel 1

I should have noted that when I put in my age verification it always says server error. Do you ever fix your servers? Ever?

Userlevel 5

Eek, @magenta2012879​. We don't want to block whatever you're trying to see as long as it's safe and you're of age! Are you following the steps here: Web Guard Are you trying to remove the restriction through the app or on MyT-Mobile? Where are you bumping into this error message?

- Marissa

Userlevel 1

I am going through your website under profile. When it asks me to verify my age I type in the info, then hit submit, then I get "server error" every single time.

Userlevel 5
Badge +12

Are you postpaid or prepaid?  What plan are you on?  Who is the primary if you are on a family plan?

Userlevel 1

I am the only person. It is the $75 unlimited plan. Why does this even matter? Tell me how to get the stupid age verification server to work. I type in the info and it says server error.

Userlevel 7
Badge +13

Have you tried using the Tmobile app under profiles , family controls and change it from there?

Userlevel 1

I would rather not download an app. Why doesn't the server work?

Userlevel 1

The app does not work either. It will not show my profile once I click on it. It tells me to try again later. You need to fix your system.

Userlevel 1

I tried using the app, but whenever I click profile it twirls that circle about then says "We are currently having trouble with your request. Please wait a few minutes and try again.".... Every time I click profile. Your system does not work.

Userlevel 6
Badge +13

Try using a different browser?  Clear browser cache and cookies?  Most everything T-Mobile-related, be it mobile or desktop is super slow for me always, but I'm usually able to gain access to everything in time and with no error.

Userlevel 5
Badge +12

Are you prepaid?

Userlevel 5

Yowch -- I checked and while we don't have any system issues listed for this functionality at this moment, it sounds like there must be something going on. Kudos to you for trying all the self-management options available, I promise that not being able to complete the change through the web or the app is definitely not the level of convenience we're going for... ideally, both would work just fine, but having both down is a huge bummer. We want to get this fixed for you -- can you Community-2153 so that we can switch the restriction off for you on our side? If reaching out over the phone isn't your thing, you're welcome to reach out to our T-Force team through Twitter (@tmobilehelp) or via Facebook message so that we can verify your account and get you taken care of! I'm sorry you spent the better part of your afternoon trying to get this working -- if you have a little extra time, we'd love to get a ticket filed for you as well. If this is an emerging issue affecting multiple customers, reports to our engineering team help issues climb the priority list and we'd like to get it working ASAP! Thanks again for giving the app a shot as well, and for keeping us updated.

- Marissa

Userlevel 1

No. I have already jumped through enough hoops. Make your fluffy system work. And why does it block gun websites? I mean... this is the most magical system I have seen.

*edited by Marissa to soften language

Userlevel 6
Badge +13

Your attitude sucks. It's worse than mine. No one wants to help you when you're being a doodoo head.

Userlevel 5

@magenta2012879​, we hear you. Based on your plan, it sounds like you're paying a grand a year for service - and that's service you want to work. We'd want it to work even if we charged $50 a year for it, so I get it.

I'm sorry for any confusion in my wording, I could have been more direct when referring you to Care or T-Force.

Without taking a peek at the account side, I can't say for sure if this is an error with the Web Guard functionality on both the app and the site, or an error with your account's PAH provisioning. Whichever it is, we want to get it fixed. If it's the latter, then it's a simple fix on our side to make sure your line has the appropriate permissions. If it's the former and is a system error affecting multiple customers, then we need tickets to be filed with those users' account information included so that our engineering teams can recreate the problem on their side in order to resolve it. Since the Support Community is a public forum, when an issue requires account access to resolve, we need a team like Care or T-Force to help.

I know you're not stoked with the way any of this has played out - from the problem in the beginning to the help we offered here in the thread. I hope you'll give us another chance and reach out to one of our teams that can look into this to get it fixed, though -- because what we want is for you to get what you're paying for.

- Marissa

So, was there ever any resolution to this? I'm having the same problem, google search brought me here. I just get an error on the website when I try to enter my personal information for age verification.

It's especially annoying because it just hangs and then wiped out all my info so I have to re-enter it all to try it a second time.

Attempting to use the mobile app also produces the same error as mentioned above "we are currently having trouble with your request. Please wait a few minutes and try again.". However, waiting several minutes to try again has not proven fruitful.

Userlevel 5

Sorry you're seeing this error too, @cmaines​. We didn't hear back from the OP regarding this issue, but if standard troubleshooting steps (clearing cache/cookies on your web browser, uninstalling and reinstalling the app) don't resolve the matter, this is something we'd need to have you Contact Us about so that we can take a look at the account's Primary Account Holder permissions. If those are already correct, we'll get a ticket filed for the issue so that it can be sent up to our engineering team!

- Marissa

I have the exact same problem with both the website and the app. In general services in the website and app are bad, server timeouts, latency, etc.

Please fix

actually, i just discovered that the correct answer is this:  if you have a prepaid account, you can't turn off web guard using either the website or the app.  what you CAN do is say bye to the stock t-mobile internet app, and start using google chrome as your browser.  web guard doesn't block sites there.  hope this helps some of you!

I have the same identical problem. Web Guard has suddenly appeared on my account and I'm unable to turn it off, it just keeps saying "web server error". I also can't receive text messages on my phone. I'm not sure how this turns itself on, on my account by itself and why text suddenly don't work. There's not an issue with resetting my phone. The customer support person was so incompetent that he just wanted to upgrade my plan. The technical support doesn't answer and I've already reset my phone. Web Guard was never turned on. I make sure that things like that are turned off. Now it turns on by itself and it's impossible to turn off.

We just learned that our particular WebGuard issue--which actually had nothing to do with WebGuard but rendered our smart TVs incapable of connecting to the Internet--was resolved by 1) unplugging the modem, 2) removing the battery from the modem, 3) replacing the battery, 4) plugging in the modem and letting it start up again.

Hope that’s useful to at least some of you.

Had same problem with TMobile Home Internet.  Working fine for a month, then all of a sudden Webguard just started blocking sites -- not just adult sites-- regular sites.  On account profile it says Webguard is disabled.  T-mobile customer service not close to being up to speed on their home internet service “That’s not a valid phone number” or “That’s not a valid account number”.  You have to try to get into T Mobile Home Internet technical support at 844 275-9310 which is, apparently, ‘different’ than the other customer support lines.  But don’t actually try.  Its a 2 hour wait every time.  Also, they use 2-party authentication to change anything in the account online.  Problem is it auto-fills the phone number associated with the modem.  So Tmobile is texting a code to a modem not a cell phone.  Modems cant display a text-- no screen. Can’t change the number online to a different mobile unless its a tmobile mobile phone.  I have sprint mobile and they have supposedly merged but says my sprint number is invalid when I try.

But, we did the old “unplug, remove battery, replace battery, replug” thing and it seemed to fix the problem.  But boy does T-Mobile have a LONG way to go on a) Home Internet Support, and b) Sprint integration.

PS: If you have a sprint mobile, NEVER call into T-Mobile customer support on that device.  They shuffle you over to a ‘different’ support team (assume old Sprint team) who knows NOTHING about T-Mobile Home internet or that it is even a product.  Call from a landline and use your internet account #.

Reply