Usage Overview loads endlessly

When I click on "Usage" the Usage Overview begins to load but never stops. This happens on all my devices. Is the T Mobile site having issues?


Best answer by tmo_amanda 17 July 2019, 23:32

View original

25 replies

Userlevel 3

Hey @kalman1978​!

Is this still happening? I don't show anything going on with the website over the past weekend. If you're still having issues, please let me know if this is only happening on mobile or if you're experiencing it on desktop too. Also, is this going through the T-Mobile app or a browser?

This is happening to me as well. The loading circle just keeps on going endlessly and I cannot see my usage overview on:

PC (Microsoft Edge, Chrome, and Firefox don't work)

My Android Phone (TMO App and Chrome don't work)

My iPad (TMO App and Safari don't work)

I don't know what's going on. The Customer Service people also seem to have no idea what the issue is.

Im having the same problem when i click on usage the usage overview circle never stops or opens so i can see my usage for all 5 of my lines this started happening on friday july 12th its still not working called tmobile several times and put in a ticket also still not fixed i use my usage detail to keep travk of my under age sons calls please fix this problem

Same as all of the above just a continuous turning circle that never ends. Have they fixed this??? Looks like many people are having the same problem, very aggravating that we are now going on day 4 of this. ..

Userlevel 2
Badge +1

I am also having same issue for 3-4 days now. I had messaged a rep who said this is known and is being "worked on". I would like a better update at this point please with an ETA? I was told it doesn't affect all accounts, a relatively small number (whatever that means?). The issue is the same regardless of method used to attempt to access detailed usage whether desktop browser (all), mobile browser, T-mobile App.

Userlevel 2
Badge +1 appears same issue with getting BILL info; just sits there with rotating animation.

Again, similar to USAGE info, occurs from desktop browsers, t-mobile App, etc.

Userlevel 3

Thank you everyone for chiming in and sharing your experience. This is impacting a small amount of users but our app and web team are already on it and working on a permanent fix. In the meantime, it's recommended to call into CARE to get the details needed. While I know this is not ideal to have to call in vs checking on My T-Mobile, this is only temporary. At this time, we do not have an estimated time it will take to get this back up and running.

We have 7 phone lines and none of them is working with usage overview and we had this problem earlier this year.  It's very frustrated that this feature is not working for over 6 months now. Yes, no kidding, over 6 months and none of their technical people are able to resolve it and I called in a few weeks ago to open a new ticket about this issue and still haven't heard back from anyone yet. I am giving up and thinking switching to a different carrier.

Again, this is new to some people here but it has been happening to us for a very long time. T-Mobile people have no idea how to fix it. That is why they cannot give anybody ETA. I just could not believe that no one is able to fix a query to pull in the data stored in the database or maybe T-mobile system didn't save any records therefore there is no data available to pull in so it just keeps looping (nothing to display). The bottom line is T-mobile should not charge their consumers until they got it resolved.

I just joined T-mobile. It is December 6, 2019 and Usage page is not loading for me, just spinning circle. Can somebody at T-mobile escalate this? This is the most basic and necessary feature on every carrier, I used them all and all worked flawlessly - until now.

I am having the same has been happening for weeks now.  I have contacted customer service numerous times with no feedback.  It is very frustrating!

This is still happening...  Customer care has been working on it for the past few days....  still awaiting resolution...

This post was made in may. It is December and its still not fixed smh! T mobile sucks. This is the most simplest service for any carrier.

I agree

They have been "working on it" for months

I just joined t mobile not too long ago and I have the same issue. I am not even sure if it really only impact "small" number of people.

Yep, still not fixed. We just switched to t-mobile a month or so ago and to have this kind of issue is very annoying and to know it's been here for months...I dunno. Not cool.

Trying to use it now and still having issues....

8/11/2020. It’s been one year since the above T-Mobile agent said a permanent solution was being worked on and this is still an issue. 


I also suspect its much more widespread than admitted, as the overwhelmingly vast majority of people rarely if ever check their usage page.  


Still no fix… still endless loading on usage details page on both the app and web page.   Pretty useless bug bug department if you ask me. 

It is still not working. The app or the website does not show usage.

Wow, came here looking for a solution. November 2020 and I'm having this same issue. 

It has been over a year now that the usage oveview feature is still not working (loading endlessly) and none of Tmobile techs are able to figure it out.  This is ridiculous and very wrong. We have 7 lines and none of the acounts is working.  Does anyone here have the contact info of the Tmobile head IT person? I need to talk to him/her to address this overdue issue.  I am paying for this service so I need to have it working period and I already spent countless hours on the phone with the different tech. people and Yes, they were able to duplicate it using my account and guess what? None of them is able resolve it for over a year now!


It was September 27th 2022… I came for answers and quickly realized there were none. We’ve all been dooped. T-Mobile has no plans to help us with this issue. I’ve been told the same as everyone else. The issue should be fixed shortly smh

This problem has not resolved for me: its been trying to load for at least 15 minutes! What is going on? this is horrible