Question

VPN (SonicWall) will not connect over T-mobile 5G Hotspot

  • 24 April 2021
  • 27 replies
  • 10674 views

Userlevel 1
Badge

VPN (SonicWall) will not connect over T-mobile 5G Hotspot 

This vpn works fine with WFI but it will not work with the hotspot

using A71 Samsung 5G phone with T-mobile service and extra downloading (paying extra but not using this because it will not connect to VPN)

VPN software SonicWall

VPN was working a month ago and then the phone did an update and immediately the VPN stopped working

VPN hanging at acquiring ip

I bought this 5G phone as a hotspot for work and now it does not work at all with VPN.  :(

 


27 replies

I found a post about turning off IPv6 on my WiFi connection on my Windows laptop that resolved this issue for me.

The issue I was having was that from my Windows laptop, I was NOT able to VPN into my workplace using my personal hot-spot thru my iphone 12 (I’m running iOS 15.1.1) using TMOBILE.

To resolve the issue, I had to disable IPv6 on my Wireless connection on my laptop.

Do disable IPv6 on my Wireless connection on my Windows laptop I did these steps:

  1. Open “Network and Internet Settings”
  2. Under “Advanced Network Settings”, Click on “Change adapter options”
  3. It will bring up a list of Network connections, double click on the one that says “Wi-Fi”
  4. In the new dialog box, click on “Properties” bottom left, do NOT click on “Wireless Properties”
  5. The next dialog box will have a list of "This connection uses the following items”
  6. Scroll down in that list to find “Internet Protocol Version 6 (TCP/IPv6)”, this will be in the list after the “Internet Protocol Version 4 (TCP/IPv4)”.
  7. Uncheck the box in front of “Internet Protocol Version 6 (TCP/IPv6)”. Leave the IPv4 checked.
  8. Hit “OK”

After I did these steps I was able to use the VPN client (in my case it is the FortiClient VPN) and I was able to successfully VPN thru my hot-spot thru my TMOBILE service.

I also went back and retested using a normal WiFi connection (thru my home network) and everything still worked in that case too.

This works like a charm, quick and easy fix.

I’m having same issue after switching to new iphone 15 (from iphone11). I’m unable to connect to corporate vpn through 5G hotsopt. If I try above steps to turn off the ipv6 in macos i’m unable to connect to the hotspot itself. So looks like T-mobile not support backward IPv4 comparability.

Not sure why T-mobile not fixing this issue as on other provider network we do not have this issue on 5G network.

Reply