Whitelistandregularusage plan? Really?

Userlevel 1

It is truly amazing how some T-Mobile tech support people are so completely useless! After waiting on hold and being subjected to inane music, and a recorded message that tells me how important my call is, and that I have “a team” of support people on my side… I get no answers!

My wife and I have been struggling for two days to set up our new iPhone 12 Pros, and especially trying to configure the dual SIM feature. From in store clerks, to local tech support, to the two levels of 611 tech support - and even to two levels of Apple support - nobody understands how (or even why) one might setup an eSIM. I actually found that now I know more about it than all of the techs that I have spoken with, and was giving them advice!

After all of this, and with a variety of data connectivity issues, I finally got my phone working. My wife’s phone (the second phone on our account) was intermittently dropping, or failing to connect to data. Rather than the “Cellular Plans” option in settings displaying the plan that we have (ONE Plan) it displayed a very odd plan “whitelistandregularusage”. What the heck is that?

We made the mistake of wading back into the T-Mobile tech support muck! Finally, have much time on hold, a dropped call, more time on hold… we finally got to a specialist who claimed that he understood the eSIM process… We laboriously explained the problem over again, and asked him about the “whitelistandregularusage”. His answer was stunningly absurd. He said that he sees that all the time, and that since we bought our phones directly from Apple and not T-Mobile, that this was a defect in the phone, and that we needed to return the phone to Apple for repair, or have them configure it! Talk about pass the buck!

It did not take long on Google to find a forum where people had reported the issue (not on this list unfortunately), but it did not seem to come up with an answer. One poster said that their father had turned off their data! Not really understating, at first, how that might be possible, I went into our T-Mobile account.

Sure enough, my phone showed one add on, but my wife’s showed none! Somehow in this process of setting up the new phones, her data had been turned to “no data”!

I changed the setting, and voila! Problem solved! I am now better equipped than a room full of T-Mobile techs, who, if that cared about learning their product, could have saved me a boatload of time!

Thanks T-Mobile!

16 replies

Thank you very much for this! I just changed my plan to Magenta and somehow my data wasn’t working and just like you, it showed “whitelistandregularusage” instead of Magenta. Thanks to you, I went to my account and sure enough, the data was turned off to “no data” instead of Magenta. I turned it on and now am waiting for it to show on my iPhone. I hope it fixed it. thanks again for sharing. 

Userlevel 7
Badge +16

yeah try to avoid calling in and instead use either Facebook or Twitter to contact TMO..their percentage of actually resolving this is quite a bit higher plus you are starting with tier 2 support unlike calling in where you get tier 1 support.

Thank you for posting this! I was on hold with T-mobile they quoted my wait an entire hour. While waiting, I started googling “whitelist general usage” as well. Eventually I stumbled upon this help post. It did the trick and I got 30 minutes back and a headache worth of convo! We had been working with some T-Mobile reps to help us and they couldn’t figure it out either.

Specifically how were you all able to fix this on your own? I’ve been all over our account online and thru the phone settings and still can’t figure out how to change the Whitelistandregularusage to the One plan

Userlevel 6
Badge +9

Specifically how were you all able to fix this on your own? I’ve been all over our account online and thru the phone settings and still can’t figure out how to change the Whitelistandregularusage to the One plan


I have a different plan, but getting to the setting is probably the same.


Log into your account, select Account, select the phone number under Lines and Devices, click the button "Manage Add-Ons", and deselect "No Data" to another option.



So just to add to this. Last night I was on the phone with tech support. The first person of tech support couldn’t do anything with my whitelist plan issue. She then switched me to the real tech support who had to put me on hold to discuss this with what I believe was going to be super tech support. I was then hung up on and have yet gotta call back. After that I did a goggle search and found this thread. Go figure that T-Mobile tech support can’t answer our question but here sits the answer for the issue. So here it is in a nut shell. 
1- the primary account holder had to login to your T-Mobile app on your phone

2- go to the bottom and tap account. 
3- somewhere on that scream towards the top find a red line that says ad ons 

4- that will show the primary phone and it’s add ons. If  DATA only has a blue dot then scroll down to your plan and tap the empty dot turning it BLUE. Scroll all the way down and tap accept and change. 
5- make sure the plan you tap has the word free next to it as that will be your plan. 
6- you can then check other phones lines on your plan by tapping on the add ons feature and select the phone. I also had to do my sons phone last night. It may take a while for you to notice your plan has changed. To check the function see if you can access the internet and text using lte or 5g

This worked out the problem  and I hope it’s helpful to you. I only wish T-Mobile tech support would copy and paste this to there trouble shooting line for when this error or change is made  


I am having the same issue.  I went into my account and the data was turned off.  I turned it back on and it works for a while and then turns off again.  The “whitelistandregularuser” never changes from my plan even after I turn the data back on.  Any other thoughts?  I had the same run around as everyone else.  T-mobile tells me it is apples and tries to send me there.  I know it is not my phone since everything works fine on wifi.  My data just doesn’t work thru T-mobile.

Thank you for posting! May have fixed my issue, but we’ll have to wait and see.

I checked my account info and my data was mysteriously turned off as well. I also have the “WhitelistAndRegularUsage” listed as my Cellular Plan, which is obviously incorrect. I recently created a new account with an existing T-Mobile number and have had nothing but problems since then.

I have spent over seven hours speaking with the “T-Mobile experts” over the phone and chatting in the app. It is such an archaic experience and a complete waste of time. Each call/chat session lasts a minimum of 30-45 min, most of which is spent being put on hold a dozen or more times and/or listening to them constantly repeat poorly rehearsed phrases like, “I understand you are frustrated with your T-Mobile experience and will do everything in my capable powers to ensure we can find the problem that is currently ailing you at this moment in time. How does that sound to you today, kind sir, kind T-Mobile family member of honor?”

After changing my data to my Essentials plan via the Data/Add-Ons in my T-Mobile account and rebooting my iPhone, I am still seeing “WhitelistAndRegularUsage” as my Cellular Plan in my phone’s Settings, and the data is still not working. 

This helped me narrow down the issue. Still I’m the primary account holder and know I didn’t restrict anything with the lines on my account. Ended up mucking with the online account add-ons and then removed/reinstalled an esim to get things working again -- no tech support assisted, as they said “all the lines appear to be fine”. I know, right?

Had the same whitelist problem. My phone plan changed when I was in Europe.  Don’t know if that had anything to do with causing my data problem.  A 611 tech named Travis got the problem solved in about 2 minutes.  Hoping it’s a one-time problem.

After spending a few hours with Apple tech support and their contractor Geek Squad, I noticed ‘WhitelistAndRegularUsage’ show up on my cell plan.  Contacted T Mobile and the rep was able to delete eSim, then she gave me a new eSim.  WhitelistAndRegularUsage is now gone and I have cell coverage again.  My cell plan now shows Magenta (By the way my cell add on was not turned off like other users)

Same issue, but under Add-Ons nothing shows relating to data. when I sign in as primary on either my iPhone or my husband’s (the phone with the problem). Yesterday T-Mobile (in store) reset the plan to our ONE Plan and it immediately reverted to “whitelist...” in his iPhone settings. Said I had to call Tech Support! Sigh!

**UPDATE: Another site suggested that the data SOC was missing. I called Tech Support (a 10-minute wait!) and they  fixed the issue within another 10 minutes.

Last week my hotspot stopped working.  In addition to many things T-mobile tech support checked, e.g. my plan provisioning, and had me do e.g. network resets, iphone/macbook restarts, etc., to get back online using my iPhone 14 (iOS 17.3.1) hotspot with my Macbook pro (Sonoma 14.3.1), required me to add a new network Location under System Settings > Network ( https://discussions.apple.com/thread/255197504?sortBy=best )  on the MacBook pro. 

It is unclear if this was the last step needed to resolve my issue, or is the only step needed. So try it out early.



I too went to accounts/ add ons, but everything was fine there. I still have whitelist and regular usage as my current subscription but no problems with data! Currently using a standard iPhone 13. Ah well….!

This did not work for me. I have tried everything, called hundreds of times, wiped the phone, deleted eSim, switched plans, switched back to original plan, turned off data, added data back, reset network settings and nothing. Nothing works and no one at T-Mobile can get it fixed. This prevents me from using dual eSims on my iPhone. Guess I will transfer to AT&T. 

Was in a Magenta Plan and upon switching to the Go5G plan, I went a whole day, without service. Couldnt Place calls, didnt receive calls, could not text. Went to TMobile first, immediately thinking it was a Network issue, was essentially sent to Apple with no assistance but to restart my phone.

Apple was more helpful, but deferred to my phone not having the most recent upgrade. I thought this was nonsense, because I know others to refuse to update their phone and can still get phone calls. There was a point after updating the phone, and still not getting any calls or texts that Apple suggested to factory reset, and if that didnt work, to BUY A NEW PHONE. 

In frustration. I backed up my device preparing to reset it myself, and then everything MAGICALLY appeared. Quite honestly, I think there was a lag in transferring my phone service to this new plan, and instead of TMobile addressing this, they non-chalantly sent me away. 

If anyone ever runs into this problem, they should: 

Back up Phone Immediately, Do the Network Reset, Wait Patiently for the Phone to restore 


Or youll fin yourself buying a new phone when you dont need it.