Wifi Calling on Samsung S8 unlocked.

After 2 days trying to restore my wifi calling in my unlocked Samsung S8 I finally figure it out.

I called T-mobile, we tried to reset settings and nothing worked out.

Here's the solution:

Press the Bixby bottom and say: "Turn on the wifi calling"

Best Regards.


11 replies

Userlevel 7
Badge +16

have you tried any of the methods mentioned above ?

Would Samsung A10s or iPhone SE work for wifi calling?

This worked for me also. Apparently the "phone" is actually a "samsung call" app, so all call settings are within the phone app setting, not in the main "settings" menu. Under the "phone" app => settings (3 dots on the upper right corner", there are whole bunch of phone related settings. In my case when I'm oversee, within Wifi call setting, just to be sure, I changed it to "never use cellular network" when making calls, and then change it back to "Wi-Fi preferred".

You can also get to it from the "Phone" app > Settings (the 3 dots on the upper right corner) > Wi-Fi calling.

I'm not just claiming it I've always had wifi calling until this past month since the phone came out, Its  T-Mobile branded unlocked phone on metro pcs and one day the option was just gone from my phone. If doesn't make sense to take away features from a phone that were working fine. I've tried the other solutions and the options are not available. Metro is no help, nor samsung, factory reset didn't fix it either. 

Userlevel 4

Technically WiFi calling is only able to work on branded devices. We have seen situations where people claim they were able to use, but unfortunately because it technically should not work, we don't have any defined steps to provide to make the feature work. 😥


I had somewhat same issue. My S8+ was set to only allow wifi calling. Its an unlocked phone from bestbuy. Tech support had me try multiple things and then said it was a device issue because it wasn't purchased through tmobile....That did not make sense to me because it has always worked. He told me to take into the store or to best buy, and that there was nothing they could do over the phone....

So after looking around I found if you ask Bixby for "call settings" OR go to the phone call icon, then hit the 3 dots in upper corner you'll see settings and then go to wifi calling. All resolved now with no help from tmobile!

Did you ever get it working? I want to get an 8 plus and would prefer unlocked but both T-mobile and Samsung are telling me I won't get wi fi calling and that's the only reason I am considering upgrading from my Galaxy 6


Is your wifi calling still working? I'm seriously thinking about getting one of these phones, but need wifi calling. Thanks.

I too lost Wifi calling randomly on my unlcoked S8 plus two days ago. Samsung support helfully informed me

1) Unlocked phones do not support WiFi calling

2) To reset my phone to factory settings since it was working for me earlier

Insane and useless does not even being to cover that support interaction.

I came across your post (thanks!) and was going to try the bixby option when I finally found the Wifi calling settings on an XDA forum.

Phone/ Dialer (where you select a contact to call) > Context Menu (the three dots on top right corner) > Settings > Wi-Fi calling

Userlevel 3
Badge +13

That should be in the phone or call settings. If the assistant can turn on a function it should be availble to manually turn on and off as well. And isn't Bixby still beta?