Solved

Native Visual Voicemail not working on my brand new Unlocked Pixel 6a phone

  • 24 November 2022
  • 22 replies
  • 2374 views

Badge

I just bought a new Unlocked Pixel 6a phone and my native Visual Voicemail is not working. My Unlocked Pixel 3a native Visual Voicemail worked fine for 3 years and it still works fine as I’ve given this phone to my brother who has the same T-Mobile plan.

I’ve talked to T-Mobile support and so far they haven’t been able to figure out why it’s not working. It appears (see pics) that it’s trying to activate, but never does.

Using the T-Mobile Visual Voicemail App is NOT an option… it is not the same and it doesn’t transcribe the voicemail to text. If this issue can’t be resolved I’ll be forced to change carriers.

 

 

 

icon

Best answer by tidbits 1 December 2022, 00:28

View original

22 replies

Userlevel 7
Badge +14

Have you tried going to the XDA forums to see if they have a workaround?

Userlevel 7
Badge +14

I bought my last 2 Pixel's from Best Buy so maybe someone with the geek squad maybe can help.

I did a Google search of your problem and there's already threads about it.

I’m having this same problem with a Pixel 5a.  Visual voicemail just stopped working.  Nothing I can do to get it back.  Used to work fine but very recently just quit.  Happened to co-incide with a huge network upgrade by TMO on my nearest tower.  I am on Mint mobile but it uses TMO’s network and I am a TMO HI customer as well.  Guess I will try calling Mint to see if they know anything but there are sure a lot of people with this problem out there in forums for this to not be some sort of real issue.

Userlevel 6
Badge +12

Works for me. With the Pixel 7. After initial setup I had an error and all I did was call voicemail and entered my pin and after that the message went away and I was good to go. 

Badge

My voicemail works and it asks for a pin and the pin works its just that visual voicemail no longer activates.  It used to work fine it just stopped recently.  I have reset everything I can think of short of complete phone erase with a new new esim.  But others have tried that and it still didn’t help.  Its like the phone now doesn’t attempt or can’t activate VVM anymore.  Used to before the problem when you rebooted your phone you would see a brief  voicemail indicator for a few seconds while VVM set itself up.  That no longer happens.  Thanks for all the ideas everyone.  Maybe when a few hundred more folks notice this and post it will get more attention.  

 

I actually did a factory reset twice and it didn’t help, so I wouldn’t waste your time. 

I guess I had never set up a voicemail pin. Since my voicemail messages had always come directly to my phone, it wasn’t until my my visual voicemail stopped working that I had to call to get my messages, and I never had to enter a pin number.

I never did understand the area I have outlined in red in this pic. 🙄

 

Badge

BTW… does anyone else often get connection errors when trying to connect to this forum? 🙄

Badge

Why is the not fixed by someone?  If it isn’t a tMobile issue then someone from the company say so to give us something to throw at Google.

If/when it starts working it always breaks when the phone is restarted or a update is pushed.  Until recently once borked it would start working on its own after 2-3 days.  Now as of the update on 6/1/23 it will just not fix itself, been 7 days and the its still there/ “Visual voicemail isn’t working” after a while i’ll get an additional “try again”.  

This is such a joke, how hard can it possibly be.  i see why people use iPhones but it would need to catch on fire for me to go down that path.  I like any good tech challenge as long as there is a solution at the end of the adventure.

Please fix this or if anyone has the fix please share the solution.

 

 

Userlevel 6
Badge +12

I noticed esims have trouble with VVM.  So if you have esim that could be the problem


If you are on regular sim. I seen some people fix the problem in the accepted answer.  Some had to turn off 5G, clear dialer cache, and then open dialer and open vvm.  

I just bought a new Unlocked Pixel 6a phone and my native Visual Voicemail is not working. My Unlocked Pixel 3a native Visual Voicemail worked fine for 3 years and it still works fine as I’ve given this phone to my brother who has the same T-Mobile plan.

I’ve talked to T-Mobile support and so far they haven’t been able to figure out why it’s not working. It appears (see pics) that it’s trying to activate, but never does.

Using the T-Mobile Visual Voicemail App is NOT an option… it is not the same and it doesn’t transcribe the voicemail to text. If this issue can’t be resolved I’ll be forced to change carriers.

 

 

 

Same exact problem. Switched to iPhone and haven’t looked back since.  

I had the problem more often than not on my Pixel 5a.  Sometimes it would activate itself and start working, sometimes it would work while still saying it could not activate. Mostly it would not work and say it couldn't activate.  The 5a recently bricked itself and Google sent me a new 6a.  VVM could not be activated for a week, then turned itself on for 2-3 days.  Now it's saying it can't be activated again, but I received 2 VVMs that I can read under the inactive VVM tab.  Spoke to T-Moble, and they claimed they do not support VVM for prepaid accounts.  First I'm hearing of this, and they don't seem to have written it down anywhere.

I don’t understand why this issue is marked solved. The original report is for Pixal 6a, and the “solution” is it works on Pixal 7. How is that a solution for Pixal 6a owners?

Badge

Have you tried going to the XDA forums to see if they have a workaround?

 

No, I’ve never been there and never heard of the place. I googled it and found their forums and it looks like they are some really geeky people… the kind that mod and root their phones. I’ve talked to “Google” tech support and they have assured me that it’s a T-Mobile issue.

Google Tech support advised me to take it to a T-Mobile store to see if they had any answers, but they couldn’t resolve the problem. The T-Mobile store advised me to take it to Best Buy because they sell Google Unlocked phones and might have an answer.

Thank you very much for your response, and at some point I might post my problem at the XDA forums.

Badge

I bought my last 2 Pixel's from Best Buy so maybe someone with the geek squad maybe can help.

I did a Google search of your problem and there's already threads about it.

 

Thanks, and yes, I’ll probably go there…. after Black Friday! 😁

I just bought a new Unlocked Pixel 6a phone and my native Visual Voicemail is not working. My Unlocked Pixel 3a native Visual Voicemail worked fine for 3 years and it still works fine as I’ve given this phone to my brother who has the same T-Mobile plan.

I’ve talked to T-Mobile support and so far they haven’t been able to figure out why it’s not working. It appears (see pics) that it’s trying to activate, but never does.

Using the T-Mobile Visual Voicemail App is NOT an option… it is not the same and it doesn’t transcribe the voicemail to text. If this issue can’t be resolved I’ll be forced to change carriers.

 

 

 

 

Userlevel 6
Badge +12

Went down on me. I fixed it by dropping to LTE instead of 5G. Then I went back to 5G and it's still sticking so far. 

Badge

I’m having this same problem with a Pixel 5a.  Visual voicemail just stopped working.  Nothing I can do to get it back.  Used to work fine but very recently just quit.  Happened to co-incide with a huge network upgrade by TMO on my nearest tower.  I am on Mint mobile but it uses TMO’s network and I am a TMO HI customer as well.  Guess I will try calling Mint to see if they know anything but there are sure a lot of people with this problem out there in forums for this to not be some sort of real issue.

 

Are you getting the same message (activating voicemail) that I was getting in the top pic that I posted? I kept thinking that it seemed like they were trying to activate it, but it never did.  

It’s obviously a carrier problem because since changing carriers I’m having no problems. Also, it’s weird that I had no problems on my Unlocked Pixel 3a with T-Mobile for the 3 years I had it and after giving it to my Brother he’s having no problems on the same T-Mobile plan that I had. 

Yeah, searching the internet, I found that a lot of people are have this same problem

Good luck! 😉

Yes same exact message.  Activating voicemail just fails now.  It used to work great on Mint but due to another issue I had with TMO upgrading my tower to much faster 5G bands including n41 I had to try changing to a newer SIM.  My older one I had to turn off 5G to keep phone working.  Once I downloaded the new eSIM 5G works much better but still has issues once in a while.  But the new eSIM apparently killed my voicemail.  I am going to try to see if Mint has any ideas but it could be a Google issue just not sure or maybe even a TMO issue.  Been on Mint for almost two years with not a single issue now its just terrible after the tower upgrades.  My wife’s phone a Pixel 3a works perfectly including VVM as it has no 5G capability.  On a positive note however my TMHI gets 650mb/s down and 100ish up now with the upgrades.  Hope someone somewhere figures this out soon.

Badge

During one of my T-Mobile ducissions with their tech support they thought it might be a Google glitch and transferred me to Google Support. When I talked to Google Tech Support they laughed, and said “Voicemail” is a carrier thing and has nothing to do with Google. And like I said, changing carriers solved my problem.

I wonder if your problem has something to do with how the new sim registered your phone?  

Badge

Unfortunately, my visual voicemail problem could not be resolved by T-Mobile and was forced to change carriers. It’s working fine now with Google FI. 

I can’t log in since my account is no longer active, but this is ToddyK

Badge

Works for me. With the Pixel 7. After initial setup I had an error and all I did was call voicemail and entered my pin and after that the message went away and I was good to go. 

Interesting. When I called my voicemail all I got was my messages and never got a prompt to enter my PIN.

 

Userlevel 6
Badge +12

Do you have ask for pin turned on? It may be a requirement now. perhaps?

My voicemail works and it asks for a pin and the pin works its just that visual voicemail no longer activates.  It used to work fine it just stopped recently.  I have reset everything I can think of short of complete phone erase with a new new esim.  But others have tried that and it still didn’t help.  Its like the phone now doesn’t attempt or can’t activate VVM anymore.  Used to before the problem when you rebooted your phone you would see a brief  voicemail indicator for a few seconds while VVM set itself up.  That no longer happens.  Thanks for all the ideas everyone.  Maybe when a few hundred more folks notice this and post it will get more attention.  

Reply