RCS Issues, Google Messages Glitch, Group Message Issues

  • 1 April 2024
  • 7 replies



This is a multifaceted problem that I’ve seen all over various forums, so I am not quite sure if the issue is specifically T-mobile, Google Messages, or something else. I have a Samsung Galaxy S22 running One UI V6.0, Android V14. The last software update was 22Mar2024 and these issues have been occurring for months.

  1. Frequently, in individual message threads or group threads, I will not be able to send or receive messages at all. I will get a single balloon of death that never converts to two balloons, and will not be given the option to send the message as SMS instead. I am connected to RCS, have 5G signal, and available WiFi.
  2. In a group chat with two other Android users (on two other carriers), random numbers join the group, and then leave the group. The other two users do not see this activity. I am the original owner of this phone and have had this specific phone number for about 20y so it is highly unlikely that this is a carryover from a previous owner.
  3. In the same group chat as in #2, I am frequently booted from the group. Sometimes I am notified of this on my side of the group chat and sometimes I am not. Someone has to manually add me back in. This happens at random times, and has been occurring for multiple weeks, so it’s not like one of us got a new version of a messaging app suddenly and it broke the chat.

In other forums, I have seen the following as a “solution” of sorts: turn on airplane mode, force stop Google Messages, delete cache, delete data, restart phone in airplane mode, exercise patience, turn off airplane mode. I have performed this action many, many times. It seems to fix it, sometimes, but doesn’t last very long. This is not a solution.

I’ve also seen performing a factory reset as a “solution.” I have not done this yet because I find it absurdly excessive.

I know I am not the only one in the T-Mobile community to experience this type of behavior. I prefer using Google Messages to Samsung Messages so switching messaging apps is not my favorite solution either. Please advise on appropriate next steps to rectify this situation.

7 replies

Userlevel 6
Badge +12

It's a known issue with RCS itself specifically with Samsung devices. Doesn't matter what carrier, or RCs service provider.


Have to wait until Google, and Samsung figure it out 


Thanks for the reply! So I guess the solution for now is to abandon Android entirely? It is not a Samsung-specific issue either, based on a super fast search for LG, but I didn’t dive in.

Userlevel 6
Badge +12

Just need a Samsung device in the group and it causes the issue. 

The only 2 constants are a Samsung device in the group, and Google Messages.  It gets worse with more Samsung devices.


The only thing that worked for me was to delete my Google account from my Android device and then sign back in. And remember, before you remove your Google account from your Android device, make sure that you have backed up everything. Go into your backup on your phone and make sure everything you care about is checked, especially if you want to save your RCS messages. After the backup, you're going to go into accounts area under setting and remove your account, and then you're going to add your Google account back in. Make sure you have backups of any two-factor authenticator app you have on your phone and make sure you know your Google password before doing so! I know it sounds like a pain, but that's the only thing that worked. And by the way, Google is the entity who told me to do this as I have Google one and have Google support that I'm able to contact.

This issue is absolutely. So tired of it. It's way more than a minor inconvenience and needs fixing immediately. 

My RCS messages are suddenly all unencrypted.  Why?

I was unable to send MMS group texts since Saturday when my Galaxy Fold 3 5G received an update. What finally worked for me was to put the phone in Safe Mode and try to send group texts. It worked in Safe Mofe, so I put the phone back in Normal Mode to start uninstalling apps but it worked in Normal Mode too. Try using Safe Mode, maybe it will work for you too.